Skip to content
Snippets Groups Projects
Commit 82ae7cb2 authored by Daniel Engberg's avatar Daniel Engberg
Browse files

chinese/tin: Remove port

Unmaintained in tree for years and has failed to build (patch stage) for
months
parent d7d7504d
No related branches found
No related tags found
No related merge requests found
......@@ -3389,3 +3389,4 @@ sysutils/datadog-agent||2024-07-13|Has expired: Unfetchable and marked BROKEN fo
converters/i18ntools||2024-07-13|Has expired: Depends on expired converters/tuc
converters/tuc||2024-07-13|Has expired: Dead upstream and unfetchable
sysutils/ipfs-go|sysutils/kubo-go|2024-07-13|Project was renamed upstream
chinese/tin||2024-07-14|Removed, unmaintained and broken for months
......@@ -126,7 +126,6 @@
SUBDIR += sourcehanserif-sc-otf
SUBDIR += sourcehanserif-tc-otf
SUBDIR += taipeisanstc
SUBDIR += tin
SUBDIR += tintin++
SUBDIR += ttf2pt1
SUBDIR += ttfm
......
CATEGORIES= chinese
MAINTAINER= ports@FreeBSD.org
CONFLICTS_INSTALL= tin # bin/metamutt
EXTRA_PATCHES= ${.CURDIR}/files/patch-attrib.c \
${.CURDIR}/files/patch-cook.c \
${.CURDIR}/files/patch-mail.c \
${.CURDIR}/files/patch-init.c
MASTERDIR= ${.CURDIR}/../../news/tin
post-patch: post-patch-zh
post-patch-zh:
${REINPLACE_CMD} -e 's,iso-8859-1,Big5,g' ${WRKSRC}/doc/tin.defaults
.include "${MASTERDIR}/Makefile"
--- src/attrib.c.orig 2015-11-22 01:14:29.000000000 +0100
+++ src/attrib.c 2016-02-21 20:49:48.322143000 +0100
@@ -593,6 +593,9 @@
add_scope("*");
snprintf(buf, sizeof(buf), "%s", "~/.tin/headers");
set_attrib(OPT_ATTRIB_X_HEADERS, "*", "", buf);
+ num = 25;
+ set_attrib(OPT_ATTRIB_MM_NETWORK_CHARSET, "*", "", (char *) &num);
+ set_attrib(OPT_ATTRIB_UNDECLARED_CHARSET, "*", "", "Big5");
add_scope("*sources*");
num = POST_PROC_SHAR;
--- src/cook.c.orig 2015-12-23 19:42:27.000000000 +0100
+++ src/cook.c 2016-02-21 20:50:33.672278000 +0100
@@ -470,7 +470,12 @@
/* convert network to local charset, tex2iso, iso2asc etc. */
ncharset = get_param(part->params, "charset");
+#ifndef CHARSET_CONVERSION
process_charsets(&line, &max_line_len, ncharset ? ncharset : "US-ASCII", tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+#else
+ /* use undeclared charset */
+ process_charsets(&line, &max_line_len, get_param(part->params, "charset") ? get_param(part->params, "charset") : curr_group->attribute->undeclared_charset, tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+#endif
#if defined(MULTIBYTE_ABLE) && !defined(NO_LOCALE)
if (IS_LOCAL_CHARSET("UTF-8"))
--- src/init.c.orig 2014-07-16 00:47:37.352661040 +0800
+++ src/init.c 2014-07-16 00:48:08.424652944 +0800
@@ -361,11 +361,11 @@
#endif /* USE_INVERSE_HACK */
TRUE, /* keep_dead_articles */
POSTED_FILE, /* posted_articles_file */
- FALSE, /* mail_8bit_header */
+ TRUE, /* mail_8bit_header */
FALSE, /* mark_ignore_tags */
TRUE, /* mark_saved_read */
TRUE, /* pos_first_unread */
- FALSE, /* post_8bit_header */
+ TRUE, /* post_8bit_header */
TRUE, /* post_process_view */
#ifndef DISABLE_PRINTING
FALSE, /* print_header */
--- src/mail.c.orig 2014-07-16 00:48:14.918652518 +0800
+++ src/mail.c 2014-07-16 00:48:50.462660253 +0800
@@ -514,7 +514,11 @@
/*
* Protect against invalid character sequences.
*/
+#ifndef CHARSET_CONVERSION
process_charsets(&r, &r_len, "UTF-8", tinrc.mm_local_charset, FALSE);
+#else
+ process_charsets(&r, &r_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : "UTF-8", tinrc.mm_local_charset, FALSE);
+#endif
group->description = convert_to_printable(r, FALSE);
}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment