Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
3
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
7c462175
Verified
Commit
7c462175
authored
9 months ago
by
sunpoet
Browse files
Options
Downloads
Patches
Plain Diff
www/pecl-yar: Update to 2.3.3
Changes:
https://pecl.php.net/package-changelog.php?package=yar
parent
6068934c
Branches
Branches containing commit
Tags
Tags containing commit
No related merge requests found
Changes
3
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
www/pecl-yar/Makefile
+1
-1
1 addition, 1 deletion
www/pecl-yar/Makefile
www/pecl-yar/distinfo
+3
-3
3 additions, 3 deletions
www/pecl-yar/distinfo
www/pecl-yar/files/patch-php82
+0
-47
0 additions, 47 deletions
www/pecl-yar/files/patch-php82
with
4 additions
and
51 deletions
www/pecl-yar/Makefile
+
1
−
1
View file @
7c462175
PORTNAME
=
yar
PORTVERSION
=
2.3.
2
PORTVERSION
=
2.3.
3
CATEGORIES
=
www
MAINTAINER
=
sunpoet@FreeBSD.org
...
...
This diff is collapsed.
Click to expand it.
www/pecl-yar/distinfo
+
3
−
3
View file @
7c462175
TIMESTAMP = 1
653151074
SHA256 (PECL/yar-2.3.
2
.tgz) =
44d7914dcfc16fddb880cac39ba94e8a17b8a29c8567c6a3bdcaee5c78c4a4bd
SIZE (PECL/yar-2.3.
2
.tgz) = 51
288
TIMESTAMP = 1
720022758
SHA256 (PECL/yar-2.3.
3
.tgz) =
e5951c7ac813dbd7dcb5738aa33b74ccdeba8a302a0649cd48affa263017b93a
SIZE (PECL/yar-2.3.
3
.tgz) = 51
333
This diff is collapsed.
Click to expand it.
www/pecl-yar/files/patch-php82
deleted
100644 → 0
+
0
−
47
View file @
6068934c
Obtained from: https://github.com/laruence/yar/pull/177
--- tests/yar.inc.orig 2022-05-18 05:52:56 UTC
+++ tests/yar.inc
@@ -105,17 +105,19 @@
PHP;
function yar_server_cleanup() {
$dir = dirname(__FILE__) . DIRECTORY_SEPARATOR . "htdocs";
- $dp = opendir($dir);
- while (($f = readdir($dp))) {
- if (in_array($f, array('.', '..'))) {
- continue;
+ if (is_dir($dir)) {
+ $dp = opendir($dir);
+ while (($f = readdir($dp))) {
+ if (in_array($f, array('.', '..'))) {
+ continue;
+ }
+ $path = $dir . DIRECTORY_SEPARATOR . $f;
+ if (is_file($path)) {
+ unlink($path);
+ }
}
- $path = $dir . DIRECTORY_SEPARATOR . $f;
- if (is_file($path)) {
- unlink($path);
- }
+ rmdir($dir);
}
- rmdir($dir);
}
/* For TCP */
--- yar_request.c.orig 2022-05-18 05:52:56 UTC
+++ yar_request.c
@@ -34,7 +34,11 @@
yar_request_t *php_yar_request_instance(zend_string *method, zend_array *parameters, void **options) /* {{{ */ {
yar_request_t *request = emalloc(sizeof(yar_request_t));
+#if PHP_VERSION_ID < 80200
if (!BG(mt_rand_is_seeded)) {
+#else
+ if (!RANDOM_G(mt19937_seeded)) {
+#endif
php_mt_srand(GENERATE_SEED());
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment