Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
6
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
77d8b715
Verified
Commit
77d8b715
authored
2 years ago
by
sunpoet
Browse files
Options
Downloads
Patches
Plain Diff
devel/py-nbformat: Update to 5.6.1
Changes:
https://github.com/jupyter/nbformat/blob/main/docs/changelog.rst
parent
81b14d8b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
devel/py-nbformat/Makefile
+8
-2
8 additions, 2 deletions
devel/py-nbformat/Makefile
devel/py-nbformat/distinfo
+3
-3
3 additions, 3 deletions
devel/py-nbformat/distinfo
devel/py-nbformat/files/setup.py
+56
-39
56 additions, 39 deletions
devel/py-nbformat/files/setup.py
with
67 additions
and
44 deletions
devel/py-nbformat/Makefile
+
8
−
2
View file @
77d8b715
PORTNAME
=
nbformat
PORTVERSION
=
5.
5.0
PORTVERSION
=
5.
6.1
CATEGORIES
=
devel python
MASTER_SITES
=
CHEESESHOP
PKGNAMEPREFIX
=
${
PYTHON_PKGNAMEPREFIX
}
...
...
@@ -24,7 +24,13 @@ USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH
=
yes
.
include
<bsd.port.pre.mk>
.if
${PYTHON_REL}
<
30800
RUN_DEPENDS
+=
${
PYTHON_PKGNAMEPREFIX
}
importlib-metadata>
=
3.6:devel/py-importlib-metadata@
${
PY_FLAVOR
}
.
endif
post-patch
:
@${
SED
}
-e
's|%%PORTVERSION%%|
${
PORTVERSION
}
|'
${
FILESDIR
}
/setup.py
>
${
WRKSRC
}
/setup.py
.
include
<bsd.port.mk>
.
include
<bsd.port.
post.
mk>
This diff is collapsed.
Click to expand it.
devel/py-nbformat/distinfo
+
3
−
3
View file @
77d8b715
TIMESTAMP = 166
367307
4
SHA256 (nbformat-5.
5.0
.tar.gz) =
9ebe30e6c3b3e5b47d39ff0a3897a1acf523d2bfafcb4e2d04cdb70f8a66c507
SIZE (nbformat-5.
5.0
.tar.gz) = 1
41188
TIMESTAMP = 166
476820
4
SHA256 (nbformat-5.
6.1
.tar.gz) =
146b5b9969391387c2089256359f5da7c718b1d8a88ba814320273ea410e646e
SIZE (nbformat-5.
6.1
.tar.gz) = 1
36804
This diff is collapsed.
Click to expand it.
devel/py-nbformat/files/setup.py
+
56
−
39
View file @
77d8b715
#
!/usr/bin/env python
#
setup
.py generated by flit for tools that don'
t
y
et
use PEP 517
#
-*- coding: utf-8 -*-
from
setup
tools
impor
t
s
et
up
from
distutils.core
import
setup
packages
=
\
[
'
nbformat
'
,
'
nbformat.corpus
'
,
'
nbformat.corpus.tests
'
,
'
nbformat.v1
'
,
'
nbformat.v2
'
,
'
nbformat.v3
'
,
'
nbformat.v4
'
]
package_data
=
\
{
''
:
[
'
*
'
]}
install_requires
=
\
[
'
fastjsonschema
'
,
'
jsonschema>=2.6
'
,
'
jupyter_core
'
,
'
traitlets>=5.1
'
]
extras_require
=
\
{
'
test
'
:
[
'
check-manifest
'
,
'
testpath
'
,
'
pytest
'
,
'
pre-commit
'
,
'
pep440
'
]}
entry_points
=
\
{
'
console_scripts
'
:
[
'
jupyter-trust =
'
'
nbformat.sign:TrustNotebookApp.launch_instance
'
]}
setup
(
name
=
'
nbformat
'
,
version
=
'
%%PORTVERSION%%
'
,
description
=
'
The Jupyter Notebook format
'
,
author
=
None
,
author_email
=
'
Jupyter Development Team <jupyter@googlegroups.com>
'
,
url
=
None
,
packages
=
packages
,
package_data
=
package_data
,
install_requires
=
install_requires
,
extras_require
=
extras_require
,
entry_points
=
entry_points
,
python_requires
=
'
>=3.7
'
,
)
setup
(
name
=
'
nbformat
'
,
version
=
'
%%PORTVERSION%%
'
,
description
=
'
The Jupyter Notebook format
'
,
long_description
=
'
This package contains the base implementation of the Jupyter Notebook format,
\n
and Python APIs for working with notebooks.
'
,
author_email
=
'
Jupyter Development Team <jupyter@googlegroups.com>
'
,
classifiers
=
[
'
Intended Audience :: Developers
'
,
'
Intended Audience :: Science/Research
'
,
'
Intended Audience :: System Administrators
'
,
'
License :: OSI Approved :: BSD License
'
,
'
Programming Language :: Python
'
,
'
Programming Language :: Python :: 3
'
,
'
Programming Language :: Python :: 3.7
'
,
'
Programming Language :: Python :: 3.8
'
,
'
Programming Language :: Python :: 3.9
'
,
'
Programming Language :: Python :: 3.10
'
,
],
install_requires
=
[
'
fastjsonschema
'
,
'
importlib-metadata>=3.6; python_version <
"
3.8
"'
,
'
jsonschema>=2.6
'
,
'
jupyter-core
'
,
'
traitlets>=5.1
'
,
],
extras_require
=
{
'
test
'
:
[
'
check-manifest
'
,
'
pep440
'
,
'
pre-commit
'
,
'
pytest
'
,
'
testpath
'
,
],
},
entry_points
=
{
'
console_scripts
'
:
[
'
jupyter-trust = nbformat.sign:TrustNotebookApp.launch_instance
'
,
],
},
packages
=
[
'
nbformat
'
,
'
nbformat.corpus
'
,
'
nbformat.corpus.tests
'
,
'
nbformat.v1
'
,
'
nbformat.v2
'
,
'
nbformat.v3
'
,
'
nbformat.v4
'
,
'
tests
'
,
'
tests.v1
'
,
'
tests.v2
'
,
'
tests.v3
'
,
'
tests.v4
'
,
],
)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment