Skip to content
Snippets Groups Projects
Verified Commit 75185660 authored by sunpoet's avatar sunpoet
Browse files

devel/py-optree: Update to 0.14.1

parent 9c8f50d6
Branches
Tags
No related merge requests found
PORTNAME= optree
PORTVERSION= 0.14.0
PORTVERSION= 0.14.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
......
TIMESTAMP = 1738089002
SHA256 (optree-0.14.0.tar.gz) = d2b4b8784f5c7651a899997c9d6d4cd814c4222cd450c76d1fa386b8f5728d61
SIZE (optree-0.14.0.tar.gz) = 158834
TIMESTAMP = 1742070384
SHA256 (optree-0.14.1.tar.gz) = c011c6124d6dcbfceade2d7c4f836eab66ed8cf9ab12f94535b41a71dd734637
SIZE (optree-0.14.1.tar.gz) = 163095
--- pyproject.toml.orig 2024-10-03 13:09:10 UTC
+++ pyproject.toml
@@ -1,7 +1,7 @@
# Package ######################################################################
[build-system]
-requires = ["setuptools", "cmake >= 3.18", "pybind11 >= 2.12"]
+requires = ["setuptools", "pybind11 >= 2.12"]
build-backend = "setuptools.build_meta"
[project]
--- setup.py.orig 2023-11-07 06:45:50 UTC
--- setup.py.orig 2025-03-01 19:39:44 UTC
+++ setup.py
@@ -67,15 +67,6 @@ class cmake_build_ext(build_ext): # noqa: N801
pass
@@ -119,10 +119,6 @@ class cmake_build_ext(build_ext): # noqa: N801
cmake_args.append(f'-Dpybind11_DIR={pybind11.get_cmake_dir()}')
build_args = ['--config', config]
- if (
- 'CMAKE_BUILD_PARALLEL_LEVEL' not in os.environ
- and hasattr(self, 'parallel')
- and self.parallel
- ):
- if 'CMAKE_BUILD_PARALLEL_LEVEL' not in os.environ and bool(getattr(self, 'parallel', 0)):
- build_args.extend(['--parallel', str(self.parallel)])
- else:
- build_args.append('--parallel')
-
build_args.extend(['--target', ext.target, '--'])
try:
@@ -138,7 +134,7 @@ class cmake_build_ext(build_ext): # noqa: N801
with unset_python_path():
self.spawn([cmake, '--version']) # cmake in the parent virtual environment
- self.mkpath(build_temp)
+ self.mkpath(str(build_temp))
with spawn_context():
self.spawn([cmake, '-S', str(ext.source_dir), '-B', str(build_temp), *cmake_args])
self.spawn([cmake, '--build', str(build_temp), *build_args])
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment