Skip to content
Snippets Groups Projects
Commit 715e1407 authored by Dima Panov's avatar Dima Panov
Browse files

net/ceph14: update to 14.2.21 release

Introduce option WITH_TESTS which covers all test/debug tools. Currently disabled due to linking errors

PR:		255763 (based on)
Approved by:	maintainer (implicit)
parent 1effaacb
No related branches found
No related tags found
No related merge requests found
TIMESTAMP = 1597409334
SHA256 (ceph-ceph-v14.2.11_GH0.tar.gz) = 45470f70befab52dbf143224e3e9bfc90870369ae9413677e79f387863e76a80
SIZE (ceph-ceph-v14.2.11_GH0.tar.gz) = 21948721
TIMESTAMP = 1621102521
SHA256 (ceph-ceph-v14.2.21_GH0.tar.gz) = a21743228d64d096119b2a92e871277bec6c60f7d274069c23e5a7c8da7f194a
SIZE (ceph-ceph-v14.2.21_GH0.tar.gz) = 21956991
SHA256 (ceph-ceph-erasure-code-corpus-2d7d78b_GH0.tar.gz) = 8ab8f36f3e0a720c882b8bb4abb3f2e26bd6b025cc263119207f7d2eb3b1e490
SIZE (ceph-ceph-erasure-code-corpus-2d7d78b_GH0.tar.gz) = 3685656
SHA256 (ceph-ceph-object-corpus-e32bf8c_GH0.tar.gz) = 79ff0d1b9f959c9f5264a0dff193105d71885615deaa9c8469902400fd82d214
......@@ -29,5 +29,5 @@ SHA256 (ceph-xxHash-1f40c65_GH0.tar.gz) = 809e06b7493ed01f13c7ba972393a5a6d23dd9
SIZE (ceph-xxHash-1f40c65_GH0.tar.gz) = 25484
SHA256 (facebook-zstd-f4340f4_GH0.tar.gz) = 0db909a46914eb7800bce044b86fcf595451713e56a2b131ace6f70ff25c1c4d
SIZE (facebook-zstd-f4340f4_GH0.tar.gz) = 1619022
SHA256 (ceph-seastar-0cf6aa6_GH0.tar.gz) = 2772b32fbcb0f26c6d1cf07c1fcb9bfef7cdd2fdc41ec21af142d6cb3ff08f38
SIZE (ceph-seastar-0cf6aa6_GH0.tar.gz) = 896598
SHA256 (ceph-spawn-5f4742f_GH0.tar.gz) = c8832724cf3dd873db7c10407404b6cef30fa770902ab446f830902fed21603a
SIZE (ceph-spawn-5f4742f_GH0.tar.gz) = 7319
f7fdb2f52131f54b891a2ec99d8205561242cdaf
v14.2.11
5ef401921d7a88aea18ec7558f7f9374ebd8f5a6
v14.2.21-212-g5ef401921d7
--- src/mgr/ActivePyModules.cc.orig 2021-05-13 17:23:08 UTC
+++ src/mgr/ActivePyModules.cc
@@ -497,7 +497,7 @@ void ActivePyModules::notify_all(const std::string &no
// Send all python calls down a Finisher to avoid blocking
// C++ code, and avoid any potential lock cycles.
dout(15) << "queuing notify to " << name << dendl;
- finisher.queue(new FunctionContext([module, notify_type, notify_id](int r){
+ finisher.queue(new FunctionContext([module = module, notify_type, notify_id](int r){
module->notify(notify_type, notify_id);
}));
}
@@ -516,7 +516,7 @@ void ActivePyModules::notify_all(const LogEntry &log_e
// log_entry: we take a copy because caller's instance is
// probably ephemeral.
dout(15) << "queuing notify (clog) to " << name << dendl;
- finisher.queue(new FunctionContext([module, log_entry](int r){
+ finisher.queue(new FunctionContext([module = module, log_entry](int r){
module->notify_clog(log_entry);
}));
}
@@ -1015,7 +1015,7 @@ void ActivePyModules::config_notify()
// Send all python calls down a Finisher to avoid blocking
// C++ code, and avoid any potential lock cycles.
dout(15) << "notify (config) " << name << dendl;
- finisher.queue(new FunctionContext([module](int r){
+ finisher.queue(new FunctionContext([module = module](int r){
module->config_notify();
}));
}
--- src/os/bluestore/KernelDevice.cc.orig 2021-05-13 17:23:08 UTC
+++ src/os/bluestore/KernelDevice.cc
@@ -67,7 +67,7 @@ int KernelDevice::_lock()
for (;;) {
struct flock fl = { F_WRLCK,
SEEK_SET };
- int r = ::fcntl(fd, F_OFD_SETLK, &fl);
+ int r = ::fcntl(fd, F_SETLK, &fl);
if (r < 0) {
if (errno == EINVAL) {
r = ::flock(fd, LOCK_EX | LOCK_NB);
diff --git a/src/rgw/rgw_main.cc b/src/rgw/rgw_main.cc
index 44609741ed..ebbbd12c01 100644
--- src/rgw/rgw_main.cc
+++ src/rgw/rgw_main.cc
@@ -565,8 +565,8 @@ int main(int argc, const char **argv)
// add a watcher to respond to realm configuration changes
RGWPeriodPusher pusher(store);
RGWFrontendPauser pauser(fes, implicit_tenant_context, &pusher);
- std::optional<RGWRealmReloader> reloader(std::in_place, store,
- service_map_meta, &pauser);
+ auto reloader = std::make_unique<RGWRealmReloader>(store,
+ service_map_meta, &pauser);
RGWRealmWatcher realm_watcher(g_ceph_context, store->svc.zone->get_realm());
realm_watcher.add_watcher(RGWRealmNotify::Reload, *reloader);
--- src/test/libcephfs/lazyio.cc.orig 2020-03-02 17:49:20 UTC
+++ src/test/libcephfs/lazyio.cc
@@ -21,7 +21,12 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <dirent.h>
+#ifdef __linux__
#include <sys/xattr.h>
+#endif
+#ifdef __FreeBSD__
+#include <sys/wait.h>
+#endif
rados_t cluster;
......@@ -6,13 +6,11 @@ It comes with a web based dashboard that cannot be build
into a package but will require the user to install it himself.
To install the dashboard, please execute:
sudo pkg install python2
sudo pkg install npm
sudo pkg install npm-node14
cd ${LOCALBASE}/share/ceph/mgr/dashboard/frontend
chown -R ceph .
ls -asl /var/lib/ceph
chown -R ceph:ceph /var/lib/ceph
sudo -u ceph npm ci
sudo chown -R ceph:ceph .
sudo chown -R ceph:ceph /var/lib/ceph
EOM
}
......
bin/ceph
bin/ceph-authtool
bin/ceph-bluestore-tool
bin/ceph-client-debug
%%TESTS%%bin/ceph-client-debug
bin/ceph-clsinfo
bin/ceph-conf
bin/ceph-coverage
%%TESTS%%bin/ceph-coverage
bin/ceph-crash
bin/ceph-debugpack
%%TESTS%%bin/ceph-debugpack
bin/ceph-dencoder
bin/ceph-diff-sorted
bin/ceph-fuse
......@@ -22,16 +22,16 @@ bin/ceph-post-file
bin/ceph-rbdnamer
bin/ceph-run
bin/ceph-syn
bin/ceph_erasure_code
bin/ceph_erasure_code_benchmark
bin/ceph_kvstorebench
bin/ceph_objectstore_bench
bin/ceph_omapbench
bin/ceph_radosacl
bin/ceph_rgw_jsonparser
bin/ceph_rgw_multiparser
bin/ceph_scratchtool
bin/cephdeduptool
%%TESTS%%bin/ceph_erasure_code
%%TESTS%%bin/ceph_erasure_code_benchmark
%%TESTS%%bin/ceph_kvstorebench
%%TESTS%%bin/ceph_objectstore_bench
%%TESTS%%bin/ceph_omapbench
%%TESTS%%bin/ceph_radosacl
%%TESTS%%bin/ceph_rgw_jsonparser
%%TESTS%%bin/ceph_rgw_multiparser
%%TESTS%%bin/ceph_scratchtool
%%TESTS%%bin/cephdeduptool
bin/cephfs-data-scan
bin/cephfs-journal-tool
bin/cephfs-table-tool
......@@ -81,7 +81,7 @@ include/radosstriper/libradosstriper.hpp
include/rbd/features.h
include/rbd/librbd.h
include/rbd/librbd.hpp
lib/ceph/ceph-monstore-update-crush.sh
%%TESTS%%lib/ceph/ceph-monstore-update-crush.sh
lib/ceph/compressor/libceph_lz4.so
lib/ceph/compressor/libceph_lz4.so.2
lib/ceph/compressor/libceph_lz4.so.2.0.0
......@@ -173,16 +173,6 @@ lib/librgw_admin_user.so.1.0.0
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/listing.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/main.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/prepare.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__pycache__/bluestore.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__pycache__/filestore.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__pycache__/strategies.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/__pycache__/validators.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/bluestore.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/filestore.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/strategies.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/strategies/validators.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/trigger.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/lvm/zap.py
%%PYTHON_SITELIBDIR%%/ceph_volume/devices/raw/__init__.py
......@@ -239,22 +229,16 @@ lib/librgw_admin_user.so.1.0.0
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_activate.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_batch.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_common.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_create.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_deactivate.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_listing.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_prepare.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_trigger.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/__pycache__/test_zap.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/__pycache__/test_bluestore.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/__pycache__/test_filestore.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/__pycache__/test_validate.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/test_bluestore.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/test_filestore.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/strategies/test_validate.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_activate.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_batch.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_common.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_create.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_deactivate.py
%%PYTHON_SITELIBDIR%%/ceph_volume/tests/devices/lvm/test_listing.py
......@@ -379,7 +363,7 @@ man/man8/ceph-bluestore-tool.8.gz
man/man8/ceph-clsinfo.8.gz
man/man8/ceph-conf.8.gz
man/man8/ceph-create-keys.8.gz
man/man8/ceph-debugpack.8.gz
%%TESTS%%man/man8/ceph-debugpack.8.gz
man/man8/ceph-dencoder.8.gz
man/man8/ceph-deploy.8.gz
man/man8/ceph-diff-sorted.8.gz
......@@ -1152,6 +1136,10 @@ sbin/mount.fuse.ceph
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/dimless-binary.directive.spec.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/dimless-binary.directive.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/directives.module.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/form-input-disable.directive.spec.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/form-input-disable.directive.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/form-scope.directive.spec.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/form-scope.directive.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/iops.directive.spec.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/iops.directive.ts
%%DATADIR%%/mgr/dashboard/frontend/src/app/shared/directives/milliseconds.directive.spec.ts
......@@ -1308,7 +1296,6 @@ sbin/mount.fuse.ceph
%%DATADIR%%/mgr/dashboard/frontend/src/jestGlobalMocks.ts
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.cs.xlf
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.de-DE.xlf
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.en-US.xlf
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.es-ES.xlf
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.fr-FR.xlf
%%DATADIR%%/mgr/dashboard/frontend/src/locale/messages.id-ID.xlf
......@@ -1377,6 +1364,7 @@ sbin/mount.fuse.ceph
%%DATADIR%%/mgr/dashboard/tests/helper.py
%%DATADIR%%/mgr/dashboard/tests/test_access_control.py
%%DATADIR%%/mgr/dashboard/tests/test_api_auditing.py
%%DATADIR%%/mgr/dashboard/tests/test_auth.py
%%DATADIR%%/mgr/dashboard/tests/test_ceph_service.py
%%DATADIR%%/mgr/dashboard/tests/test_cephfs.py
%%DATADIR%%/mgr/dashboard/tests/test_controllers.py
......@@ -1591,20 +1579,25 @@ sbin/mount.fuse.ceph
%%DATADIR%%/mgr/volumes/fs/exception.py
%%DATADIR%%/mgr/volumes/fs/fs_util.py
%%DATADIR%%/mgr/volumes/fs/operations/__init__.py
%%DATADIR%%/mgr/volumes/fs/operations/access.py
%%DATADIR%%/mgr/volumes/fs/operations/clone_index.py
%%DATADIR%%/mgr/volumes/fs/operations/group.py
%%DATADIR%%/mgr/volumes/fs/operations/index.py
%%DATADIR%%/mgr/volumes/fs/operations/lock.py
%%DATADIR%%/mgr/volumes/fs/operations/op_sm.py
%%DATADIR%%/mgr/volumes/fs/operations/rankevicter.py
%%DATADIR%%/mgr/volumes/fs/operations/resolver.py
%%DATADIR%%/mgr/volumes/fs/operations/snapshot_util.py
%%DATADIR%%/mgr/volumes/fs/operations/subvolume.py
%%DATADIR%%/mgr/volumes/fs/operations/template.py
%%DATADIR%%/mgr/volumes/fs/operations/trash.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/__init__.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/auth_metadata.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/metadata_manager.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/op_sm.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/subvolume_attrs.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/subvolume_base.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/subvolume_v1.py
%%DATADIR%%/mgr/volumes/fs/operations/versions/subvolume_v2.py
%%DATADIR%%/mgr/volumes/fs/operations/volume.py
%%DATADIR%%/mgr/volumes/fs/purge_queue.py
%%DATADIR%%/mgr/volumes/fs/vol_spec.py
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment