Skip to content
Snippets Groups Projects
Commit 707da9c7 authored by Gleb Popov's avatar Gleb Popov
Browse files

lang/ghc: Update to 8.10.6

parent dcc0bde2
No related branches found
No related tags found
No related merge requests found
......@@ -23,7 +23,7 @@ USES= autoreconf compiler:c11 gmake iconv:patch,translit \
USE_LOCALE= en_US.UTF-8
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} LD=${LD} PATH=${SLAVES_PREFIX}/bin:${PATH}
CONFIGURE_ENV= PATH=${SLAVES_PREFIX}/bin:${PATH}
MAKE_ENV= PATH=${SLAVES_PREFIX}/bin:${PATH}
SUB_FILES= build.mk
......@@ -71,7 +71,7 @@ BOOT_SUB_LIST_OFF= HSC2HS=${BOOT_HSC2HS}
PROFILE_SUB_LIST= WITH_PROFILE="YES"
PROFILE_SUB_LIST_OFF= WITH_PROFILE="NO"
GHC_VERSION= 8.10.5
GHC_VERSION= 8.10.6
CABAL_VERSION= 3.2.1.0
HSCOLOUR_VERSION= 1.24.4
LLVM_VERSION= 10
......@@ -84,6 +84,8 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
CONFIGURE_TARGET= ${GHC_ARCH}-portbld-${OPSYS:tl}
# This version of ncurses is needed by bootstrap compiler
.if ${OSVERSION} > 1300078 && empty(PORT_OPTIONS:MBOOT) && ${ARCH} != powerpc64
BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
......@@ -186,11 +188,6 @@ SLAVES_PREFIX= ${WRKDIR}/slaves_prefix
SLAVES_WRKDIRPREFIX= ${WRKDIR}/slaves_wrkdirprefix
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|; \
s|%%AR%%|${AR}|; \
s|%%LD%%|${LD}|' \
${WRKSRC}/libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs
.if empty(PORT_OPTIONS:MBOOT)
@${REINPLACE_CMD} -e '/^mandir/d' ${BOOT_DIR}/mk/build.mk
@${REINPLACE_CMD} -e '/^infodir/d' ${BOOT_DIR}/mk/build.mk
......
TIMESTAMP = 1622990833
SHA256 (ghc-8.10.5-src.tar.xz) = f10941f16e4fbd98580ab5241b9271bb0851304560c4d5ca127e3b0e20e3076f
SIZE (ghc-8.10.5-src.tar.xz) = 19920148
TIMESTAMP = 1629818779
SHA256 (ghc-8.10.6-src.tar.xz) = 43afba72a533408b42c1492bd047b5e37e5f7204e41a5cedd3182cc841610ce9
SIZE (ghc-8.10.6-src.tar.xz) = 19932832
SHA256 (ghc-8.6.5-boot-amd64-freebsd.tar.xz) = aeaf8c0fee0d83de5088aa7ab92e92ee6999b4830e01e33bf3dd450b115c0208
SIZE (ghc-8.6.5-boot-amd64-freebsd.tar.xz) = 70213260
SHA256 (ghc-8.6.5-boot-i386-freebsd.tar.xz) = 47cc24cdcfa19601bb81a7f5660d1d72fec1110119e8ffe1daa0cddc7959206f
......
--- configure.ac.orig 2018-04-17 19:30:22 UTC
+++ configure.ac
@@ -447,6 +447,9 @@ XCODE_VERSION()
dnl ** Building a cross compiler?
dnl --------------------------------------------------------------
CrossCompiling=NO
+
+build=`echo $build | sed -e 's/amd64-/x86_64-/g; s/armv[[67]]-/arm-/g; s/-freebsd.*$/-freebsd/g'`
+
# If 'host' and 'target' differ, then this means we are building a cross-compiler.
if test "$TargetPlatform" != "$HostPlatform" ; then
CrossCompiling=YES
--- libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs.orig 2017-11-28 16:40:34 UTC
+++ libraries/Cabal/Cabal/Distribution/Simple/Program/Builtin.hs
@@ -59,6 +59,8 @@ import Distribution.Compat.Exception
import Distribution.Verbosity
import Distribution.Version
+import System.FilePath (takeDirectory)
+
import qualified Data.Map as Map
-- ------------------------------------------------------------
@@ -265,11 +267,13 @@ alexProgram = (simpleProgram "alex") {
gccProgram :: Program
gccProgram = (simpleProgram "gcc") {
- programFindVersion = findProgramVersion "-dumpversion" id
- }
+ programFindLocation = \v p -> findProgramOnSearchPath v p "%%CC%%"
+}
arProgram :: Program
-arProgram = simpleProgram "ar"
+arProgram = (simpleProgram "ar") {
+ programFindLocation = \v p -> findProgramOnSearchPath v p "%%AR%%"
+}
stripProgram :: Program
stripProgram = (simpleProgram "strip") {
@@ -337,7 +341,9 @@ greencardProgram :: Program
greencardProgram = simpleProgram "greencard"
ldProgram :: Program
-ldProgram = simpleProgram "ld"
+ldProgram = (simpleProgram "ld") {
+ programFindLocation = \v p -> findProgramOnSearchPath v p "%%LD%%"
+ }
tarProgram :: Program
tarProgram = (simpleProgram "tar") {
--- libraries/base/base.cabal.orig 2021-06-05 13:37:03 UTC
+++ libraries/base/base.cabal
@@ -404,6 +404,9 @@ Library
System.CPUTime.Posix.RUsage
System.CPUTime.Unsupported
+ if os(freebsd)
+ cc-options: -DLIBICONV_PLUG
+
-- We need to set the unit id to base (without a version number)
-- as it's magic.
ghc-options: -this-unit-id base
https://bugs.gentoo.org/792558
From 83407ffc7acc00cc025b9f6ed063add9ab9f9bcc Mon Sep 17 00:00:00 2001
From: Krzysztof Gogolewski <krzysztof.gogolewski@tweag.io>
Date: Fri, 25 Sep 2020 02:52:19 +0200
Subject: [PATCH] Various documentation fixes
* Use r'' in conf.py. This fixes a Sphinx warning:
WARNING: Support for evaluating Python 2 syntax is deprecated and will be removed in Sphinx 4.0. Convert docs/users_guide/conf.py to Python 3 syntax.
--- docs/users_guide/conf.py
+++ docs/users_guide/conf.py
@@ -100,13 +100,13 @@ htmlhelp_basename = 'GHCUsersGuide'
latex_elements = {
'inputenc': '',
'utf8extra': '',
- 'preamble': '''
+ 'preamble': r'''
\usepackage{fontspec}
\usepackage{makeidx}
\setsansfont{DejaVu Sans}
\setromanfont{DejaVu Serif}
\setmonofont{DejaVu Sans Mono}
-\setlength{\\tymin}{45pt}
+\setlength{\tymin}{45pt}
''',
}
This diff is collapsed.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment