Skip to content
Snippets Groups Projects
Commit 6f94e40e authored by Yuri Victorovich's avatar Yuri Victorovich
Browse files

science/openmolcas: Update 22.02 -> 22.06

Also test target is added.
The workaround for the cmake bug when cmake fails to find the
physical memory size is added.
parent 30529d60
No related branches found
No related tags found
No related merge requests found
PORTNAME= openmolcas
DISTVERSION= 22.02
PORTREVISION= 2
DISTVERSION= 22.06
CATEGORIES= science # chemistry
MAINTAINER= yuri@FreeBSD.org
......@@ -11,33 +10,42 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= build breaks: Symbol 'maxfilesize' at (1) has no IMPLICIT type; did you mean 'mxfile'?
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR} \
chemps2:science/chemps2
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/libaec \
libxc.so:science/libxc
USES= cmake fortran python shebangfix
USES= cmake:testing fortran python shebangfix
USE_GCC= yes # see https://gitlab.com/Molcas/OpenMolcas/-/issues/351
USE_GITLAB= yes
GL_ACCOUNT= Molcas
GL_PROJECT= OpenMolcas
GL_COMMIT= f8df69cf87b241a15ebc82d72a8f9a031a385dd4
GL_COMMIT= 17238da5c339c41ddf14ceb88f139d57143d7a14
USE_GITHUB= nodefault
GH_TUPLE= Reference-LAPACK:lapack:aa631b4b:lapack/External/lapack \
ilyak:libefp:7d1ff5fd:libefp/External/efp \
mcodev31:libmsym:0c47befe:libmsym/External/libmsym \
libwfa:libwfa:bbe3392a:libwfa/External/libwfa
SHEBANG_FILES= sbin/help_doc sbin/help_func sbin/help_basis sbin/setup sbin/verify sbin/version
SHEBANG_GLOB= *.py
CMAKE_ON= CHEMPS2 EFPLIB MSYM # TODO GEN1INT - package doesn't install itself, WFA - breaks due to https://gitlab.com/conradsnicta/armadillo-code/-/issues/216
CMAKE_ARGS= -DEXTERNAL_LIBXC:STRING=${LOCALBASE} \
-DFREEBSD_PYTHON_VER:STRING=${PYTHON_VER}
#CMAKE_ON= # for EFPLIB, MSYM see https://gitlab.com/Molcas/OpenMolcas/-/issues/350, for WFA - hdf5 needs updating
CMAKE_OFF= BUILD_TESTING
CMAKE_INSTALL_PREFIX= ${DATADIR} # installed into DATADIR because it doesn't respect UNIX file path conventions, see https://gitlab.com/Molcas/OpenMolcas/-/issues/352
BINARY_ALIAS= cpp=${CPP} # cpp is called from cmake scripts
BINARY_ALIAS+= python3=${PYTHON_CMD} # cpp is called from cmake scripts
post-patch:
# fix python path
@${REINPLACE_CMD} -e "s|'/usr/bin/env python3'|'${PYTHON_CMD}'|" ${WRKSRC}/Tools/pymolcas/export.py
post-install:
# remove unused static libraries, see https://gitlab.com/Molcas/OpenMolcas/-/issues/354
......@@ -45,7 +53,12 @@ post-install:
# remove unnecessary fines
@${RM} ${STAGEDIR}${CMAKE_INSTALL_PREFIX}/CONTRIBUTORS.md
@${RM} ${STAGEDIR}${CMAKE_INSTALL_PREFIX}/LICENSE
# remove empty include directory
@${RMDIR} ${STAGEDIR}${DATADIR}/include
# remove empty doc directory
@${RMDIR} ${STAGEDIR}${DATADIR}/doc
post-test: # A total of 5 test(s) failed, with 3 critical failure(s), see https://gitlab.com/Molcas/OpenMolcas/-/issues/369
@cd ${BUILD_WRKSRC} && ${STAGEDIR}${DATADIR}/pymolcas verify
.include <bsd.port.mk>
TIMESTAMP = 1653368495
TIMESTAMP = 1658693647
SHA256 (Reference-LAPACK-lapack-aa631b4b_GH0.tar.gz) = 04ddd43c8b1bed6447427e9dd2b4dd2ead7e2497d7a8fa5fea7f9b31f52117a2
SIZE (Reference-LAPACK-lapack-aa631b4b_GH0.tar.gz) = 7631245
SHA256 (ilyak-libefp-7d1ff5fd_GH0.tar.gz) = 147ba9713bba4f7587c349fb19ff372c4279f011a009d09bd00ec1ae89dba868
SIZE (ilyak-libefp-7d1ff5fd_GH0.tar.gz) = 5614915
SHA256 (mcodev31-libmsym-0c47befe_GH0.tar.gz) = 6a18fe4e5ff1595b86f30c96b68844951471b0333a2940cc0031feaf963a3dec
SIZE (mcodev31-libmsym-0c47befe_GH0.tar.gz) = 88596
SHA256 (libwfa-libwfa-bbe3392a_GH0.tar.gz) = c130488370ab0df228e532c80223ded3d23d80f04d405c2912588cfcfa05d121
SIZE (libwfa-libwfa-bbe3392a_GH0.tar.gz) = 192935
SHA256 (Molcas-OpenMolcas-f8df69cf87b241a15ebc82d72a8f9a031a385dd4_GL0.tar.gz) = 862ab4e5a76955e67af870c7c1b4344c250784299c5c0363c425a722671a892a
SIZE (Molcas-OpenMolcas-f8df69cf87b241a15ebc82d72a8f9a031a385dd4_GL0.tar.gz) = 38439145
SHA256 (Molcas-OpenMolcas-17238da5c339c41ddf14ceb88f139d57143d7a14_GL0.tar.gz) = e5d47d0624f88c5980a334aab9c8b353c679acbf1f5fb75d93277daf8dd3d18d
SIZE (Molcas-OpenMolcas-17238da5c339c41ddf14ceb88f139d57143d7a14_GL0.tar.gz) = 38467330
--- CMakeLists.txt.orig 2022-05-24 05:51:48 UTC
--- CMakeLists.txt.orig 2022-06-07 08:43:34 UTC
+++ CMakeLists.txt
@@ -48,7 +48,7 @@ find_program (GIT "git")
find_program (PERL "perl")
......@@ -9,3 +9,14 @@
################################################################################
# #
@@ -2375,6 +2375,10 @@ message ("Configuring runtime environment settings:")
cmake_host_system_information (RESULT host_mem QUERY TOTAL_PHYSICAL_MEMORY)
cmake_host_system_information (RESULT host_name QUERY HOSTNAME)
cmake_host_system_information (RESULT host_system QUERY OS_NAME)
+
+# workaround for https://gitlab.kitware.com/cmake/cmake/-/issues/23776
+execute_process(COMMAND sysctl -n hw.physmem OUTPUT_VARIABLE host_mem)
+math (EXPR host_mem "${host_mem}/1024/1024")
# memory/disk default sizes
#==========================
......@@ -137,6 +137,7 @@
%%DATADIR%%/bin/single_aniso.exe
%%DATADIR%%/bin/slapaf.exe
%%DATADIR%%/bin/surfacehop.exe
%%DATADIR%%/bin/symmetrize.exe
%%DATADIR%%/bin/vibrot.exe
%%DATADIR%%/data/MolGUI.prgm
%%DATADIR%%/data/abdata
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment