Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
6
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
6ea42400
Verified
Commit
6ea42400
authored
1 year ago
by
sunpoet
Browse files
Options
Downloads
Patches
Plain Diff
devel/py-awscrt: Update to 0.16.26
Changes:
https://github.com/awslabs/aws-crt-python/releases
parent
5bb0a4a8
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
devel/py-awscrt/Makefile
+1
-1
1 addition, 1 deletion
devel/py-awscrt/Makefile
devel/py-awscrt/distinfo
+3
-3
3 additions, 3 deletions
devel/py-awscrt/distinfo
devel/py-awscrt/files/patch-setup.py
+37
-4
37 additions, 4 deletions
devel/py-awscrt/files/patch-setup.py
with
41 additions
and
8 deletions
devel/py-awscrt/Makefile
+
1
−
1
View file @
6ea42400
PORTNAME
=
awscrt
PORTVERSION
=
0.16.
19
PORTVERSION
=
0.16.
26
CATEGORIES
=
devel python
MASTER_SITES
=
PYPI
PKGNAMEPREFIX
=
${
PYTHON_PKGNAMEPREFIX
}
...
...
This diff is collapsed.
Click to expand it.
devel/py-awscrt/distinfo
+
3
−
3
View file @
6ea42400
TIMESTAMP = 16
85792224
SHA256 (awscrt-0.16.
19
.tar.gz) =
f514febfd9cc2b7afa3d3906cf786189a34837e321cd1fb719fbef00a78f2d65
SIZE (awscrt-0.16.
19
.tar.gz) =
28488666
TIMESTAMP = 16
92211613
SHA256 (awscrt-0.16.
26
.tar.gz) =
1cc8cfa42cd16cb54d8b75417fec0fb038f7318c490209290bdb6c42ad3c2dff
SIZE (awscrt-0.16.
26
.tar.gz) =
31262472
This diff is collapsed.
Click to expand it.
devel/py-awscrt/files/patch-setup.py
+
37
−
4
View file @
6ea42400
---
setup
.
py
.
orig
202
2
-
11
-
09
18
:
39
:
08
UTC
---
setup
.
py
.
orig
202
3
-
07
-
19
00
:
27
:
11
UTC
+++
setup
.
py
@@
-
320
,
7
+
320
,
7
@@
def
awscrt_ext
():
@@
-
14
,
7
+
14
,
6
@@
import
shutil
import
subprocess
import
sys
import
sysconfig
-
from
wheel.bdist_wheel
import
bdist_wheel
def
is_64bit
():
@@
-
283
,
16
+
282
,
6
@@
class
awscrt_build_ext
(
setuptools
.
command
.
build_ext
.
bu
super
().
run
()
-
class
bdist_wheel_abi3
(
bdist_wheel
):
-
def
get_tag
(
self
):
-
python
,
abi
,
plat
=
super
().
get_tag
()
-
if
python
.
startswith
(
"
cp
"
)
and
sys
.
version_info
>=
(
3
,
11
):
-
# on CPython, our wheels are abi3 and compatible back to 3.11
-
return
"
cp311
"
,
"
abi3
"
,
plat
-
-
return
python
,
abi
,
plat
-
-
def
awscrt_ext
():
# fetch the CFLAGS/LDFLAGS from env
extra_compile_args
=
os
.
environ
.
get
(
'
CFLAGS
'
,
''
).
split
()
@@
-
360
,
7
+
349
,
7
@@
def
awscrt_ext
():
# a proper MacOS Universal2 binary. The linker warns us about this,
# but WHATEVER. Building everything twice (x86_64 and arm64) takes too long.
if
not
is_macos_universal2
():
-
extra_link_args
+=
[
'
-Wl,-fatal_warnings
'
]
+
extra_link_args
+=
[
'
-Wl,-fatal-warnings
'
]
return
setuptools
.
Extension
(
'
_awscrt
'
,
if
sys
.
version_info
>=
(
3
,
11
):
define_macros
.
append
((
'
Py_LIMITED_API
'
,
'
0x030B0000
'
))
@@
-
410
,
6
+
399
,
6
@@
setuptools
.
setup
(
],
python_requires
=
'
>=3.7
'
,
ext_modules
=
[
awscrt_ext
()],
-
cmdclass
=
{
'
build_ext
'
:
awscrt_build_ext
,
"
bdist_wheel
"
:
bdist_wheel_abi3
},
+
cmdclass
=
{
'
build_ext
'
:
awscrt_build_ext
},
test_suite
=
'
test
'
,
)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment