Skip to content
Snippets Groups Projects
Commit 6d9b7dea authored by Jack Low's avatar Jack Low Committed by Fernando Apesteguía
Browse files

audio/audacity: Update to 3.2.0

ChangeLog: https://www.audacityteam.org/

PR:		266668
Reported by:	xxjack12xx@gmail.com (maintainer)
parent 2c0375a1
No related branches found
No related tags found
No related merge requests found
PORTNAME= audacity
DISTVERSIONPREFIX= Audacity-
DISTVERSION= 3.1.3
PORTREVISION= 2
DISTVERSION= 3.2.0
CATEGORIES= audio
MAINTAINER= xxjack12xx@gmail.com
......@@ -15,12 +14,14 @@ BUILD_DEPENDS= conan:sysutils/conan
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libexpat.so:textproc/expat2 \
libmp3lame.so:audio/lame \
libmpg123.so:audio/mpg123 \
libopus.so:audio/opus \
libportaudio.so:audio/portaudio \
libportmidi.so:audio/portmidi \
libsndfile.so:audio/libsndfile \
libsoxr.so:audio/libsoxr \
libsqlite3.so:databases/sqlite3 \
libwavpack.so:audio/wavpack \
libuuid.so:misc/e2fsprogs-libuuid
USES= cmake compiler:c++17-lang cpe desktop-file-utils gettext \
......@@ -46,8 +47,9 @@ CMAKE_ARGS= -Daudacity_lib_preference:STRING=system \
-Daudacity_use_wxwidgets:STRING=system \
-Daudacity_use_zlib:STRING=system
CMAKE_ON= audacity_use_pa_oss audacity_obey_system_dependencies
CMAKE_OFF= audacity_has_networking audacity_has_updates_check \
audacity_use_pa_alsa audacity_use_pch
CMAKE_OFF= audacity_has_audiocom_upload audacity_has_networking audacity_has_updates_check \
audacity_use_pa_alsa audacity_use_pch audacity_has_sentry_reporting \
audacity_has_tests audacity_has_vst3
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LV2 MAD \
OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
......
TIMESTAMP = 1640677957
SHA256 (audacity-audacity-Audacity-3.1.3_GH0.tar.gz) = 07aed333a20b8df381d5c0a167840883fff8ef65f5e5f71e654c0925d6c60de8
SIZE (audacity-audacity-Audacity-3.1.3_GH0.tar.gz) = 56500219
TIMESTAMP = 1664238989
SHA256 (audacity-audacity-Audacity-3.2.0_GH0.tar.gz) = b6c3b15607a4925ea2ea5af12db8adaed759481fd1d3f51c5d8d9020171eea61
SIZE (audacity-audacity-Audacity-3.2.0_GH0.tar.gz) = 56964814
--- cmake-proxies/CMakeLists.txt.orig 2022-05-07 05:25:37 UTC
--- cmake-proxies/CMakeLists.txt.orig 2022-09-27 06:14:03 UTC
+++ cmake-proxies/CMakeLists.txt
@@ -103,7 +103,7 @@ add_conan_lib(
@@ -130,7 +130,7 @@ else()
libmad
libmad/0.15.2b@audacity/stable
libmad/0.15.2b-1@
OPTION_NAME libmad
- PKG_CONFIG "mad >= 0.15.0b" # Ubuntu has broken PC file
+ PKG_CONFIG "libmad >= 0.15.0b" # Ubuntu has broken PC file
)
endif()
add_conan_lib(
--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2021-02-04 18:52:51 UTC
--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2022-09-22 16:16:06 UTC
+++ lib-src/libnyquist/nyquist/xlisp/xlisp.h
@@ -172,6 +172,15 @@ extern long ptrtoabs();
@@ -181,6 +181,15 @@ extern long ptrtoabs();
#endif
#endif
......
--- libraries/lib-basic-ui/BasicUI.cpp.orig 2022-09-28 03:57:45 UTC
+++ libraries/lib-basic-ui/BasicUI.cpp
@@ -29,6 +29,7 @@ Paul Licameli
#include <string>
+extern char** environ;
namespace
{
--- src/AboutDialog.cpp.orig 2021-09-22 19:37:04 UTC
--- src/AboutDialog.cpp.orig 2022-09-22 16:16:06 UTC
+++ src/AboutDialog.cpp
@@ -64,7 +64,7 @@ hold information about one contributor to Audacity.
@@ -59,7 +59,7 @@ hold information about one contributor to Audacity.
// RevisionIdent.h may contain #defines like these ones:
//#define REV_LONG "28864acb238cb3ca71dda190a2d93242591dd80e"
//#define REV_TIME "Sun Apr 12 12:40:22 2015 +0100"
......
--- src/CMakeLists.txt.orig 2021-10-28 09:14:30 UTC
+++ src/CMakeLists.txt
@@ -38,7 +38,7 @@ elseif( GIT_FOUND )
else()
# No Git installed and no version data is available.
# Generate an empty file and let AboutDialog do the rest
- file( TOUCH "${_PRVDIR}/RevisionIdent.h" )
+ file( WRITE "${_PRVDIR}/RevisionIdent.h" "\n" )
endif()
# Handle Audio Units option
--- src/MIDIPlay.cpp.orig 2021-10-31 02:53:52 UTC
--- src/MIDIPlay.cpp.orig 2022-09-27 05:35:02 UTC
+++ src/MIDIPlay.cpp
@@ -490,7 +490,7 @@ static double SystemTime(bool usingAlsa)
if (usingAlsa) {
struct timespec now;
// CLOCK_MONOTONIC_RAW is unaffected by NTP or adj-time
- clock_gettime(CLOCK_MONOTONIC_RAW, &now);
+ clock_gettime(CLOCK_REALTIME, &now);
//return now.tv_sec + now.tv_nsec * 0.000000001;
return (now.tv_sec + now.tv_nsec * 0.000000001) - streamStartTime;
}
-#ifdef FreeBSD
+#ifdef __FreeBSD__
clock_gettime(CLOCK_REALTIME, &now);
#else
clock_gettime(CLOCK_MONOTONIC_RAW, &now);
audacity
bin/audacity
lib/audacity/lib-audio-devices.so
lib/audacity/lib-audio-graph.so
lib/audacity/lib-basic-ui.so
lib/audacity/lib-components.so
lib/audacity/lib-exceptions.so
lib/audacity/lib-ffmpeg-support.so
lib/audacity/lib-files.so
lib/audacity/lib-graphics.so
lib/audacity/lib-ipc.so
lib/audacity/lib-math.so
lib/audacity/lib-module-manager.so
lib/audacity/lib-preferences.so
lib/audacity/lib-project-history.so
lib/audacity/lib-project-rate.so
lib/audacity/lib-project.so
lib/audacity/lib-registries.so
lib/audacity/lib-sample-track.so
lib/audacity/lib-screen-geometry.so
lib/audacity/lib-string-utils.so
lib/audacity/lib-strings.so
lib/audacity/lib-theme-resources.so
lib/audacity/lib-theme.so
lib/audacity/lib-track.so
lib/audacity/lib-transactions.so
lib/audacity/lib-utility.so
lib/audacity/lib-uuid.so
lib/audacity/lib-xml.so
lib/audacity/modules/mod-script-pipe.so
share/man/man1/audacity.1.gz
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
%%DATADIR%%/EffectsMenuDefaults.xml
%%DATADIR%%/nyquist/aud-do-support.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
......@@ -159,6 +166,7 @@ share/icons/hicolor/scalable/apps/audacity.svg
%%NLS%%share/locale/vi/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/audacity.mo
share/man/man1/audacity.1.gz
share/metainfo/audacity.appdata.xml
share/mime/packages/audacity.xml
share/pixmaps/audacity.xpm
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment