Skip to content
Snippets Groups Projects
Verified Commit 601fec4a authored by sunpoet's avatar sunpoet
Browse files

www/py-httpcore: Add TRIO option

parent 2ab02c81
No related branches found
No related tags found
No related merge requests found
......@@ -22,13 +22,15 @@ USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
OPTIONS_DEFINE= ASYNCIO HTTP2 SOCKS
OPTIONS_DEFINE= ASYNCIO HTTP2 SOCKS TRIO
OPTIONS_DEFAULT=ASYNCIO HTTP2
ASYNCIO_DESC= Asynchronous support via anyio
HTTP2_DESC= HTTP/2 support
TRIO_DESC= Asynchronous support via trio
ASYNCIO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anyio>=4.0<5.0:devel/py-anyio@${PY_FLAVOR}
HTTP2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h2>=3<5:www/py-h2@${PY_FLAVOR}
SOCKS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}socksio>=1<2:net/py-socksio@${PY_FLAVOR}
TRIO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trio>=0.22.0:net/py-trio@${PY_FLAVOR}
.include <bsd.port.mk>
--- pyproject.toml.orig 2020-02-02 00:00:00 UTC
+++ pyproject.toml
@@ -41,7 +41,7 @@ socks = [
"socksio==1.*",
]
trio = [
- "trio>=0.22.0,<0.23.0",
+ "trio>=0.22.0",
]
asyncio = [
"anyio>=4.0,<5.0",
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment