Skip to content
Snippets Groups Projects
Commit 4f891b06 authored by Yuri Victorovich's avatar Yuri Victorovich
Browse files

New port: textproc/cpp-peglib: C++ header-only PEG (Parsing Expression Grammars) library

parent 220a7739
No related branches found
No related tags found
No related merge requests found
......@@ -103,6 +103,7 @@
SUBDIR += confetti
SUBDIR += confget
SUBDIR += consul-template
SUBDIR += cpp-peglib
SUBDIR += crex
SUBDIR += crimson
SUBDIR += crunch
......
PORTNAME= cpp-peglib
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.7
CATEGORIES= textproc devel
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ header-only PEG (Parsing Expression Grammars) library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++17-lang
USE_GITHUB= yes
GH_ACCOUNT= yhirose
NO_ARCH= yes
PLIST_FILES= include/peglib.h
do-test:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DFREEBSD_BUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
test/test-main
.include <bsd.port.mk>
TIMESTAMP = 1619238419
SHA256 (yhirose-cpp-peglib-v1.3.7_GH0.tar.gz) = 3f68843d442e5013ff927cadc6ae2e2364305fbf30dee287c798b094642124f8
SIZE (yhirose-cpp-peglib-v1.3.7_GH0.tar.gz) = 289691
--- CMakeLists.txt.orig 2021-03-31 01:03:42 UTC
+++ CMakeLists.txt
@@ -17,10 +17,16 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
set(add_link_deps Threads::Threads)
endif()
+if (FREEBSD_BUILD_EXAMPLES)
add_subdirectory(example)
+endif()
+if (FREEBSD_BUILD_LINT)
add_subdirectory(lint)
+endif()
+if (FREEBSD_BUILD_TESTS)
add_subdirectory(test)
enable_testing()
+endif()
install(FILES peglib.h DESTINATION include)
cpp-peglib is a single file C++ header-only PEG (Parsing Expression Grammars)
library.
This library supports the linear-time parsing known as the Packrat parsing.
WWW: https://github.com/yhirose/cpp-peglib
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment