Skip to content
Snippets Groups Projects
Commit 4f1a5f76 authored by Rainer Hurling's avatar Rainer Hurling
Browse files

math/saga: Update to 9.0.0

Major release with serveral features and bugfixes[1]. With some backwards incompatible API changes.

Some of the highlights are:
- Readme added with licensing hints
- Better UTF-8 support
- Add support for sLong datatype
- Several fixes for db_pgsql
- PostgreSQL: support loading geometry collections
- Grid calculator: functions added, better formula parsing
- Grid calculator: expression replacement option added
- Several enhancements to 3D viewer
- Reorganize python files, some Python related fixes
- helper/saga_python_version_tester.py, script added
- Remove qhull dependency

Changelog: https://sourceforge.net/p/saga-gis/wiki/Changelog%209.0.0/attachment/changelog_saga_9.0.0.txt
parent 1e04a4cf
No related branches found
No related tags found
No related merge requests found
PORTNAME= saga
PORTVERSION= 8.5.1
PORTREVISION= 1
PORTVERSION= 9.0.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
......@@ -15,8 +14,7 @@ LICENSE_COMB= multi
BROKEN= requires OpenMP support that is missing on this architecture
.endif
BUILD_DEPENDS= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
swig:devel/swig
BUILD_DEPENDS= swig:devel/swig
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
libgdal.so:graphics/gdal \
......@@ -26,25 +24,27 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopencv_core.so:graphics/opencv \
libpdal_base.so:math/pdal \
libproj.so:graphics/proj \
libqhull_r.so:math/qhull \
libsvm.so:science/libsvm \
libsz.so:science/libaec \
libtiff.so:graphics/tiff
RUN_DEPENDS:= swig:devel/swig
USES= cmake compiler:c++11-lib dos2unix gnome \
USES= cmake compiler:c++14-lang dos2unix gnome \
iconv:wchar_t libtool localbase pkgconfig python
DOS2UNIX_GLOB= *.cpp *.h
USE_LDCONFIG= yes
USE_WX= 3.2+
GIT_TAGNAME= 570fadfa8
GIT_TAGNAME= c059b7db8
CMAKE_ARGS= -DSVM_INCLUDE:PATH=${LOCALBASE}/include/svm.h
CMAKE_ON= WITH_DEV_TOOLS WITH_EXCERCISES WITH_MRMR WITH_SYSTEM_SVM
CMAKE_ON+= CMAKE_VERBOSE_MAKEFILE
CMAKE_ON= CMAKE_VERBOSE_MAKEFILE
CMAKE_ON+= WITH_DEV_TOOLS
CMAKE_ON+= WITH_EXCERCISES
CMAKE_ON+= WITH_MRMR
CMAKE_ON+= WITH_SYSTEM_SVM
CMAKE_OFF= WITH_CLIPPER_ONE
CMAKE_OFF+= WITH_TOOLS_LAS WITH_TRIANGLE
CMAKE_OFF+= WITH_TOOLS_RIEGL
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/saga-gis
......@@ -69,11 +69,6 @@ VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
.include <bsd.port.pre.mk>
# make describe needs them here
CPP= clang-cpp${LLVM_DEFAULT}
CC= clang${LLVM_DEFAULT}
CXX= clang++${LLVM_DEFAULT}
SUB_FILES= pkg-message
post-patch:
......
TIMESTAMP = 1675887783
SHA256 (saga-8.5.1.tar.gz) = 2676749b418081fcf705b88ac6a2e83286b8a57fffaf9b7e99b84c09d028f4e1
SIZE (saga-8.5.1.tar.gz) = 8329350
TIMESTAMP = 1680115702
SHA256 (saga-9.0.0.tar.gz) = 622d33615e919d4cbd9b1eff8d50576b43cec93aa2b0fa851051fe0404e7d986
SIZE (saga-9.0.0.tar.gz) = 8347884
--- CMakeLists.txt.orig 2022-08-28 17:59:56 UTC
--- CMakeLists.txt.orig 2023-03-29 11:00:39 UTC
+++ CMakeLists.txt
@@ -21,6 +21,9 @@ endif()
set(CMAKE_BUILD_TYPE Release)
endif()
@@ -26,6 +26,10 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON CACHE STRING "Th
set(CMAKE_CXX_STANDARD 14 CACHE STRING "C++ standard to be used")
set(CMAKE_CXX_STANDARD_REQUIRED ON CACHE STRING "The C++ standard is required")
+# Get Compiler info for about dialog
+set(COMPILER "${CMAKE_CXX_COMPILER_ID} ${CMAKE_CXX_COMPILER_VERSION}")
+add_definitions(-DCOMPILER="${COMPILER}")
+
# Platform dependant compiler requirements
if(MSVC)
set(CMAKE_CONFIGURATION_TYPES "Debug;Release" CACHE STRING "" FORCE)
......@@ -30,14 +30,14 @@ include/saga/saga_gdi/sgdi_dialog.h
include/saga/saga_gdi/sgdi_helper.h
include/saga/saga_gdi/sgdi_layout_items.h
lib/libsaga_api.so
lib/libsaga_api.so.8
lib/libsaga_api.so.9
lib/libsaga_api.so.%%PORTVERSION%%
lib/libsaga_gdi.so
lib/libsaga_gdi.so.8
lib/libsaga_gdi.so.9
lib/libsaga_gdi.so.%%PORTVERSION%%
%%PYTHON_SITELIBDIR%%/_saga_api.so
%%PYTHON_SITELIBDIR%%/saga.py
%%PYTHON_SITELIBDIR%%/saga_api.py
%%PYTHON_SITELIBDIR%%/saga_helper.py
lib/saga/libclimate_tools.so
lib/saga/libcontrib_perego.so
lib/saga/libdb_odbc.so
......@@ -140,6 +140,8 @@ share/pixmaps/saga.png
@mode 0777
@dir %%DATADIR%%
@mode 0666
%%DATADIR%%/helper/convert2utf-8.bat
%%DATADIR%%/helper/convert2utf-8.py
%%DATADIR%%/helper/doxygen_saga_api_chm
%%DATADIR%%/helper/doxygen_saga_api_html
%%DATADIR%%/helper/make_arcsaga_toolboxes.bat
......@@ -153,22 +155,17 @@ share/pixmaps/saga.png
%%DATADIR%%/helper/make_tools_interface.bat
%%DATADIR%%/helper/make_translation_files.bat
@mode 0755
%%DATADIR%%/python/examples/00_grid_create_dummy.py
%%DATADIR%%/python/examples/01_grid_asc_to_saga.py
%%DATADIR%%/python/examples/02_grid_morphometry.py
%%DATADIR%%/python/examples/03_grid_difference.py
%%DATADIR%%/python/examples/04_grid_contour.py
%%DATADIR%%/python/examples/05_shp2xyz.py
%%DATADIR%%/python/examples/06_xyz2shp.py
%%DATADIR%%/python/examples/07_grid_tpi.py
%%DATADIR%%/python/examples/saga_helper.py
%%DATADIR%%/python/examples/test_all.bat
%%DATADIR%%/helper/saga_python_version_tester.bat
%%DATADIR%%/helper/saga_python_version_tester.py
%%DATADIR%%/python/helpers/print_version.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/environment.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/param_interface.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/tools.py
@mode 0666
%%DATADIR%%/python/saga.py
%%DATADIR%%/python/saga_python_api.txt
%%DATADIR%%/python/saga_python_example.py
%%DATADIR%%/python/saga_python_runner.bat
%%DATADIR%%/python/test_data/test.mgrd
%%DATADIR%%/python/test_data/test.sdat
%%DATADIR%%/python/test_data/test.sgrd
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment