Skip to content
Snippets Groups Projects
Commit 4c711886 authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

graphics/povray36: Remove expired port

2023-09-30 graphics/povray36: No longer supported upstream; use POV-Ray 3.7 instead

PR:		274091
parent a09f6b9a
No related branches found
No related tags found
No related merge requests found
......@@ -7880,3 +7880,4 @@ devel/libtar||2023-09-30|Has expired: Abandonware since 2013 and multiple CVEs o
devel/pear-htmlpurifier||2023-09-30|Has expired: Unfetchable as the pear channel no longer works
devel/pear-channel-htmlpurifier.org||2023-09-30|Has expired: PEAR Channel is no longer functional
devel/pmdk||2023-09-30|Has expired: FreeBSD has been deprecated since 1.13.X and support has been dropped on 2.0
graphics/povray36|graphics/povray37|2023-09-30|Has expired: No longer supported upstream; use POV-Ray 3.7 instead
......@@ -827,7 +827,6 @@
SUBDIR += poppler-utils
SUBDIR += potrace
SUBDIR += povray-meta
SUBDIR += povray36
SUBDIR += povray37
SUBDIR += povray38
SUBDIR += ppmcaption
......
......@@ -12,7 +12,7 @@ NO_BUILD= yes
NO_ARCH= yes
PLIST_FILES= bin/povray
POV_VERSIONS_ALL= 36 37 38
POV_VERSIONS_ALL= 37 38
#By default only the following version will be installed and
#link bin/povray -> bin/povray${DEFAULT_VER} will be created.
DEFAULT_VER?= 37
......
PORTNAME= povray
PORTVERSION= 3.6.1
PORTREVISION= 15
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.povray.org/pub/povray/%SUBDIR%/ \
ftp://ftp.mirrorservice.org/sites/ftp.povray.org/pub/povray/%SUBDIR%/
MASTER_SITE_SUBDIR= Old-Versions/Official-3.62/Unix
PKGNAMESUFFIX= 36
DIST_SUBDIR= povray36
MAINTAINER= bsd@philippost.de
COMMENT= Persistence of Vision Ray Tracer
WWW= https://www.povray.org/
DEPRECATED= No longer supported upstream; use POV-Ray 3.7 instead
EXPIRATION_DATE= 2023-09-30
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= compiler:c11 gmake jpeg tar:bzip2 xorg
USE_XORG= x11
GNU_CONFIGURE= yes
USE_CXXSTD= gnu++98
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-3.6
DATADIR= ${PREFIX}/share/${PORTNAME}-3.6
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if (${ARCH} == "i386" || ${ARCH} == "amd64")
LIB_DEPENDS+= libvgagl.so:graphics/svgalib
.endif
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
.if (${ARCH} == "i386" && !${ARCH} == "amd64" )
CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
CXXFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
CONFIGURE_ARGS= --disable-optimiz
.endif
CONFIGURE_ARGS+= --x-includes="${LOCALBASE}/include" --includedir=${LOCALBASE} \
CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -L${LOCALBASE}/lib" \
LDFLAGS="-L${LOCALBASE}/lib" \
COMPILED_BY=${HOSTARCH}-portbld-${OPSYS:tl}-${OSREL:R} \
--program-transform-name='s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/'
.include <bsd.port.post.mk>
SHA256 (povray36/povray-3.6.1.tar.bz2) = 4e8a7fecd44807343b6867e1f2440aa0e09613d6d69a7385ac48f4e5e7737a73
SIZE (povray36/povray-3.6.1.tar.bz2) = 8200160
--- Makefile.in~ 2004-08-03 08:20:09.000000000 +0900
+++ Makefile.in 2013-03-05 11:42:15.000000000 +0900
@@ -813,17 +813,17 @@
for f in $$filelist ; do \
$(INSTALL_DATA) $(top_srcdir)/doc/$$f $(DESTDIR)$(povdocdir)/$$f ; \
done
- @echo "Copying user configuration and INI files..."; \
- $(mkinstalldirs) $(povconfuser); \
- filelist='povray.conf povray.ini'; \
- for f in $$filelist ; do \
- if test -e $(povconfuser)/$$f; then \
- echo "Creating backup of $(povconfuser)/$$f"; \
- mv -f $(povconfuser)/$$f $(povconfuser)/$$f.bak; \
- fi; \
- done; \
- $(INSTALL_DATA) $(top_srcdir)/povray.conf $(povconfuser)/povray.conf ; \
- $(INSTALL_DATA) $(top_builddir)/povray.ini $(povconfuser)/povray.ini
+# @echo "Copying user configuration and INI files..."; \
+# $(mkinstalldirs) $(povconfuser); \
+# filelist='povray.conf povray.ini'; \
+# for f in $$filelist ; do \
+# if test -e $(povconfuser)/$$f; then \
+# echo "Creating backup of $(povconfuser)/$$f"; \
+# mv -f $(povconfuser)/$$f $(povconfuser)/$$f.bak; \
+# fi; \
+# done; \
+# $(INSTALL_DATA) $(top_srcdir)/povray.conf $(povconfuser)/povray.conf ; \
+# $(INSTALL_DATA) $(top_builddir)/povray.ini $(povconfuser)/povray.ini
# For 'make uninstall' we remove the whole POV-Ray data directory.
# We have to use uninstall-local and not uninstall-data-local.
This diff is collapsed.
The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
photo-realistic images using a rendering technique called ray-tracing. It
reads in a text file containing information describing the objects and
lighting in a scene and generates an image of that scene from the view point
of a camera also described in the text file. Ray-tracing is not a fast
process by any means, but it produces very high quality images with realistic
reflections, shading, perspective and other effects.
This diff is collapsed.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment