Skip to content
Snippets Groups Projects
Commit 4a8a17c8 authored by Gleb Popov's avatar Gleb Popov
Browse files

multimedia/gstreamer1: Update to 1.22, new stable branch.

PR:		269895
Exp-run by:	antoine
Sponsored by:   Serenity Cybersecurity, LLC
parent d3cc1971
No related branches found
No related tags found
No related merge requests found
Showing
with 132 additions and 57 deletions
......@@ -35,6 +35,16 @@ include/gstreamer-%%VERSION%%/gst/vulkan/vulkan.h
include/gstreamer-%%VERSION%%/gst/vulkan/vulkan_fwd.h
include/gstreamer-%%VERSION%%/gst/vulkan/wayland/gstvkdisplay_wayland.h
include/gstreamer-%%VERSION%%/gst/vulkan/wayland/wayland.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwl_fwd.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlbuffer.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlcontext.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwldisplay.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwllinuxdmabuf.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlshmallocator.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlvideobufferpool.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlvideoformat.h
include/gstreamer-%%VERSION%%/gst/wayland/gstwlwindow.h
include/gstreamer-%%VERSION%%/gst/wayland/wayland-prelude.h
include/gstreamer-%%VERSION%%/gst/wayland/wayland.h
lib/girepository-%%VERSION%%/GstVulkan-%%VERSION%%.typelib
lib/girepository-%%VERSION%%/GstVulkanWayland-%%VERSION%%.typelib
......
......@@ -33,6 +33,7 @@ BAD_GST_ENABLED_PLUGINS=accurip \
codecalpha \
codecparsers \
codecs \
codectimestamper \
coloreffects \
data \
debugutils \
......
--- data/meson.build.orig 2022-09-05 21:41:46 UTC
--- data/meson.build.orig 2023-01-23 19:29:34 UTC
+++ data/meson.build
@@ -1,3 +1,4 @@
+if get_option('data').enabled()
encoding_targetsdir = join_paths(get_option('datadir'),
'gstreamer-' + api_version, 'encoding-profiles')
@@ -21,3 +22,4 @@ foreach path_targets : encoding_targets
etargets = path_targets.get(1)
install_data(sources: etargets, install_dir: dir)
endforeach
@@ -28,3 +29,4 @@ meson.add_devenv(env)
env = environment()
env.prepend('GST_ENCODING_TARGET_PATH', srcdirs)
meson.add_devenv(env)
+endif
--- ext/webrtc/meson.build.orig 2023-01-23 19:29:34 UTC
+++ ext/webrtc/meson.build
@@ -12,6 +12,10 @@ webrtc_sources = [
'webrtcdatachannel.c',
]
+if not is_variable('libgstwebrtcnice_dep')
+ libgstwebrtcnice_dep=cc.find_library('gstwebrtcnice-1.0', required : true)
+endif
+
webrtc_option = get_option('webrtc').require(
libgstwebrtcnice_dep.found(), error_message: 'webrtc plugin requires libgstwebrtcnice.')
if webrtc_option.disabled()
--- ext/zxing/gstzxing.cpp.orig 2022-12-19 23:34:46 UTC
--- ext/zxing/gstzxing.cpp.orig 2023-01-23 19:29:34 UTC
+++ ext/zxing/gstzxing.cpp
@@ -368,8 +368,8 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter
auto result = ReadBarcode ({(unsigned char *)data, width, height, zxing->image_format}, hints);
@@ -369,7 +369,7 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter
if (result.isValid ()) {
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
- TextUtfEncoding::ToUtf8 (result.text ()).c_str (),
result.text ().c_str (),
- ToString (result.format ()));
+ result.text ().c_str (),
+ ToString (result.format ()).c_str());
} else {
goto out;
}
@@ -394,9 +394,9 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter
@@ -394,7 +394,7 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter
"timestamp", G_TYPE_UINT64, timestamp,
"stream-time", G_TYPE_UINT64, stream_time,
"running-time", G_TYPE_UINT64, running_time,
- "type", G_TYPE_STRING, ToString (result.format ()),
+ "type", G_TYPE_STRING, ToString (result.format ()).c_str(),
"symbol", G_TYPE_STRING,
- TextUtfEncoding::ToUtf8 (result.text ()).c_str (), NULL);
+ result.text ().c_str (), NULL);
result.text ().c_str (), NULL);
if (zxing->attach_frame) {
/* create a sample from image */
--- ext/zxing/meson.build.orig 2022-12-19 23:34:46 UTC
+++ ext/zxing/meson.build
@@ -2,16 +2,17 @@ zxing_sources = [
'gstzxing.cpp',
'gstzxingplugin.c',
]
-zxing_dep = dependency('zxing', version : '>= 1.1.1', required : get_option('zxing'))
+zxing_dep = dependency('zxing', version : '>= 1.4.0', required : get_option('zxing'))
if zxing_dep.found()
gstzxing = library('gstzxing',
zxing_sources,
c_args : gst_plugins_bad_args,
+ cpp_args: '-DZX_USE_UTF8',
include_directories : [configinc],
dependencies : [gstvideo_dep, zxing_dep],
install : true,
install_dir : plugins_install_dir,
- override_options : ['cpp_std=c++11'],
+ override_options : ['cpp_std=c++17'],
)
pkgconfig.generate(gstzxing, install_dir : plugins_pkgconfig_install_dir)
plugins += [gstzxing]
--- gst-libs/gst/codecparsers/meson.build.orig 2022-09-05 20:42:22 UTC
--- gst-libs/gst/codecparsers/meson.build.orig 2023-01-23 19:29:34 UTC
+++ gst-libs/gst/codecparsers/meson.build
@@ -1,3 +1,4 @@
+if get_option('codecparsers').enabled()
codecparser_sources = files([
'gstjpeg2000sampling.c',
'gstjpegparser.c',
@@ -69,3 +70,4 @@ gstcodecparsers_dep = declare_dependency(link_with : g
@@ -71,3 +72,4 @@ meson.override_dependency(pkg_name, gstcodecparsers_de
libraries += [[pkg_name, {'lib': gstcodecparsers}]]
gst_libraries += [[pkg_name, {'lib': gstcodecparsers}]]
meson.override_dependency(pkg_name, gstcodecparsers_dep)
+endif
--- gst-libs/gst/interfaces/meson.build.orig 2022-09-05 21:08:24 UTC
--- gst-libs/gst/interfaces/meson.build.orig 2023-01-23 19:29:34 UTC
+++ gst-libs/gst/interfaces/meson.build
@@ -1,3 +1,4 @@
+if get_option('interfaces').enabled()
photography_sources = ['photography.c']
photo_headers = ['photography.h', 'photography-prelude.h']
install_headers(photo_headers, subdir : 'gstreamer-1.0/gst/interfaces')
@@ -40,3 +41,4 @@ gstphotography_dep = declare_dependency(link_with : gs
@@ -40,3 +41,4 @@ meson.override_dependency(pkg_name, gstphotography_dep
libraries += [[pkg_name, {'lib': gstphotography}]]
gst_libraries += [[pkg_name, {'lib': gstphotography}]]
meson.override_dependency(pkg_name, gstphotography_dep)
+endif
--- gst-libs/gst/uridownloader/meson.build.orig 2022-09-05 21:20:17 UTC
--- gst-libs/gst/uridownloader/meson.build.orig 2023-01-23 19:29:34 UTC
+++ gst-libs/gst/uridownloader/meson.build
@@ -1,3 +1,4 @@
+if get_option('uridownloader').enabled()
urid_sources = [
'gstfragment.c',
'gsturidownloader.c',
@@ -27,4 +28,5 @@ gsturidownloader_dep = declare_dependency(link_with :
@@ -27,4 +28,5 @@ gst_libraries += [[pkg_name, {'lib': gsturidownloader}
dependencies : [gstbase_dep])
libraries += [[pkg_name, {'lib': gsturidownloader}]]
gst_libraries += [[pkg_name, {'lib': gsturidownloader}]]
-meson.override_dependency(pkg_name, gsturidownloader_dep)
\ No newline at end of file
+meson.override_dependency(pkg_name, gsturidownloader_dep)
......
--- gst-libs/gst/va/meson.build.orig 2023-01-23 19:29:34 UTC
+++ gst-libs/gst/va/meson.build
@@ -27,7 +27,7 @@ gstva_dep = dependency('', required : false)
gstva_dep = dependency('', required : false)
-if host_system != 'linux'
+if get_option('skip_gstva')
subdir_done()
endif
--- gst-libs/gst/webrtc/meson.build.orig 2022-09-05 21:22:10 UTC
--- gst-libs/gst/webrtc/meson.build.orig 2023-01-23 19:29:34 UTC
+++ gst-libs/gst/webrtc/meson.build
@@ -1,3 +1,4 @@
+if get_option('webrtc').enabled()
webrtc_sources = files([
'dtlstransport.c',
'icetransport.c',
@@ -95,3 +96,4 @@ gstwebrtc_dep = declare_dependency(link_with: gstwebrt
dependencies: gstwebrtc_dependencies)
'ice.c',
@@ -102,4 +103,5 @@ meson.override_dependency(pkg_name, gstwebrtc_dep)
meson.override_dependency(pkg_name, gstwebrtc_dep)
-subdir('nice')
\ No newline at end of file
+subdir('nice')
+endif
--- gst/codectimestamper/meson.build.orig 2023-02-28 08:03:28 UTC
+++ gst/codectimestamper/meson.build
@@ -9,7 +9,8 @@ gstcodectimestamper = library('gstcodectimestamper',
codectimestamper_sources,
c_args : gst_plugins_bad_args + [ '-DGST_USE_UNSTABLE_API' ],
include_directories : [configinc],
- dependencies : [gstcodecparsers_dep, gstbase_dep, gstvideo_dep],
+ dependencies : [dependency('gstreamer-codecparsers-1.0', required : true),
+ gstbase_dep, gstvideo_dep],
install : true,
install_dir : plugins_install_dir,
)
--- meson_options.txt.orig 2022-09-04 20:24:08 UTC
--- meson_options.txt.orig 2023-01-23 19:29:34 UTC
+++ meson_options.txt
@@ -1,5 +1,39 @@
@@ -1,5 +1,41 @@ option('gst_play_tests', type: 'boolean', value: false
option('gst_play_tests', type: 'boolean', value: false,
description: 'Enable GstPlay tests that need network access')
+option('adaptivedemux', type: 'feature', value: 'auto',
......@@ -37,6 +37,8 @@
+ description: 'data lib')
+option('pkgconfig', type: 'feature', value: 'auto',
+ description: 'pkgconfig lib')
+option('skip_gstva', type: 'boolean', value: true,
+ description: 'skip building gst-libs/gst/va, used for multimedia/gstreamer1-vaapi')
# Feature options for plugins without external deps
option('accurip', type : 'feature', value : 'auto')
--- tests/examples/meson.build.orig 2022-09-13 22:41:40 UTC
--- tests/examples/meson.build.orig 2023-01-23 19:29:34 UTC
+++ tests/examples/meson.build
@@ -1,20 +1,54 @@
@@ -1,24 +1,66 @@
-subdir('audiomixmatrix')
-subdir('avsamplesink')
-subdir('camerabin2')
-subdir('codecparsers')
-subdir('codecs')
-subdir('d3d11')
-subdir('directfb')
-subdir('gtk')
-subdir('ipcpipeline')
-subdir('mediafoundation')
-subdir('mpegts')
-subdir('msdk')
-subdir('mxf')
-subdir('nvcodec')
-subdir('opencv', if_found: opencv_dep)
-subdir('qsv')
-subdir('uvch264')
-subdir('va')
-subdir('waylandsink')
......@@ -30,15 +34,24 @@
+if get_option('codecparsers').enabled()
+ subdir('codecparsers')
+endif
+if get_option('codecs').enabled()
+ subdir('codecs')
+endif
+if get_option('d3d11').enabled()
+ subdir('d3d11')
+endif
+if get_option('directfb').enabled()
+ subdir('directfb')
+endif
+if get_option('gtk3').enabled()
+ subdir('gtk')
+endif
+if get_option('ipcpipeline').enabled()
+ subdir('ipcpipeline')
+endif
+if get_option('mediafoundation').enabled()
+ subdir('mediafoundation')
+endif
+if get_option('mpegts').enabled()
+ subdir('mpegts')
+endif
......@@ -54,6 +67,9 @@
+if get_option('opencv').enabled()
+ subdir('opencv', if_found: opencv_dep)
+endif
+if get_option('qsv').enabled()
+ subdir('qsv')
+endif
+if get_option('uvch264').enabled()
+ subdir('uvch264')
+endif
......
--- tools/meson.build.orig 2022-09-05 21:25:23 UTC
--- tools/meson.build.orig 2023-01-23 19:29:34 UTC
+++ tools/meson.build
@@ -1,6 +1,8 @@
@@ -1,3 +1,4 @@
+if get_option('tools').enabled()
executable('gst-transcoder-' + api_version,
'gst-transcoder.c', 'utils.c',
install : true,
@@ -5,3 +6,4 @@ executable('gst-transcoder-' + api_version,
dependencies : [gst_dep, gstpbutils_dep, gst_transcoder_dep],
c_args: ['-DG_LOG_DOMAIN="gst-transcoder-@0@"'.format(api_version)],
)
......
......@@ -70,7 +70,13 @@ include/gstreamer-%%VERSION%%/gst/uridownloader/gsturidownloader_debug.h
include/gstreamer-%%VERSION%%/gst/uridownloader/uridownloader-prelude.h
include/gstreamer-%%VERSION%%/gst/webrtc/datachannel.h
include/gstreamer-%%VERSION%%/gst/webrtc/dtlstransport.h
include/gstreamer-%%VERSION%%/gst/webrtc/ice.h
include/gstreamer-%%VERSION%%/gst/webrtc/icestream.h
include/gstreamer-%%VERSION%%/gst/webrtc/icetransport.h
include/gstreamer-%%VERSION%%/gst/webrtc/nice/nice.h
include/gstreamer-%%VERSION%%/gst/webrtc/nice/nice_fwd.h
include/gstreamer-%%VERSION%%/gst/webrtc/nice/nicestream.h
include/gstreamer-%%VERSION%%/gst/webrtc/nice/nicetransport.h
include/gstreamer-%%VERSION%%/gst/webrtc/rtcsessiondescription.h
include/gstreamer-%%VERSION%%/gst/webrtc/rtpreceiver.h
include/gstreamer-%%VERSION%%/gst/webrtc/rtpsender.h
......@@ -103,6 +109,7 @@ lib/gstreamer-%%VERSION%%/libgstbayer.so
lib/gstreamer-%%VERSION%%/libgstbz2.so
lib/gstreamer-%%VERSION%%/libgstcamerabin.so
lib/gstreamer-%%VERSION%%/libgstcodecalpha.so
lib/gstreamer-%%VERSION%%/libgstcodectimestamper.so
lib/gstreamer-%%VERSION%%/libgstcoloreffects.so
lib/gstreamer-%%VERSION%%/libgstdebugutilsbad.so
lib/gstreamer-%%VERSION%%/libgstdvbsubenc.so
......@@ -203,6 +210,9 @@ lib/libgsturidownloader-%%VERSION%%.so.%%SOVERSION%%
lib/libgstwebrtc-%%VERSION%%.so
lib/libgstwebrtc-%%VERSION%%.so.0
lib/libgstwebrtc-%%VERSION%%.so.%%SOVERSION%%
lib/libgstwebrtcnice-%%VERSION%%.so
lib/libgstwebrtcnice-%%VERSION%%.so.0
lib/libgstwebrtcnice-%%VERSION%%.so.%%SOVERSION%%
libdata/pkgconfig/gstreamer-bad-audio-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-codecparsers-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-insertbin-%%VERSION%%.pc
......@@ -214,6 +224,7 @@ libdata/pkgconfig/gstreamer-plugins-bad-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-sctp-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-transcoder-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-webrtc-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-webrtc-nice-%%VERSION%%.pc
share/gir-%%VERSION%%/GstBadAudio-%%VERSION%%.gir
share/gir-%%VERSION%%/GstCodecs-%%VERSION%%.gir
share/gir-%%VERSION%%/GstInsertBin-%%VERSION%%.gir
......
......@@ -14,7 +14,8 @@ PLIST= ${.CURDIR}/pkg-plist
PATCHDIR= ${.CURDIR}/files
NO_GSTREAMER_COMMON= yes
GOOD_GST_ENABLED_PLUGINS= alpha \
GOOD_GST_ENABLED_PLUGINS= adaptivedemux2 \
alpha \
apetag \
audiofx \
audioparsers \
......@@ -60,6 +61,7 @@ GOOD_GST_ENABLED_PLUGINS= alpha \
videomixer \
wavenc \
wavparse \
xingmux \
y4m
.include "${MASTERDIR}/Makefile"
lib/gstreamer-%%VERSION%%/libgstadaptivedemux2.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
lib/gstreamer-%%VERSION%%/libgstalpha.so
lib/gstreamer-%%VERSION%%/libgstalphacolor.so
......@@ -45,6 +46,7 @@ lib/gstreamer-%%VERSION%%/libgstvideofilter.so
lib/gstreamer-%%VERSION%%/libgstvideomixer.so
lib/gstreamer-%%VERSION%%/libgstwavenc.so
lib/gstreamer-%%VERSION%%/libgstwavparse.so
lib/gstreamer-%%VERSION%%/libgstxingmux.so
lib/gstreamer-%%VERSION%%/libgsty4menc.so
%%DATADIR%%-%%VERSION%%/presets/GstIirEqualizer10Bands.prs
%%DATADIR%%-%%VERSION%%/presets/GstIirEqualizer3Bands.prs
......
......@@ -6,6 +6,8 @@ COMMENT= GStreamer (Intel MediaSDK) plugin
GST_PLUGIN= msdk
DIST= bad
CONFIGURE_ARGS= -Dskip_gstva=false
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
PLIST= ${.CURDIR}/pkg-plist
......
include/gstreamer-%%VERSION%%/gst/va/gstva.h
include/gstreamer-%%VERSION%%/gst/va/gstvaallocator.h
include/gstreamer-%%VERSION%%/gst/va/gstvadisplay.h
include/gstreamer-%%VERSION%%/gst/va/gstvadisplay_drm.h
include/gstreamer-%%VERSION%%/gst/va/gstvadisplay_wrapped.h
include/gstreamer-%%VERSION%%/gst/va/gstvapool.h
include/gstreamer-%%VERSION%%/gst/va/gstvautils.h
include/gstreamer-%%VERSION%%/gst/va/va-enumtypes.h
include/gstreamer-%%VERSION%%/gst/va/va-prelude.h
include/gstreamer-%%VERSION%%/gst/va/va_fwd.h
lib/girepository-%%VERSION%%/GstVa-%%VERSION%%.typelib
lib/gstreamer-%%VERSION%%/libgstmsdk.so
lib/libgstva-%%VERSION%%.so
lib/libgstva-%%VERSION%%.so.0
lib/libgstva-%%VERSION%%.so.%%SOVERSION%%
libdata/pkgconfig/gstreamer-va-%%VERSION%%.pc
share/gir-%%VERSION%%/GstVa-%%VERSION%%.gir
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment