Skip to content
Snippets Groups Projects
Commit 4994fd0d authored by Jan Beich's avatar Jan Beich
Browse files

devel/git-cinnabar: unbreak after d1b5bac3

Patching file git-core/tree-walk.c using Plan A...
Hunk #1 failed at 47.
cc -o hg-connect-http.o -c -MF ./.depend/hg-connect-http.o.d -MQ hg-connect-http.o -MMD -MP  -isystem/usr/local/include -DLIBICONV_PLUG -O2 -pipe -ffunction-sections -fdata-sections -fstack-protector-strong -fno-strict-aliasing  -DLIBICONV_PLUG -fstack-protector-strong  -I. -I/usr/local/include -DGIT_HOST_CPU="\"amd64\"" -DUSE_LIBPCRE2 -I/usr/local/include -DUSE_CURL_FOR_IMAP_SEND -I/usr/include -DUSE_ST_TIMESPEC -DSUPPORTS_SIMPLE_IPC -DSHA1_DC -DSHA1DC_NO_STANDARD_INCLUDES -DSHA1DC_INIT_SAFE_HASH_DEFAULT=0 -DSHA1DC_CUSTOM_INCLUDE_SHA1_C="\"cache.h\"" -DSHA1DC_CUSTOM_INCLUDE_UBC_CHECK_C="\"git-compat-util.h\"" -DSHA256_BLK -pthread -DHAVE_PATHS_H -DHAVE_STRINGS_H -DHAVE_CLOCK_GETTIME -DHAVE_CLOCK_MONOTONIC -DHAVE_BSD_SYSCTL -DHAVE_BSD_KERN_PROC_SYSCTL -DHAVE_GETDELIM -DHAVE_ARC4RANDOM -DFREAD_READS_DIRECTORIES -DDIR_HAS_BSD_GROUP_SEMANTICS -DFILENO_IS_A_MACRO -DSHELL_PATH='"/bin/sh"'  helper/hg-connect-http.c
done
1 out of 1 hunks failed--saving rejects to helper/tree-walk.patched.c.rej
done
gmake[2]: *** [helper/helper.mk:99: helper/tree-walk.patched.c] Error 1
parent e94bcbcf
Branches
Tags
No related merge requests found
PORTNAME= git-cinnabar
DISTVERSION= 0.5.10
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
......
https://github.com/glandium/git-cinnabar/commit/02449dbf25b1
--- helper/tree-walk.c.patch.orig 2022-07-30 21:04:45 UTC
+++ helper/tree-walk.c.patch
@@ -1,12 +1,12 @@ diff --git a/tree-walk.c b/tree-walk.c
diff --git a/tree-walk.c b/tree-walk.c
-index 3a94959d64..70558d2964 100644
+index 74f4d710e8..f46ac155eb 100644
--- a/tree-walk.c
+++ b/tree-walk.c
@@ -47,7 +47,7 @@ static int decode_tree_entry(struct tree_desc *desc, const char *buf, unsigned l
/* Initialize the descriptor entry */
desc->entry.path = path;
-- desc->entry.mode = canon_mode(mode);
+- desc->entry.mode = (desc->flags & TREE_DESC_RAW_MODES) ? mode : canon_mode(mode);
+ desc->entry.mode = mode;
desc->entry.pathlen = len - 1;
oidread(&desc->entry.oid, (const unsigned char *)path + len);
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment