Skip to content
Snippets Groups Projects
Commit 39d767fa authored by John Kennedy's avatar John Kennedy Committed by Mikael Urankar
Browse files

x11-servers/xorg-server: Fix build on aarch64

Same fix as https://reviews.freebsd.org/D8465

PR:		265691
Approved by:	portmgr (build fix blanket)
parent 99f5901e
No related branches found
No related tags found
No related merge requests found
--- hw/xfree86/os-support/meson.build.orig 2022-07-12 13:27:57 UTC
+++ hw/xfree86/os-support/meson.build
@@ -113,7 +113,7 @@ elif host_machine.system().endswith('bsd')
--- hw/xfree86/os-support/meson.build.orig 2022-07-12 13:27:57.000000000 +0000
+++ hw/xfree86/os-support/meson.build 2022-08-08 23:22:53.349353000 +0000
@@ -111,9 +111,9 @@
if host_machine.system() == 'netbsd' or host_machine.system() == 'openbsd'
os_dep += cc.find_library('i386')
endif
elif host_machine.cpu_family() == 'arm'
- elif host_machine.cpu_family() == 'arm'
+ elif host_machine.cpu_family() == 'arm' or host_machine.cpu_family() == 'aarch64'
srcs_xorg_os_support += 'bsd/arm_video.c'
- elif host_machine.cpu_family() == 'powerpc'
+ elif host_machine.cpu_family() == 'ppc' or host_machine.cpu_family() == 'ppc64'
......
--- include/meson.build.orig 2022-07-12 13:27:57.000000000 +0000
+++ include/meson.build 2022-08-09 00:48:12.688887000 +0000
@@ -377,7 +377,7 @@
xorg_data.set('HAVE_SYS_VT_H', cc.has_header('sys/vt.h') ? '1' : false)
if host_machine.system() == 'freebsd' or host_machine.system() == 'dragonfly'
- if host_machine.cpu_family() == 'x86' or host_machine.cpu_family() == 'x86_64'
+ if host_machine.cpu_family() == 'x86' or host_machine.cpu_family() == 'x86_64' or host_machine.cpu_family() == 'aarch64'
xorg_data.set('USE_DEV_IO', '1')
endif
elif host_machine.system() == 'netbsd'
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment