Skip to content
Snippets Groups Projects
Commit 2f784ffe authored by Piotr Kubaj's avatar Piotr Kubaj
Browse files

devel/llvm16: fix patching on powerpc64

Remove the upstreamed patch.
parent 0877b50a
No related branches found
No related tags found
No related merge requests found
......@@ -226,10 +226,6 @@ MLIR_PATTERN= ${MLIR_COMMANDS:S/^/bin./:tW:C/ */|/g}|mlir|libMLIR|obj.MLIRCAP
.include <bsd.port.options.mk>
.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
EXTRA_PATCHES= ${FILESDIR}/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp
.endif
# keep in sync with /usr/src/lib/clang/clang.build.mk
# ----------- start of sync block ------------------
# Armv6 and armv7 uses hard float abi, unless the CPUTYPE has soft in it.
......
--- clang/lib/Driver/ToolChains/Clang.cpp.orig 2021-08-11 19:51:00.122735000 +0200
+++ clang/lib/Driver/ToolChains/Clang.cpp 2021-08-11 19:51:24.346107000 +0200
@@ -1921,8 +1921,7 @@
if (T.isOSBinFormatELF()) {
switch (getToolChain().getArch()) {
case llvm::Triple::ppc64: {
- if ((T.isOSFreeBSD() && T.getOSMajorVersion() >= 13) ||
- T.isOSOpenBSD() || T.isMusl())
+ if (T.isOSFreeBSD() || T.isOSOpenBSD() || T.isMusl())
ABIName = "elfv2";
else
ABIName = "elfv1";
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment