Skip to content
Snippets Groups Projects
Commit 2eafd2a0 authored by Yuri Victorovich's avatar Yuri Victorovich
Browse files

audio/lsp-plugins-lv2: Update 1.1.31 -> 1.2.0

Reported by:	portscout
parent 9c62f527
No related branches found
No related tags found
No related merge requests found
PORTNAME= lsp-plugins
DISTVERSION= 1.1.31
DISTVERSION= 1.2.0
CATEGORIES= audio
MASTER_SITES= https://github.com/sadko4u/lsp-plugins/releases/download/1.2.0/
PKGNAMESUFFIX= -lv2
DISTFILES= ${PORTNAME}-src-${DISTVERSION}.tar.gz
MAINTAINER= yuri@FreeBSD.org
COMMENT= Collection of free LV2 plugins
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_FILE= ${WRKSRC}/COPYING
ONLY_FOR_ARCHS= amd64 armv7 i386 powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= assembly only for these architectures
BROKEN_i386= error: inline assembly requires more registers than available
BUILD_DEPENDS= llvm${LLVM_VERSION}>0:devel/llvm${LLVM_VERSION} \
lv2>0:audio/lv2
LIB_DEPENDS= libsndfile.so:audio/libsndfile
BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile
USES= gmake gl gnome iconv:wchar_t pkgconfig xorg # compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= sadko4u
USE_GNOME= cairo
USE_XORG= x11
USE_GL= gl
......@@ -27,19 +27,21 @@ USE_GL= gl
BINARY_ALIAS= g++=${CXX} c++=${CXX}
MAKE_ARGS= BUILD_MODULES='lv2' ETC_PATH=${PREFIX}/etc VERSION=${DISTVERSION}
# clang-8, 9, 10 crash: fatal error: error in backend: Cannot select: 0x805afb270: v4f32 = fp_extend 0x805afbc98
LLVM_VERSION= 11
CPP= clang-cpp${LLVM_VERSION}
CC= clang${LLVM_VERSION}
CXX= clang++${LLVM_VERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= JACK
OPTIONS_DEFAULT= JACK
MAKE_ARGS= FEATURES+='lv2'
OPTIONS_DEFINE= JACK VST2
OPTIONS_DEFAULT= JACK VST2
OPTIONS_SUB= yes
JACK_MAKE_ARGS= BUILD_MODULES+='jack'
JACK_DESC= Build Jack plugins
JACK_MAKE_ARGS= FEATURES+='jack'
JACK_LIB_DEPENDS= libjack.so:audio/jack
VST2_DESC= Build VST2 plugins
VST2_MAKE_ARGS= FEATURES+='vst2'
post-patch:
# FreeBSD does not have exp10(3), use pow(3) instead
@${GREP} -lR "exp10(" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
......@@ -47,10 +49,20 @@ post-patch:
@${GREP} -lR "<alloca\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<alloca\.h>|<stdlib.h>|'
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} config ${MAKE_ARGS}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/lsp-plugins.lv2/lsp-*.so
@${STRIP_CMD} \
${STAGEDIR}${PREFIX}/lib/lv2/lsp-plugins.lv2/lsp-*.so \
${STAGEDIR}${PREFIX}/lib/liblsp-r3d-glx-lib-1.0.1.so
post-install-JACK-on:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lsp-* ${STAGEDIR}${PREFIX}/lib/lsp-plugins/lsp-*.so
@${STRIP_CMD}
${STAGEDIR}${PREFIX}/bin/lsp-* \
${STAGEDIR}${PREFIX}/lib/lsp-plugins/liblsp-plugins-jack-1.2.0.so
post-install-VST2-on:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/vst/lsp-plugins/*.so
.include <bsd.port.mk>
TIMESTAMP = 1640213497
SHA256 (sadko4u-lsp-plugins-1.1.31_GH0.tar.gz) = 1c7327072913b3d95902d1a7c6cdac77d733099abf6616005544cea5e24f567e
SIZE (sadko4u-lsp-plugins-1.1.31_GH0.tar.gz) = 67357220
TIMESTAMP = 1650483074
SHA256 (lsp-plugins-src-1.2.0.tar.gz) = af75332bf996dd572ae1a8e6ea3537d02cc95c5a05b7ee04597afd068800e977
SIZE (lsp-plugins-src-1.2.0.tar.gz) = 25971969
- fix of the compilation problem: https://github.com/lsp-plugins/lsp-plugin-fw/commit/b2d31f757611b6fb8fc16c8a78465b11bc392526
From b2d31f757611b6fb8fc16c8a78465b11bc392526 Mon Sep 17 00:00:00 2001
From: sadko4u <sadko4u@gmail.com>
Date: Thu, 21 Apr 2022 00:00:52 +0300
Subject: [PATCH] Fixed compilation for clang.
--- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ports.h.orig 2022-03-25 17:27:50 UTC
+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ports.h
@@ -470,7 +470,7 @@ namespace lsp
class MeshPort: public Port
{
private:
- jack::mesh_t *pMesh;
+ plug::mesh_t *pMesh;
public:
explicit MeshPort(const meta::port_t *meta, Wrapper *w) : Port(meta, w)
@@ -485,7 +485,7 @@ namespace lsp
virtual int init()
{
- pMesh = jack::mesh_t::create(pMetadata);
+ pMesh = jack::create_mesh(pMetadata);
return (pMesh == NULL) ? STATUS_NO_MEM : STATUS_OK;
}
@@ -494,7 +494,7 @@ namespace lsp
if (pMesh == NULL)
return;
- jack::mesh_t::destroy(pMesh);
+ jack::destroy_mesh(pMesh);
pMesh = NULL;
}
--- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/types.h.orig 2022-03-25 17:27:50 UTC
+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/types.h
@@ -147,45 +147,41 @@ namespace lsp
} path_t;
- typedef struct mesh_t: public plug::mesh_t
+ inline plug::mesh_t *create_mesh(const meta::port_t *meta)
{
- static mesh_t *create(const meta::port_t *meta)
- {
- size_t buffers = meta->step;
- size_t buf_size = meta->start * sizeof(float);
- size_t mesh_size = sizeof(mesh_t) + sizeof(float *) * buffers;
+ size_t buffers = meta->step;
+ size_t buf_size = meta->start * sizeof(float);
+ size_t mesh_size = sizeof(plug::mesh_t) + sizeof(float *) * buffers;
- // Align values to 64-byte boundaries
- buf_size = align_size(buf_size, OPTIMAL_ALIGN);
- mesh_size = align_size(mesh_size, OPTIMAL_ALIGN);
+ // Align values to 64-byte boundaries
+ buf_size = align_size(buf_size, OPTIMAL_ALIGN);
+ mesh_size = align_size(mesh_size, OPTIMAL_ALIGN);
- // Allocate pointer
- uint8_t *ptr = static_cast<uint8_t *>(malloc(mesh_size + buf_size * buffers));
- if (ptr == NULL)
- return NULL;
+ // Allocate pointer
+ uint8_t *ptr = static_cast<uint8_t *>(malloc(mesh_size + buf_size * buffers));
+ if (ptr == NULL)
+ return NULL;
- // Initialize references
- mesh_t *mesh = reinterpret_cast<mesh_t *>(ptr);
- mesh->nState = plug::M_EMPTY;
- mesh->nBuffers = 0;
- mesh->nItems = 0;
- ptr += mesh_size;
- for (size_t i=0; i<buffers; ++i)
- {
- mesh->pvData[i] = reinterpret_cast<float *>(ptr);
- ptr += buf_size;
- }
-
- return mesh;
- }
-
- static void destroy(mesh_t *mesh)
+ // Initialize references
+ plug::mesh_t *mesh = reinterpret_cast<plug::mesh_t *>(ptr);
+ mesh->nState = plug::M_EMPTY;
+ mesh->nBuffers = 0;
+ mesh->nItems = 0;
+ ptr += mesh_size;
+ for (size_t i=0; i<buffers; ++i)
{
- if (mesh != NULL)
- free(mesh);
+ mesh->pvData[i] = reinterpret_cast<float *>(ptr);
+ ptr += buf_size;
}
- } mesh_t;
+ return mesh;
+ }
+
+ inline void destroy_mesh(plug::mesh_t *mesh)
+ {
+ if (mesh != NULL)
+ free(mesh);
+ }
}
}
--- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ui_ports.h.orig 2022-03-25 17:27:50 UTC
+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ui_ports.h
@@ -167,24 +167,24 @@ namespace lsp
class UIMeshPort: public UIPort
{
private:
- jack::mesh_t *pMesh;
+ plug::mesh_t *pMesh;
public:
explicit UIMeshPort(jack::Port *port): UIPort(port)
{
- pMesh = jack::mesh_t::create(port->metadata());
+ pMesh = jack::create_mesh(port->metadata());
}
virtual ~UIMeshPort()
{
- jack::mesh_t::destroy(pMesh);
+ jack::destroy_mesh(pMesh);
pMesh = NULL;
}
public:
virtual bool sync()
{
- mesh_t *mesh = pPort->buffer<mesh_t>();
+ plug::mesh_t *mesh = pPort->buffer<plug::mesh_t>();
if ((mesh == NULL) || (!mesh->containsData()))
return false;
......@@ -121,8 +121,11 @@
%%JACK%%bin/lsp-plugins-trigger-midi-stereo
%%JACK%%bin/lsp-plugins-trigger-mono
%%JACK%%bin/lsp-plugins-trigger-stereo
%%JACK%%lib/lsp-plugins/lsp-plugins-jack-core-1.1.31.so
%%JACK%%lib/lsp-plugins/lsp-plugins-r3d-glx.so
%%JACK%%lib/liblsp-r3d-glx-lib-1.0.1.a
%%JACK%%lib/liblsp-r3d-glx-lib-1.0.1.so
%%JACK%%lib/liblsp-r3d-glx-lib.a
%%JACK%%lib/liblsp-r3d-glx-lib.so
%%JACK%%lib/lsp-plugins/liblsp-plugins-jack-1.2.0.so
lib/lv2/lsp-plugins.lv2/art_delay_mono.ttl
lib/lv2/lsp-plugins.lv2/art_delay_stereo.ttl
lib/lv2/lsp-plugins.lv2/comp_delay_mono.ttl
......@@ -165,8 +168,8 @@ lib/lv2/lsp-plugins.lv2/limiter_mono.ttl
lib/lv2/lsp-plugins.lv2/limiter_stereo.ttl
lib/lv2/lsp-plugins.lv2/loud_comp_mono.ttl
lib/lv2/lsp-plugins.lv2/loud_comp_stereo.ttl
lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2.so
lib/lv2/lsp-plugins.lv2/lsp-plugins-r3d-glx.so
lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2-1.2.0.so
lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2ui-1.2.0.so
lib/lv2/lsp-plugins.lv2/manifest.ttl
lib/lv2/lsp-plugins.lv2/mb_compressor_lr.ttl
lib/lv2/lsp-plugins.lv2/mb_compressor_mono.ttl
......@@ -249,3 +252,128 @@ lib/lv2/lsp-plugins.lv2/trigger_midi_mono.ttl
lib/lv2/lsp-plugins.lv2/trigger_midi_stereo.ttl
lib/lv2/lsp-plugins.lv2/trigger_mono.ttl
lib/lv2/lsp-plugins.lv2/trigger_stereo.ttl
%%VST2%%lib/vst/lsp-plugins/art-delay-mono.so
%%VST2%%lib/vst/lsp-plugins/art-delay-stereo.so
%%VST2%%lib/vst/lsp-plugins/comp-delay-mono.so
%%VST2%%lib/vst/lsp-plugins/comp-delay-stereo.so
%%VST2%%lib/vst/lsp-plugins/comp-delay-x2-stereo.so
%%VST2%%lib/vst/lsp-plugins/compressor-lr.so
%%VST2%%lib/vst/lsp-plugins/compressor-mono.so
%%VST2%%lib/vst/lsp-plugins/compressor-ms.so
%%VST2%%lib/vst/lsp-plugins/compressor-stereo.so
%%VST2%%lib/vst/lsp-plugins/crossover-lr.so
%%VST2%%lib/vst/lsp-plugins/crossover-mono.so
%%VST2%%lib/vst/lsp-plugins/crossover-ms.so
%%VST2%%lib/vst/lsp-plugins/crossover-stereo.so
%%VST2%%lib/vst/lsp-plugins/dyna-processor-lr.so
%%VST2%%lib/vst/lsp-plugins/dyna-processor-mono.so
%%VST2%%lib/vst/lsp-plugins/dyna-processor-ms.so
%%VST2%%lib/vst/lsp-plugins/dyna-processor-stereo.so
%%VST2%%lib/vst/lsp-plugins/expander-lr.so
%%VST2%%lib/vst/lsp-plugins/expander-mono.so
%%VST2%%lib/vst/lsp-plugins/expander-ms.so
%%VST2%%lib/vst/lsp-plugins/expander-stereo.so
%%VST2%%lib/vst/lsp-plugins/gate-lr.so
%%VST2%%lib/vst/lsp-plugins/gate-mono.so
%%VST2%%lib/vst/lsp-plugins/gate-ms.so
%%VST2%%lib/vst/lsp-plugins/gate-stereo.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x16-lr.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x16-mono.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x16-ms.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x16-stereo.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x32-lr.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x32-mono.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x32-ms.so
%%VST2%%lib/vst/lsp-plugins/graph-equalizer-x32-stereo.so
%%VST2%%lib/vst/lsp-plugins/impulse-responses-mono.so
%%VST2%%lib/vst/lsp-plugins/impulse-responses-stereo.so
%%VST2%%lib/vst/lsp-plugins/impulse-reverb-mono.so
%%VST2%%lib/vst/lsp-plugins/impulse-reverb-stereo.so
%%VST2%%lib/vst/lsp-plugins/latency-meter.so
%%VST2%%lib/vst/lsp-plugins/limiter-mono.so
%%VST2%%lib/vst/lsp-plugins/limiter-stereo.so
%%VST2%%lib/vst/lsp-plugins/loud-comp-mono.so
%%VST2%%lib/vst/lsp-plugins/loud-comp-stereo.so
%%VST2%%lib/vst/lsp-plugins/lsp-plugins-vst2-1.2.0.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-lr.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-mono.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-ms.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-stereo.so
%%VST2%%lib/vst/lsp-plugins/mb-expander-lr.so
%%VST2%%lib/vst/lsp-plugins/mb-expander-mono.so
%%VST2%%lib/vst/lsp-plugins/mb-expander-ms.so
%%VST2%%lib/vst/lsp-plugins/mb-expander-stereo.so
%%VST2%%lib/vst/lsp-plugins/mb-gate-lr.so
%%VST2%%lib/vst/lsp-plugins/mb-gate-mono.so
%%VST2%%lib/vst/lsp-plugins/mb-gate-ms.so
%%VST2%%lib/vst/lsp-plugins/mb-gate-stereo.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x12-do.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x12.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x24-do.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x24.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x48-do.so
%%VST2%%lib/vst/lsp-plugins/multisampler-x48.so
%%VST2%%lib/vst/lsp-plugins/oscillator-mono.so
%%VST2%%lib/vst/lsp-plugins/oscilloscope-x1.so
%%VST2%%lib/vst/lsp-plugins/oscilloscope-x2.so
%%VST2%%lib/vst/lsp-plugins/oscilloscope-x4.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x16-lr.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x16-mono.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x16-ms.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x16-stereo.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x32-lr.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x32-mono.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x32-ms.so
%%VST2%%lib/vst/lsp-plugins/para-equalizer-x32-stereo.so
%%VST2%%lib/vst/lsp-plugins/phase-detector.so
%%VST2%%lib/vst/lsp-plugins/profiler-mono.so
%%VST2%%lib/vst/lsp-plugins/profiler-stereo.so
%%VST2%%lib/vst/lsp-plugins/room-builder-mono.so
%%VST2%%lib/vst/lsp-plugins/room-builder-stereo.so
%%VST2%%lib/vst/lsp-plugins/sampler-mono.so
%%VST2%%lib/vst/lsp-plugins/sampler-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-compressor-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-compressor-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-compressor-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-compressor-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-dyna-processor-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-dyna-processor-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-dyna-processor-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-dyna-processor-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-expander-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-expander-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-expander-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-expander-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-gate-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-gate-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-gate-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-gate-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-limiter-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-limiter-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-compressor-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-compressor-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-compressor-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-compressor-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-expander-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-expander-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-expander-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-expander-stereo.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-gate-lr.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-gate-mono.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-gate-ms.so
%%VST2%%lib/vst/lsp-plugins/sc-mb-gate-stereo.so
%%VST2%%lib/vst/lsp-plugins/slap-delay-mono.so
%%VST2%%lib/vst/lsp-plugins/slap-delay-stereo.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x1.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x12.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x16.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x2.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x4.so
%%VST2%%lib/vst/lsp-plugins/spectrum-analyzer-x8.so
%%VST2%%lib/vst/lsp-plugins/surge-filter-mono.so
%%VST2%%lib/vst/lsp-plugins/surge-filter-stereo.so
%%VST2%%lib/vst/lsp-plugins/trigger-midi-mono.so
%%VST2%%lib/vst/lsp-plugins/trigger-midi-stereo.so
%%VST2%%lib/vst/lsp-plugins/trigger-mono.so
%%VST2%%lib/vst/lsp-plugins/trigger-stereo.so
libdata/pkgconfig/lsp-r3d-glx-lib.pc
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment