Skip to content
Snippets Groups Projects
Commit 2c0bb3ce authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

net/wmwlmon: Remove expired port

2023-12-31 net/wmwlmon: BROKEN on all supported versions after the EOL of 12
parent 7f905b89
No related branches found
No related tags found
No related merge requests found
......@@ -8225,3 +8225,4 @@ net/thcrut||2023-12-31|Has expired: BROKEN on all supported versions after the E
games/OpenDiablo2||2023-12-31|Has expired: Upstream repository has been archived on Dec 20, 2021
graphics/figurine||2023-12-31|Has expired: BROKEN for more than 2 years on all supported versions after the EOL of 12
editors/xi-term||2023-12-31|Has expired: Frontend depends on deprecated editors/xi-core. No upstream activity.
net/wmwlmon||2023-12-31|Has expired: BROKEN on all supported versions after the EOL of 12
......@@ -1633,7 +1633,6 @@
SUBDIR += wmping
SUBDIR += wmwave
SUBDIR += wmwifi
SUBDIR += wmwlmon
SUBDIR += wol
SUBDIR += wpa_supplicant_gui
SUBDIR += wping
......
PORTNAME= wmwlmon
PORTVERSION= 1.0
CATEGORIES= net windowmaker
MASTER_SITES= http://www.nazgul.ch/dev/
MAINTAINER= LukeD@pobox.com
COMMENT= DockApp showing the state of a wireless network device
WWW= http://www.nazgul.ch/dev_wmwlmon.html
DEPRECATED= BROKEN on all supported versions after the EOL of 12
EXPIRATION_DATE= 2023-12-31
BROKEN_FreeBSD_13= does not compile: wl.c:29:10: fatal error: 'dev/wi/if_wavelan_ieee.h' file not found
BROKEN_FreeBSD_14= does not compile: wl.c:29:10: fatal error: 'dev/wi/if_wavelan_ieee.h' file not found
USES= xorg
USE_XORG= x11 xext xpm
PLIST_FILES= bin/wmwlmon man/man1/wmwlmon.1.gz
post-patch:
${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#g' \
-e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmwlmon ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmwlmon.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
SHA256 (wmwlmon-1.0.tar.gz) = d260828a3eadc39adf487d08384a2226de3e10298acf3e630865d6985edb170e
SIZE (wmwlmon-1.0.tar.gz) = 15097
--- wl.c.orig 2008-05-12 21:42:17.000000000 -0700
+++ wl.c 2008-05-15 21:27:36.000000000 -0700
@@ -283,6 +283,7 @@
int
get_wi_signal(const char *interface)
{
+#if __FreeBSD__ > 600100 && __FreeBSD__ < 700052 /* wi support is broken on 7 because of struct wi_req removal*/
int s;
struct ifreq ifr;
struct wi_req wreq;
@@ -319,6 +320,9 @@
#ifdef __FreeBSD__
return (wreq.wi_val[1]);
#endif
+#else
+ return (-1);
+#endif
}
/*
--- wl.h.orig 2006-05-04 18:44:47 UTC
+++ wl.h
@@ -16,7 +16,7 @@
* OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
*/
-#ifndef __OpenBSD__
+#ifndef IFM_TYPE_MATCH
#define IFM_TYPE_MATCH(dt, t) (IFM_TYPE((dt)) == 0 || \
IFM_TYPE((dt)) == IFM_TYPE((t)))
#endif
--- wmwlmon.1.orig 2008-05-13 10:42:02.000000000 -0700
+++ wmwlmon.1 2008-05-15 21:30:56.000000000 -0700
@@ -105,7 +105,6 @@
.It iwi(4)
.It ral(4)
.It upgt(4)
-.It wi(4)
.It wpi(4)
.El
.Pp
A DockApp that shows the state of a wireless network device.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment