Skip to content
Snippets Groups Projects
Commit 246333ec authored by Yuri Victorovich's avatar Yuri Victorovich
Browse files

biology/py-python-libsbml: Use CMAKE_BUILD_PARALLEL_LEVEL env var for parallelization

parent 2ca9bcd5
No related branches found
No related tags found
No related merge requests found
......@@ -16,7 +16,8 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
USES= python:3.8-3.9
USE_PYTHON= autoplist distutils # autoplist produces incomplete plist, missing files are in pkg-plist. Reported to the upstream author fbergman@caltech.edu on 2021-08-17
MAKE_ENV= FREEBSD_MAKE_JOBS=${_MAKE_JOBS}
MAKE_ENV= CMAKE_BUILD_PARALLEL_LEVEL=${MAKE_JOBS_NUMBER}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libsbml/_libsbml*.so
......
- workaround for https://github.com/sbmlteam/python-libsbml/issues/36
--- setup.py.orig 2023-05-25 10:49:17 UTC
+++ setup.py
@@ -248,7 +248,7 @@ class CMakeBuild(build_ext):
'-DWITH_LIBXML=OFF',
]
)
- self.spawn(['cmake', '--build', '.', '--target', 'install'] + build_args)
+ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'install'] + build_args)
os.chdir(cwd)
DEP_DIR = dep_inst_dir
@@ -297,7 +297,7 @@ class CMakeBuild(build_ext):
os.chdir(build_temp)
self.spawn(['cmake', SRC_DIR] + cmake_args)
if not self.dry_run:
- self.spawn(['cmake', '--build', '.', '--target', 'binding_python_lib'] + build_args)
+ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'binding_python_lib'] + build_args)
# at this point the build should be complete, and we have all the files
# neeed in the temp build_folder
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment