Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
3
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
246333ec
Commit
246333ec
authored
1 year ago
by
Yuri Victorovich
Browse files
Options
Downloads
Patches
Plain Diff
biology/py-python-libsbml: Use CMAKE_BUILD_PARALLEL_LEVEL env var for parallelization
parent
2ca9bcd5
No related branches found
No related tags found
No related merge requests found
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
biology/py-python-libsbml/Makefile
+2
-1
2 additions, 1 deletion
biology/py-python-libsbml/Makefile
biology/py-python-libsbml/files/patch-setup.py
+0
-22
0 additions, 22 deletions
biology/py-python-libsbml/files/patch-setup.py
with
2 additions
and
23 deletions
biology/py-python-libsbml/Makefile
+
2
−
1
View file @
246333ec
...
...
@@ -16,7 +16,8 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
USES
=
python:3.8-3.9
USE_PYTHON
=
autoplist distutils
# autoplist produces incomplete plist, missing files are in pkg-plist. Reported to the upstream author fbergman@caltech.edu on 2021-08-17
MAKE_ENV
=
FREEBSD_MAKE_JOBS
=
${
_MAKE_JOBS
}
MAKE_ENV
=
CMAKE_BUILD_PARALLEL_LEVEL
=
${
MAKE_JOBS_NUMBER
}
post-install
:
@${
STRIP_CMD
}
${
STAGEDIR
}${
PYTHONPREFIX_SITELIBDIR
}
/libsbml/_libsbml
*
.so
...
...
This diff is collapsed.
Click to expand it.
biology/py-python-libsbml/files/patch-setup.py
deleted
100644 → 0
+
0
−
22
View file @
2ca9bcd5
-
workaround
for
https
:
//
github
.
com
/
sbmlteam
/
python
-
libsbml
/
issues
/
36
---
setup
.
py
.
orig
2023
-
05
-
25
10
:
49
:
17
UTC
+++
setup
.
py
@@
-
248
,
7
+
248
,
7
@@
class
CMakeBuild
(
build_ext
):
'
-DWITH_LIBXML=OFF
'
,
]
)
-
self
.
spawn
([
'
cmake
'
,
'
--build
'
,
'
.
'
,
'
--target
'
,
'
install
'
]
+
build_args
)
+
self
.
spawn
([
'
cmake
'
,
'
--build
'
,
'
.
'
,
'
-j
'
,
os
.
getenv
(
'
FREEBSD_MAKE_JOBS
'
),
'
--target
'
,
'
install
'
]
+
build_args
)
os
.
chdir
(
cwd
)
DEP_DIR
=
dep_inst_dir
@@
-
297
,
7
+
297
,
7
@@
class
CMakeBuild
(
build_ext
):
os
.
chdir
(
build_temp
)
self
.
spawn
([
'
cmake
'
,
SRC_DIR
]
+
cmake_args
)
if
not
self
.
dry_run
:
-
self
.
spawn
([
'
cmake
'
,
'
--build
'
,
'
.
'
,
'
--target
'
,
'
binding_python_lib
'
]
+
build_args
)
+
self
.
spawn
([
'
cmake
'
,
'
--build
'
,
'
.
'
,
'
-j
'
,
os
.
getenv
(
'
FREEBSD_MAKE_JOBS
'
),
'
--target
'
,
'
binding_python_lib
'
]
+
build_args
)
# at this point the build should be complete, and we have all the files
# neeed in the temp build_folder
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment