Skip to content
Snippets Groups Projects
Commit 1ed91292 authored by baptiste daroussin's avatar baptiste daroussin
Browse files

deskutils/i3status: update to 2.15

parent 76b8901d
No related branches found
No related tags found
No related merge requests found
PORTNAME= i3status
PORTVERSION= 2.14
PORTREVISION= 3
PORTVERSION= 2.15
CATEGORIES= deskutils
MASTER_SITES= http://i3wm.org/i3status/
......
TIMESTAMP = 1636561077
SHA256 (i3status-2.14.tar.xz) = 5c4d0273410f9fa3301fd32065deda32e9617fcae8b3cb34793061bf21644924
SIZE (i3status-2.14.tar.xz) = 68900
TIMESTAMP = 1724134861
SHA256 (i3status-2.15.tar.xz) = 6c67f52cae4f139df764ad1cc736562be0f97750791bc212b53f34c06eaf2205
SIZE (i3status-2.15.tar.xz) = 70220
--- meson.build.orig 2021-11-12 10:03:11 UTC
+++ meson.build
@@ -222,15 +222,15 @@ install_subdir(
# because configure_file strips the backslash in e.g. \@display,
# resulting in @display, breaking our Perl code:
# https://github.com/mesonbuild/meson/issues/7165
-bash = find_program('bash')
+sh = find_program('sh')
replace_dirs = [
- bash, '-c', # Use bash to capture output and mark as executable
+ sh, '-c', # Use bash to capture output and mark as executable
'sed -e \'s,@abs_top_builddir@,'
+ meson.current_build_dir()
+ ',g;s,@abs_top_srcdir@,'
+ meson.current_source_dir()+',g\''
# Only mark files ending in .pl as executables
- + ' "$0" > "$1" && { [[ "${1##*.}" == pl ]] && chmod +x "$1" || true; }',
+ + ' "$0" > "$1" && { [ "${1##*.}" = pl ] && chmod +x "$1" || true; }',
'@INPUT0@', # $0
'@OUTPUT0@', # $1
]
--- src/print_battery_info.c.orig 2021-11-09 07:27:11 UTC
+++ src/print_battery_info.c
@@ -595,7 +595,7 @@ void print_battery_info(battery_info_ctx_t *ctx) {
#endif
#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__) || defined(__OpenBSD__)
/* These OSes report battery time in minutes. */
- hide_seconds = true;
+ ctx->hide_seconds = true;
#endif
if (ctx->number < 0) {
--- src/print_disk_info.c.orig 2021-11-10 16:46:42 UTC
+++ src/print_disk_info.c
@@ -63,7 +63,7 @@ static int print_bytes_human(char *outwalk, uint64_t b
* Determines whether remaining bytes are below given threshold.
*
*/
-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
+#if defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
static bool below_threshold(struct statfs buf, const char *prefix_type, const char *threshold_type, const double low_threshold) {
#else
static bool below_threshold(struct statvfs buf, const char *prefix_type, const char *threshold_type, const double low_threshold) {
@@ -124,17 +124,17 @@ void print_disk_info(disk_info_ctx_t *ctx) {
INSTANCE(ctx->path);
-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
+#if defined(__OpenBSD__) || defined(__DragonFly__) || defined(__APPLE__)
struct statfs buf;
if (statfs(path, &buf) == -1)
return;
mounted = true;
-#elif defined(__NetBSD__)
+#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
struct statvfs buf;
- if (statvfs(path, &buf) == -1)
+ if (statvfs(ctx->path, &buf) == -1)
return;
mounted = true;
--- src/print_volume.c.orig 2021-11-09 07:27:11 UTC
+++ src/print_volume.c
@@ -250,8 +250,8 @@ void print_volume(volume_ctx_t *ctx) {
const char *devicename = "UNSUPPORTED"; /* TODO: implement support for this */
pbval = 1;
- if (mixer_idx > 0)
- asprintf(&mixerpath, "/dev/mixer%d", mixer_idx);
+ if (ctx->mixer_idx > 0)
+ asprintf(&mixerpath, "/dev/mixer%d", ctx->mixer_idx);
else
mixerpath = defaultmixer;
@@ -264,7 +264,7 @@ void print_volume(volume_ctx_t *ctx) {
goto out;
}
- if (mixer_idx > 0)
+ if (ctx->mixer_idx > 0)
free(mixerpath);
#if defined(__NetBSD__) || defined(__OpenBSD__)
@@ -351,7 +351,7 @@ void print_volume(volume_ctx_t *ctx) {
}
#endif
- buffer = apply_volume_format(fmt, buffer, vol & 0x7f, devicename);
+ ctx->buf = apply_volume_format(ctx->fmt, vol & 0x7f, devicename);
close(mixfd);
goto out_with_format;
#endif
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment