Skip to content
Snippets Groups Projects
Commit 17f6df6b authored by Gleb Popov's avatar Gleb Popov
Browse files

games/moonlight-embedded: Update to 2.5.3

Enable compiling a discover feature.
parent a06b6204
No related branches found
No related tags found
No related merge requests found
PORTNAME= moonlight-embedded
DISTVERSION= 2.5.2
DISTVERSION= 2.5.3
CATEGORIES= games
MASTER_SITES= https://github.com/irtimmer/moonlight-embedded/releases/download/v${DISTVERSION}/
......@@ -11,7 +11,8 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
LIB_DEPENDS= libavahi-client.so:net/avahi-app \
libavcodec.so:multimedia/ffmpeg \
libcurl.so:ftp/curl \
libenet.so:net/enet \
libexpat.so:textproc/expat2 \
......@@ -34,10 +35,9 @@ post-patch:
-e '/libpulse-simple/d' \
-e '/libcec/d' \
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e '/avahi-client/d' -e 's@SHARED@STATIC@' \
@${REINPLACE_CMD} -e 's@SHARED@STATIC@' \
-e 's@OpenSSL 1.0.2@OpenSSL@' -e '/^install(/d' \
${WRKSRC}/libgamestream/CMakeLists.txt
@${RM} ${WRKSRC}/libgamestream/discover.c
@${REINPLACE_CMD} -e 's@/etc/moonlight/moonlight.conf@${PREFIX}/etc/moonlight.conf@' \
-e 's@moonligt@moonlight@g' \
${WRKSRC}/docs/README.pod
......
TIMESTAMP = 1649611079
SHA256 (moonlight-embedded-2.5.2.tar.xz) = 05b8c4db5ff4e5ea6f6edf2ffc35fef4c989792342549498fd372bc21707f809
SIZE (moonlight-embedded-2.5.2.tar.xz) = 295184
TIMESTAMP = 1666188557
SHA256 (moonlight-embedded-2.5.3.tar.xz) = 2fcd00049f58b0af882f0eec7077013c062bc35c8705f3d6bb7949d44e98fac0
SIZE (moonlight-embedded-2.5.3.tar.xz) = 303180
--- src/main.c.orig 2021-12-20 00:24:48 UTC
+++ src/main.c
@@ -258,12 +244,8 @@ int main(int argc, char* argv[]) {
exit(-1);
}
config.address[0] = 0;
- printf("Searching for server...\n");
- gs_discover_server(config.address);
- if (config.address[0] == 0) {
- fprintf(stderr, "Autodiscovery failed. Specify an IP address next time.\n");
- exit(-1);
- }
+ fprintf(stderr, "Autodiscovery unsupported. Specify an IP address next time.\n");
+ exit(-1);
}
char host_config_file[128];
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment