Skip to content
Snippets Groups Projects
Commit 092bf949 authored by Jan Beich's avatar Jan Beich
Browse files

x11-wm/kwinft: add new port

KWinFT (KWin Fast Track) is a robust, fast and versatile yet easy to
use composited window manager for the Wayland and X11 windowing
systems on Linux.

The KWinFT project is a reboot of KDE's KWin and intended to be used
as part of a KDE Plasma Desktop.

https://gitlab.com/kwinft/kwinft
parent 6dd08776
No related branches found
No related tags found
No related merge requests found
......@@ -49,6 +49,7 @@
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kickshaw
SUBDIR += kwinft
SUBDIR += labwc
SUBDIR += larswm
SUBDIR += leftwm
......
PORTNAME= kwinft
DISTVERSIONPREFIX= ${PORTNAME}@
DISTVERSION= 5.23.0
CATEGORIES= x11-wm
PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
PATCHFILES+= 4d47897f7cc5.patch:-p1 # https://gitlab.com/kwinft/kwinft/-/merge_requests/134
PATCHFILES+= ac7b3268dbc3.patch:-p1 # https://gitlab.com/kwinft/kwinft/-/merge_requests/134
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Wayland compositor and X11 window manager
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libwayland-server.so:graphics/wayland \
libWraplandServer.so:graphics/wrapland \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libwlroots.so:x11-toolkits/wlroots \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon \
libxcb-cursor.so:x11/xcb-util-cursor \
libxcb-image.so:x11/xcb-util-image \
libxcb-keysyms.so:x11/xcb-util-keysyms \
libxcb-icccm.so:x11/xcb-util-wm
TEST_DEPENDS= ${qt-testlib_PORT:T}>0:${qt-testlib_PORT}
CONFLICTS_INSTALL= plasma5-kwin # bin/kwin_wayland
USES= cmake:testing gl kde:5 pkgconfig python:run qt:5 shebangfix xorg
USE_GITLAB= yes
USE_GL= egl gbm
USE_KDE= ecm_build activities auth completion config configwidgets \
coreaddons crash decoration globalaccel i18n iconthemes \
idletime kcmutils kdeclarative kio kscreenlocker newstuff \
notifications package plasma-framework service textwidgets \
widgetsaddons windowsystem xmlgui
USE_LDCONFIG= yes
USE_QT= qmake_build buildtools_build core dbus declarative gui \
multimedia_run quickcontrols2_run widgets x11extras
USE_XORG= x11 xcb xi
SHEBANG_FILES= kconf_update/*.py kconf_update/*.pl
GL_COMMIT= 13be8a5795369b6744a5b4a1cb80dc781144cab8
PLIST_SUB= VERSION=${PORTVERSION}
LDFLAGS+= -Wl,--as-needed # GL, ICE/SM/Xext, epoll-shim, glib, intl, Qt5*, KF5*
OPTIONS_DEFINE= BREEZE DOCS QA11Y
OPTIONS_DEFAULT=BREEZE QA11Y
BREEZE_DESC= Default window decoration plugin
BREEZE_USE= KDE=breeze
BREEZE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Breeze
DOCS_USE= KDE=doctools_build
DOCS_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5DocTools
QA11Y_DESC= Accessibility (focus tracking) for Zoom effect
QA11Y_LIB_DEPENDS= libqaccessibilityclient-qt5.so:accessibility/libqaccessibilityclient
QA11Y_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_QAccessibilityClient
.include <bsd.port.mk>
TIMESTAMP = 1634224922
SHA256 (kwinft-kwinft-13be8a5795369b6744a5b4a1cb80dc781144cab8_GL0.tar.gz) = 7a1f7de9e0ba028e45f50f5a4ed2879af4bf11243e64620875e0401c4eb3dbab
SIZE (kwinft-kwinft-13be8a5795369b6744a5b4a1cb80dc781144cab8_GL0.tar.gz) = 4814244
SHA256 (4d47897f7cc5.patch) = 253a4822219f587b567812262de99fac781e440353847c21e4bf1431950ede9e
SIZE (4d47897f7cc5.patch) = 1081
SHA256 (ac7b3268dbc3.patch) = ceb26e10c1810ec5a70c28354ed93a23f72b9d24b3c6c2e0ff4eec389ce5082e
SIZE (ac7b3268dbc3.patch) = 868
CMake Error at CMakeLists.txt:816 (add_executable):
Target "kwin_wayland" links to target "Threads::Threads" but the target was
not found. Perhaps a find_package() call is missing for an IMPORTED
target, or an ALIAS target is missing?
--- CMakeLists.txt.orig 2021-10-14 15:22:02 UTC
+++ CMakeLists.txt
@@ -168,6 +168,12 @@ set_package_properties(XKB PROPERTIES
find_package(Qt5XkbCommonSupport REQUIRED)
+find_package(Threads)
+set_package_properties(Threads PROPERTIES
+ TYPE REQUIRED
+ PURPOSE "Required for building KWin with Wayland support"
+)
+
find_package(Libinput 1.9)
set_package_properties(Libinput PROPERTIES TYPE REQUIRED PURPOSE "Required for input handling on Wayland.")
In file included from plugins/scenes/opengl/scene_opengl.cpp:30:
plugins/scenes/opengl/scene_opengl.h:93:10: error: no template named 'unordered_map' in namespace 'std'
std::unordered_map<uint32_t, OpenGLWindow*> windows;
~~~~~^
--- plugins/scenes/opengl/scene_opengl.h.orig 2021-06-08 12:27:49 UTC
+++ plugins/scenes/opengl/scene_opengl.h
@@ -30,6 +30,8 @@ along with this program. If not, see <http://www.gnu.
#include "decorations/decorationrenderer.h"
#include "platformsupport/scenes/opengl/backend.h"
+#include <unordered_map>
+
namespace KWin
{
class LanczosFilter;
KWinFT (KWin Fast Track) is a robust, fast and versatile yet easy to
use composited window manager for the Wayland and X11 windowing
systems on Linux.
The KWinFT project is a reboot of KDE's KWin and intended to be used
as part of a KDE Plasma Desktop.
WWW: https://gitlab.com/kwinft/kwinft
[
{ type: install
message: <<EOM
WARNING: X11 support is currently unstable on FreeBSD. Replacing KWin
in Plasma Desktop may not work. Test standalone first.
Native Wayland on top of KMS console:
$ export XDG_RUNTIME_DIR=$(mktemp -dt run)
$ dbus-daemon --session --fork --address=unix:runtime=yes
$ seatd-launch kwin_wayland
Native X11 on top of Xorg:
$ echo "exec dbus-run-session kwin_x11" >~/.xinitrc
$ startx
Nested under Wayland as Wayland window manager:
$ kwin_wayland
Nested under Wayland as X11 window manager:
$ Xwayland :8 &
$ DISPLAY=:8 kwin_x11
Nested under X11 as Wayland window manager:
$ cage kwin_wayland
Nested under X11 as X11 window manager:
$ Xephyr :8 &
$ DISPLAY=:8 kwin_x11
Replace KWin in Plasma Desktop:
$ pkg set -n plasma5-kwin:kwinft
$ pkg set -o x11-wm/plasma5-kwin:x11-wm/kwinft
$ pkg upgrade -f kwinft
$ pkg lock kwinft
EOM
}
]
bin/kwin_wayland
bin/kwin_wayland_wrapper
bin/kwin_x11
include/kwin_export.h
include/kwinanimationeffect.h
include/kwinconfig.h
include/kwindeformeffect.h
include/kwineffectquickview.h
include/kwineffects.h
include/kwineffects_export.h
include/kwinglobals.h
include/kwinglplatform.h
include/kwingltexture.h
include/kwinglutils.h
include/kwinglutils_export.h
include/kwinglutils_funcs.h
include/kwinxrenderutils.h
include/kwinxrenderutils_export.h
lib/cmake/KWinDBusInterface/KWinDBusInterfaceConfig.cmake
lib/cmake/KWinEffects/KWinEffectsConfig.cmake
lib/cmake/KWinEffects/KWinEffectsConfigVersion.cmake
lib/cmake/KWinEffects/KWinEffectsTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/KWinEffects/KWinEffectsTargets.cmake
lib/kconf_update_bin/kwin5_update_default_rules
lib/libexec/kwin-applywindowdecoration
lib/libexec/kwin_killer_helper
lib/libexec/kwin_rules_dialog
lib/libkcmkwincommon.so.5
lib/libkcmkwincommon.so.%%VERSION%%
lib/libkwin.so.5
lib/libkwin.so.%%VERSION%%
lib/libkwin4_effect_builtins.so
lib/libkwin4_effect_builtins.so.1
lib/libkwin4_effect_builtins.so.1.0.0
lib/libkwineffects.so
lib/libkwineffects.so.13
lib/libkwineffects.so.%%VERSION%%
lib/libkwinglutils.so
lib/libkwinglutils.so.13
lib/libkwinglutils.so.%%VERSION%%
lib/libkwinxrenderutils.so
lib/libkwinxrenderutils.so.13
lib/libkwinxrenderutils.so.%%VERSION%%
%%QT_PLUGINDIR%%/kcm_kwin_scripts.so
%%QT_PLUGINDIR%%/kcm_kwinoptions.so
%%QT_PLUGINDIR%%/kcm_kwinscreenedges.so
%%QT_PLUGINDIR%%/kcm_kwintabbox.so
%%QT_PLUGINDIR%%/kcm_kwintouchscreen.so
%%QT_PLUGINDIR%%/kcms/kcm_kwin_effects.so
%%QT_PLUGINDIR%%/kcms/kcm_kwin_virtualdesktops.so
%%QT_PLUGINDIR%%/kcms/kcm_kwindecoration.so
%%QT_PLUGINDIR%%/kcms/kcm_kwinrules.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_aurorae.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_decoration.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_effect.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_script.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_windowswitcher.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kcm_kwin4_genericscripted.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_blur_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_coverswitch_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_cube_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_cubeslide_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_desktopgrid_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_diminactive_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_flipswitch_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_glide_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_invert_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_lookingglass_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_magiclamp_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_magnifier_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_mouseclick_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_mousemark_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_presentwindows_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_resize_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_showfps_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_showpaint_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_slide_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_thumbnailaside_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_trackmouse_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_windowgeometry_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_wobblywindows_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_zoom_config.so
%%QT_PLUGINDIR%%/kwincompositing.so
%%QT_PLUGINDIR%%/org.kde.kdecoration2/kwin5_aurorae.so
%%QT_PLUGINDIR%%/org.kde.kwin.scenes/KWinSceneOpenGL.so
%%QT_PLUGINDIR%%/org.kde.kwin.scenes/KWinSceneQPainter.so
%%QT_PLUGINDIR%%/org.kde.kwin.scenes/KWinSceneXRender.so
%%QT_QMLDIR%%/org/kde/kwin/decoration/AppMenuButton.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/ButtonGroup.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/Decoration.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/DecorationButton.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/MenuButton.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/libdecorationplugin.so
%%QT_QMLDIR%%/org/kde/kwin/decoration/qmldir
%%QT_QMLDIR%%/org/kde/kwin/decorations/plastik/libplastikplugin.so
%%QT_QMLDIR%%/org/kde/kwin/decorations/plastik/qmldir
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/libkdecorationprivatedeclarative.so
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/qmldir
lib/systemd/user/plasma-kwin_x11.service
share/config.kcfg/kwin.kcfg
share/config.kcfg/kwin_colorcorrect.kcfg
share/config.kcfg/kwindecorationsettings.kcfg
share/config.kcfg/virtualdesktopssettings.kcfg
share/dbus-1/interfaces/org.kde.KWin.VirtualDesktopManager.xml
share/dbus-1/interfaces/org.kde.KWin.xml
share/dbus-1/interfaces/org.kde.kwin.ColorCorrect.xml
share/dbus-1/interfaces/org.kde.kwin.Compositing.xml
share/dbus-1/interfaces/org.kde.kwin.Effects.xml
%%PORTDOCS%%share/doc/HTML/en/kcontrol/desktop/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/desktop/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/button.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/configure.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/decoration.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwindecoration/main.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwineffects/configure-effects.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwineffects/dialog-information.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwineffects/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwineffects/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwineffects/video.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwinscreenedges/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwinscreenedges/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwintabbox/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/kwintabbox/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowbehaviour/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowbehaviour/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/Face-smile.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/akgregator-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/akregator-attributes.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/akregator-fav.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/config-win-behavior.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/emacs-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/emacs-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/focus-stealing-pop2top-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/index.docbook
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/knotes-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/knotes-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kopete-attribute-2.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kopete-chat-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kopete-chat-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kopete-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-detect-window.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-kopete-rules.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-rule-editor.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-rules-main-n-akregator.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-rules-main.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-rules-ordering.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-window-attributes.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/kwin-window-matching.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/pager-4-desktops.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-compose-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-compose-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-main-attribute.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-main-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-reminder-attribute-2.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/tbird-reminder-info.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-emacs.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-init.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-knotes.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-kopete-chat.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-kopete.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-ready-akregator.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-tbird-compose.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-tbird-main.png
%%PORTDOCS%%share/doc/HTML/en/kcontrol/windowspecific/window-matching-tbird-reminder.png
share/icons/hicolor/16x16/apps/kwin.png
share/icons/hicolor/32x32/apps/kwin.png
share/icons/hicolor/48x48/apps/kwin.png
share/icons/hicolor/scalable/apps/kwin.svgz
share/kconf_update/kwin-5.16-auto-bordersize.sh
share/kconf_update/kwin-5.18-move-animspeed.py
share/kconf_update/kwin-5.21-desktop-grid-click-behavior.py
share/kconf_update/kwin-5.23-placement.pl
share/kconf_update/kwin.upd
share/kconf_update/kwinrules-5.19-placement.pl
share/kconf_update/kwinrules-5.23-placement.pl
share/kconf_update/kwinrules.upd
share/knotifications5/kwin.notifyrc
share/knsrcfiles/aurorae.knsrc
share/knsrcfiles/kwineffect.knsrc
share/knsrcfiles/kwinscripts.knsrc
share/knsrcfiles/kwinswitcher.knsrc
share/knsrcfiles/window-decorations.knsrc
share/kpackage/kcms/kcm_kwin_effects/contents/ui/Effect.qml
share/kpackage/kcms/kcm_kwin_effects/contents/ui/Video.qml
share/kpackage/kcms/kcm_kwin_effects/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_effects/metadata.desktop
share/kpackage/kcms/kcm_kwin_effects/metadata.json
share/kpackage/kcms/kcm_kwin_virtualdesktops/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.desktop
share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.json
share/kpackage/kcms/kcm_kwindecoration/contents/ui/ButtonGroup.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/Buttons.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/Themes.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/main.qml
share/kpackage/kcms/kcm_kwindecoration/metadata.desktop
share/kpackage/kcms/kcm_kwindecoration/metadata.json
share/kpackage/kcms/kcm_kwinrules/contents/ui/FileDialogLoader.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/OptionsComboBox.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/RuleItemDelegate.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/RulesEditor.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/RulesList.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/ValueEditor.qml
share/kpackage/kcms/kcm_kwinrules/metadata.desktop
share/kpackage/kcms/kcm_kwinrules/metadata.json
share/kservices5/kcm_kwin_effects.desktop
share/kservices5/kcm_kwin_virtualdesktops.desktop
share/kservices5/kcm_kwinrules.desktop
share/kservices5/kwin-script-videowall.desktop
share/kservices5/kwin/kwin4_decoration_qml_plastik.desktop
share/kservices5/kwincompositing.desktop
share/kservices5/kwindecoration.desktop
share/kservices5/kwinoptions.desktop
share/kservices5/kwinscreenedges.desktop
share/kservices5/kwinscripts.desktop
share/kservices5/kwintabbox.desktop
share/kservices5/kwintouchscreen.desktop
share/kservicetypes5/kwindecoration.desktop
share/kservicetypes5/kwindesktopswitcher.desktop
share/kservicetypes5/kwineffect.desktop
share/kservicetypes5/kwinscript.desktop
share/kservicetypes5/kwinwindowswitcher.desktop
share/kwin/aurorae/AppMenuButton.qml
share/kwin/aurorae/AuroraeButton.qml
share/kwin/aurorae/AuroraeButtonGroup.qml
share/kwin/aurorae/AuroraeMaximizeButton.qml
share/kwin/aurorae/Decoration.qml
share/kwin/aurorae/DecorationButton.qml
share/kwin/aurorae/MenuButton.qml
share/kwin/aurorae/aurorae.qml
share/kwin/cubecap.png
share/kwin/decorations/kwin4_decoration_qml_plastik/contents/config/main.xml
share/kwin/decorations/kwin4_decoration_qml_plastik/contents/ui/PlastikButton.qml
share/kwin/decorations/kwin4_decoration_qml_plastik/contents/ui/config.ui
share/kwin/decorations/kwin4_decoration_qml_plastik/contents/ui/main.qml
share/kwin/decorations/kwin4_decoration_qml_plastik/metadata.desktop
share/kwin/effects/desktopgrid/main.qml
share/kwin/effects/kwin4_effect_dialogparent/contents/code/main.js
share/kwin/effects/kwin4_effect_dialogparent/metadata.desktop
share/kwin/effects/kwin4_effect_dialogparent/metadata.json
share/kwin/effects/kwin4_effect_dimscreen/contents/code/main.js
share/kwin/effects/kwin4_effect_dimscreen/metadata.desktop
share/kwin/effects/kwin4_effect_dimscreen/metadata.json
share/kwin/effects/kwin4_effect_eyeonscreen/contents/code/main.js
share/kwin/effects/kwin4_effect_eyeonscreen/metadata.desktop
share/kwin/effects/kwin4_effect_eyeonscreen/metadata.json
share/kwin/effects/kwin4_effect_fade/contents/code/main.js
share/kwin/effects/kwin4_effect_fade/contents/config/main.xml
share/kwin/effects/kwin4_effect_fade/metadata.desktop
share/kwin/effects/kwin4_effect_fade/metadata.json
share/kwin/effects/kwin4_effect_fadedesktop/contents/code/main.js
share/kwin/effects/kwin4_effect_fadedesktop/metadata.desktop
share/kwin/effects/kwin4_effect_fadedesktop/metadata.json
share/kwin/effects/kwin4_effect_fadingpopups/contents/code/main.js
share/kwin/effects/kwin4_effect_fadingpopups/metadata.desktop
share/kwin/effects/kwin4_effect_fadingpopups/metadata.json
share/kwin/effects/kwin4_effect_frozenapp/contents/code/main.js
share/kwin/effects/kwin4_effect_frozenapp/metadata.desktop
share/kwin/effects/kwin4_effect_frozenapp/metadata.json
share/kwin/effects/kwin4_effect_fullscreen/contents/code/fullscreen.js
share/kwin/effects/kwin4_effect_fullscreen/metadata.desktop
share/kwin/effects/kwin4_effect_fullscreen/metadata.json
share/kwin/effects/kwin4_effect_login/contents/code/main.js
share/kwin/effects/kwin4_effect_login/contents/config/main.xml
share/kwin/effects/kwin4_effect_login/contents/ui/config.ui
share/kwin/effects/kwin4_effect_login/metadata.desktop
share/kwin/effects/kwin4_effect_login/metadata.json
share/kwin/effects/kwin4_effect_logout/contents/code/main.js
share/kwin/effects/kwin4_effect_logout/metadata.desktop
share/kwin/effects/kwin4_effect_logout/metadata.json
share/kwin/effects/kwin4_effect_maximize/contents/code/maximize.js
share/kwin/effects/kwin4_effect_maximize/metadata.desktop
share/kwin/effects/kwin4_effect_maximize/metadata.json
share/kwin/effects/kwin4_effect_morphingpopups/contents/code/morphingpopups.js
share/kwin/effects/kwin4_effect_morphingpopups/metadata.desktop
share/kwin/effects/kwin4_effect_morphingpopups/metadata.json
share/kwin/effects/kwin4_effect_scale/contents/code/main.js
share/kwin/effects/kwin4_effect_scale/contents/config/main.xml
share/kwin/effects/kwin4_effect_scale/contents/ui/config.ui
share/kwin/effects/kwin4_effect_scale/metadata.desktop
share/kwin/effects/kwin4_effect_scale/metadata.json
share/kwin/effects/kwin4_effect_sessionquit/contents/code/main.js
share/kwin/effects/kwin4_effect_sessionquit/metadata.desktop
share/kwin/effects/kwin4_effect_sessionquit/metadata.json
share/kwin/effects/kwin4_effect_squash/contents/code/main.js
share/kwin/effects/kwin4_effect_squash/metadata.desktop
share/kwin/effects/kwin4_effect_squash/metadata.json
share/kwin/effects/kwin4_effect_translucency/contents/code/main.js
share/kwin/effects/kwin4_effect_translucency/contents/config/main.xml
share/kwin/effects/kwin4_effect_translucency/contents/ui/config.ui
share/kwin/effects/kwin4_effect_translucency/metadata.desktop
share/kwin/effects/kwin4_effect_translucency/metadata.json
share/kwin/effects/kwin4_effect_windowaperture/contents/code/main.js
share/kwin/effects/kwin4_effect_windowaperture/metadata.desktop
share/kwin/effects/kwin4_effect_windowaperture/metadata.json
share/kwin/effects/presentwindows/main.qml
share/kwin/kcm_kwintabbox/dolphin.png
share/kwin/kcm_kwintabbox/kmail.png
share/kwin/kcm_kwintabbox/konqueror.png
share/kwin/kcm_kwintabbox/systemsettings.png
share/kwin/onscreennotification/plasma/dummydata/osd.qml
share/kwin/onscreennotification/plasma/main.qml
share/kwin/outline/plasma/outline.qml
share/kwin/scripts/desktopchangeosd/contents/ui/main.qml
share/kwin/scripts/desktopchangeosd/contents/ui/osd.qml
share/kwin/scripts/desktopchangeosd/metadata.desktop
share/kwin/scripts/desktopchangeosd/metadata.json
share/kwin/scripts/minimizeall/contents/code/main.js
share/kwin/scripts/minimizeall/metadata.desktop
share/kwin/scripts/minimizeall/metadata.json
share/kwin/scripts/synchronizeskipswitcher/contents/code/main.js
share/kwin/scripts/synchronizeskipswitcher/metadata.desktop
share/kwin/scripts/synchronizeskipswitcher/metadata.json
share/kwin/scripts/videowall/contents/code/main.js
share/kwin/scripts/videowall/contents/config/main.xml
share/kwin/scripts/videowall/contents/ui/config.ui
share/kwin/scripts/videowall/metadata.desktop
share/kwin/scripts/videowall/metadata.json
share/kwin/tm_inner.png
share/kwin/tm_outer.png
share/qlogging-categories5/org_kde_kwin.categories
......@@ -26,6 +26,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
xwayland-devel>0:x11-servers/xwayland-devel
RUN_DEPENDS= xwayland-devel>0:x11-servers/xwayland-devel
CONFLICTS_INSTALL= kwinft # bin/kwin_wayland
USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig \
python:3.5+,run qt:5 shebangfix tar:xz xorg
USE_GL= egl
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment