Skip to content
Snippets Groups Projects
Commit 092787df authored by Dmitry Marakasov's avatar Dmitry Marakasov
Browse files

games/stratagus: fix build with recent c++ library

In recent c++ library (such as on 14.x), <experimental/filesystem>
header would be removed in favor of standard <filesystem>. Remove
check for the former and don't do weird stuff when
experimental/filesystem is not present.

Reported by:	pkg-fallout
parent f5bf335f
Branches
Tags
No related merge requests found
--- CMakeLists.txt.orig 2022-07-31 09:44:18 UTC
--- CMakeLists.txt.orig 2022-08-10 18:13:08 UTC
+++ CMakeLists.txt
@@ -656,7 +656,7 @@ if(APPLE)
list(APPEND CMAKE_PREFIX_PATH /opt/homebrew/)
endif()
-if(NOT WIN32 OR NOT MSVC)
+if(FALSE)
include(CheckCXXSourceCompiles)
set(FS_SRC "
#include <experimental/filesystem>
@@ -807,7 +807,7 @@ endif()
# Stratagus definitions
......@@ -41,7 +50,7 @@
set(stratagus_LIBS ${stratagus_LIBS} ${THEORA_LIBRARY})
endif()
@@ -1311,7 +1311,7 @@ if (WIN32)
@@ -1311,8 +1311,8 @@ if (WIN32)
install(TARGETS midiplayer DESTINATION ${GAMEDIR})
endif()
......@@ -50,6 +59,7 @@
+if(ENABLE_DOC)
install(FILES
doc/development.html
doc/faq.html
@@ -1325,8 +1325,11 @@ if(ENABLE_DOC AND DOXYGEN_FOUND)
doc/README-SDL.txt
DESTINATION share/doc/stratagus
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment