diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 38d6d6a044932e6faf99f0fe790251593d459f63..5b7e6c81a60d6131ac426eeb8658f389a60069bb 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -1,6 +1,6 @@
 PORTNAME=	minidlna
 PORTVERSION=	1.3.2
-PORTREVISION=	2
+PORTREVISION=	3
 PORTEPOCH=	1
 CATEGORIES=	net multimedia www
 MASTER_SITES=	SF
diff --git a/net/minidlna/files/patch-metadata.c b/net/minidlna/files/patch-metadata.c
new file mode 100644
index 0000000000000000000000000000000000000000..32b4bde4729bdcf24996676fb078ed7000c7d95f
--- /dev/null
+++ b/net/minidlna/files/patch-metadata.c
@@ -0,0 +1,14 @@
+--- metadata.c.orig	2022-08-30 05:42:54 UTC
++++ metadata.c
+@@ -146,6 +146,11 @@ check_for_captions(const char *path, int64_t detailID)
+ 		strcpy(p, ".smi");
+ 		ret = access(file, R_OK);
+ 	}
++	if (ret != 0)
++	{
++		strcpy(p, ".ass");
++		ret = access(file, R_OK);
++	}
+ 
+ 	if (ret == 0)
+ 	{