diff --git a/net/Makefile b/net/Makefile
index d78476f05ea3311d11ae378dd2c39c86abbf564c..0f9fc6b7b35f119a453a131f7cf9a6ed8cbe3773 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1093,6 +1093,7 @@
     SUBDIR += py-pcapy-ng
     SUBDIR += py-port-for
     SUBDIR += py-portend
+    SUBDIR += py-pychromecast
     SUBDIR += py-pyenet
     SUBDIR += py-pyfixbuf
     SUBDIR += py-pygeoip
diff --git a/net/py-pychromecast/Makefile b/net/py-pychromecast/Makefile
new file mode 100644
index 0000000000000000000000000000000000000000..2f46f5ba1ba19fe6237e85a6589b82ec636f4d5c
--- /dev/null
+++ b/net/py-pychromecast/Makefile
@@ -0,0 +1,20 @@
+PORTNAME=	PyChromecast
+DISTVERSION=	13.0.8
+CATEGORIES=	net python
+MASTER_SITES=	PYPI
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	lexi.freebsd@le-fay.org
+COMMENT=	Python module to talk to Google Chromecast
+WWW=		https://pypi.org/project/PyChromecast/
+
+LICENSE=	MIT
+
+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}protobuf>0:devel/py-protobuf@${PY_FLAVOR}	\
+		${PYTHON_PKGNAMEPREFIX}zeroconf>0:net/py-zeroconf@${PY_FLAVOR}		\
+		${PYTHON_PKGNAMEPREFIX}casttube>0:net/py-casttube@${PY_FLAVOR}
+
+USES=		python
+USE_PYTHON=	distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/net/py-pychromecast/distinfo b/net/py-pychromecast/distinfo
new file mode 100644
index 0000000000000000000000000000000000000000..2017f205ee2fcc4b1d8fd13a844e898f5d1e76b4
--- /dev/null
+++ b/net/py-pychromecast/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703588893
+SHA256 (PyChromecast-13.0.8.tar.gz) = e4b7523db137f8de05eedcc6154113b68532848629442b448c2334fac966a447
+SIZE (PyChromecast-13.0.8.tar.gz) = 52095
diff --git a/net/py-pychromecast/pkg-descr b/net/py-pychromecast/pkg-descr
new file mode 100644
index 0000000000000000000000000000000000000000..c7de15e49366ad6a33b2756265c00691f1939d1f
--- /dev/null
+++ b/net/py-pychromecast/pkg-descr
@@ -0,0 +1,10 @@
+Library for Python 3.6+ to communicate with the Google Chromecast.
+
+It currently supports:
+* Auto discovering connected Chromecasts on the network
+* Start the default media receiver and play any online media
+* Control playback of current playing media
+* Implement Google Chromecast api v2
+* Communicate with apps via channels
+* Easily extendable to add support for unsupported namespaces
+* Multi-room setups with Audio cast devices