diff --git a/www/py-requests-aws4auth/Makefile b/www/py-requests-aws4auth/Makefile
index db30cfe4051a514a5385420750af765e5856abd6..eef696c0f2456abdcf96d570a73b66e42a8cc448 100644
--- a/www/py-requests-aws4auth/Makefile
+++ b/www/py-requests-aws4auth/Makefile
@@ -20,4 +20,9 @@ USE_PYTHON=	autoplist concurrent distutils
 
 NO_ARCH=	yes
 
+OPTIONS_DEFINE=	HTTPX
+HTTPX_DESC=	HTTP client support via httpx
+
+HTTPX__RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}httpx>=0:www/py-httpx@${PY_FLAVOR}
+
 .include <bsd.port.mk>