diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 505a5da1d8b7fb5bfaa7e8d3e8f74d067fee1d91..d992216205b77e2c076421c8831532cb754c7079 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -2,7 +2,6 @@ PORTNAME?=	proftpd
 .if !defined(DISTVERSION)
 PORTVERSION?=	${PROFTPD_VERSION}
 .endif
-PORTREVISION?=	2
 CATEGORIES?=	ftp
 MASTER_SITES=	ftp://ftp.proftpd.org/distrib/source/ \
 		https://github.com/downloads/proftpd/proftpd.github.com/ \
@@ -24,7 +23,7 @@ BUILD_DEPENDS+=	${LOCALBASE}/sbin/proftpd:ftp/proftpd
 RUN_DEPENDS+=	${LOCALBASE}/sbin/proftpd:ftp/proftpd
 .endif
 
-PROFTPD_VERSION=	1.3.8b
+PROFTPD_VERSION=	1.3.8c
 
 CPE_VENDOR=	proftpd
 CPE_PRODUCT=	proftpd
@@ -50,7 +49,8 @@ PORTDOCS=	*
 .endif
 
 MAKE_JOBS_UNSAFE=	yes
-USES+=		gmake libtool
+USES=		gmake libtool perl5
+USE_PERL5=	run
 GNU_CONFIGURE=	yes
 GNU_CONFIGURE_MANPREFIX=	${PREFIX}/share
 
diff --git a/ftp/proftpd/distinfo b/ftp/proftpd/distinfo
index 79f324d42cbc42b19f62e43af0b22a086bb4d2c1..d13f0dd411b4fe56820b992ac3279cb61f696fb6 100644
--- a/ftp/proftpd/distinfo
+++ b/ftp/proftpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1704667613
-SHA256 (proftpd-1.3.8b.tar.gz) = 183ab7c6107de271a2959ff268f55c9b6c76b2cf0029e6584fccc019686601e0
-SIZE (proftpd-1.3.8b.tar.gz) = 19752808
+TIMESTAMP = 1734635541
+SHA256 (proftpd-1.3.8c.tar.gz) = 2a48f2ca338456e750d2373bf671025ed799e04e0baa16c7bb8dbfd67d8734d2
+SIZE (proftpd-1.3.8c.tar.gz) = 19751847
diff --git a/ftp/proftpd/pkg-plist b/ftp/proftpd/pkg-plist
index 7bc0258eaf27c26ec6e4ca396cc5ed766d84585b..607550b30ce0cbe3ceffa5c16aaa3b61de040895 100644
--- a/ftp/proftpd/pkg-plist
+++ b/ftp/proftpd/pkg-plist
@@ -7,12 +7,14 @@ bin/ftptop
 bin/ftpwho
 bin/prxs
 etc/PROFTPD-MIB.txt
-@sample etc/proftpd.conf.sample
-@sample etc/proftpd/dhparams.pem.sample
-@sample etc/proftpd/blacklist.dat.sample
+@sample %%ETCDIR%%.conf.sample
+@sample %%ETCDIR%%/blacklist.dat.sample
+@sample %%ETCDIR%%/dhparams.pem.sample
+include/proftpd/Make.rules
 include/proftpd/acconfig.h
 include/proftpd/ascii.h
 include/proftpd/auth.h
+include/proftpd/base.h
 include/proftpd/bindings.h
 include/proftpd/buildstamp.h
 include/proftpd/ccan-json.h
@@ -52,8 +54,7 @@ include/proftpd/mkhome.h
 include/proftpd/mod_ctrls.h
 include/proftpd/mod_dnsbl.h
 include/proftpd/mod_quotatab.h
-include/proftpd/Make.rules
-include/proftpd/base.h
+include/proftpd/mod_sftp.h
 include/proftpd/mod_sftp/agent.h
 include/proftpd/mod_sftp/auth.h
 include/proftpd/mod_sftp/bcrypt.h
@@ -83,7 +84,6 @@ include/proftpd/mod_sftp/ssh2.h
 include/proftpd/mod_sftp/tap.h
 include/proftpd/mod_sftp/umac.h
 include/proftpd/mod_sftp/utf8.h
-include/proftpd/mod_sftp.h
 include/proftpd/mod_snmp.h
 include/proftpd/mod_sql.h
 include/proftpd/mod_tls.h
@@ -137,10 +137,10 @@ libexec/proftpd/mod_dynmasq.a
 libexec/proftpd/mod_dynmasq.so
 libexec/proftpd/mod_exec.a
 libexec/proftpd/mod_exec.so
-libexec/proftpd/mod_ifversion.a
-libexec/proftpd/mod_ifversion.so
 libexec/proftpd/mod_ifsession.a
 libexec/proftpd/mod_ifsession.so
+libexec/proftpd/mod_ifversion.a
+libexec/proftpd/mod_ifversion.so
 %%MEMCACHE%%libexec/proftpd/mod_memcache.a
 %%MEMCACHE%%libexec/proftpd/mod_memcache.so
 libexec/proftpd/mod_qos.a
@@ -149,32 +149,32 @@ libexec/proftpd/mod_quotatab.a
 libexec/proftpd/mod_quotatab.so
 libexec/proftpd/mod_quotatab_file.a
 libexec/proftpd/mod_quotatab_file.so
-libexec/proftpd/mod_quotatab_sql.a
-libexec/proftpd/mod_quotatab_sql.so
 libexec/proftpd/mod_quotatab_radius.a
 libexec/proftpd/mod_quotatab_radius.so
+libexec/proftpd/mod_quotatab_sql.a
+libexec/proftpd/mod_quotatab_sql.so
 libexec/proftpd/mod_radius.a
 libexec/proftpd/mod_radius.so
 libexec/proftpd/mod_ratio.a
 libexec/proftpd/mod_ratio.so
 libexec/proftpd/mod_readme.a
 libexec/proftpd/mod_readme.so
+%%REDIS%%libexec/proftpd/mod_redis.a
+%%REDIS%%libexec/proftpd/mod_redis.so
 libexec/proftpd/mod_rewrite.a
 libexec/proftpd/mod_rewrite.so
-libexec/proftpd/mod_shaper.a
-libexec/proftpd/mod_shaper.so
 libexec/proftpd/mod_sftp.a
 libexec/proftpd/mod_sftp.so
 libexec/proftpd/mod_sftp_pam.a
 libexec/proftpd/mod_sftp_pam.so
 libexec/proftpd/mod_sftp_sql.a
 libexec/proftpd/mod_sftp_sql.so
+libexec/proftpd/mod_shaper.a
+libexec/proftpd/mod_shaper.so
 libexec/proftpd/mod_site_misc.a
 libexec/proftpd/mod_site_misc.so
 libexec/proftpd/mod_snmp.a
 libexec/proftpd/mod_snmp.so
-%%REDIS%%libexec/proftpd/mod_redis.a
-%%REDIS%%libexec/proftpd/mod_redis.so
 libexec/proftpd/mod_sql.a
 libexec/proftpd/mod_sql.so
 libexec/proftpd/mod_sql_passwd.a
@@ -197,31 +197,31 @@ libexec/proftpd/mod_wrap2_file.so
 %%REDIS%%libexec/proftpd/mod_wrap2_redis.so
 libexec/proftpd/mod_wrap2_sql.a
 libexec/proftpd/mod_wrap2_sql.so
-share/man/man1/ftpcount.1.gz
-share/man/man1/ftpmail.1.gz
-share/man/man1/ftpasswd.1.gz
-share/man/man1/ftpquota.1.gz
-share/man/man1/ftpwho.1.gz
-share/man/man1/ftptop.1.gz
-share/man/man5/proftpd.conf.5.gz
-share/man/man5/xferlog.5.gz
-share/man/man8/proftpd.8.gz
-share/man/man8/ftpscrub.8.gz
-share/man/man8/ftpshut.8.gz
-share/man/man8/ftpdctl.8.gz
 sbin/ftpscrub
 sbin/ftpshut
 sbin/in.proftpd
 sbin/proftpd
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/proftpd.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/proftpd.mo
+%%NLS%%share/locale/bg_BG/LC_MESSAGES/proftpd.mo
 %%NLS%%share/locale/en_US/LC_MESSAGES/proftpd.mo
 %%NLS%%share/locale/es_ES/LC_MESSAGES/proftpd.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/proftpd.mo
 %%NLS%%share/locale/it_IT/LC_MESSAGES/proftpd.mo
 %%NLS%%share/locale/ja_JP/LC_MESSAGES/proftpd.mo
-%%NLS%%share/locale/ru_RU/LC_MESSAGES/proftpd.mo
-%%NLS%%share/locale/bg_BG/LC_MESSAGES/proftpd.mo
-%%NLS%%share/locale/fr_FR/LC_MESSAGES/proftpd.mo
 %%NLS%%share/locale/ko_KR/LC_MESSAGES/proftpd.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/proftpd.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/proftpd.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/proftpd.mo
+share/man/man1/ftpasswd.1.gz
+share/man/man1/ftpcount.1.gz
+share/man/man1/ftpmail.1.gz
+share/man/man1/ftpquota.1.gz
+share/man/man1/ftptop.1.gz
+share/man/man1/ftpwho.1.gz
+share/man/man5/proftpd.conf.5.gz
+share/man/man5/xferlog.5.gz
+share/man/man8/ftpdctl.8.gz
+share/man/man8/ftpscrub.8.gz
+share/man/man8/ftpshut.8.gz
+share/man/man8/proftpd.8.gz
 @dir lib/proftpd
 @dir %%LOCALSTATEDIR%%/proftpd