diff --git a/security/aws-c-auth/Makefile b/security/aws-c-auth/Makefile
index 21e20314b67ff8db13da64bd9011d69744343d5c..50abb0f59af1202a9584fe88f78c58447d4230e2 100644
--- a/security/aws-c-auth/Makefile
+++ b/security/aws-c-auth/Makefile
@@ -1,6 +1,6 @@
 PORTNAME=	aws-c-auth
 DISTVERSIONPREFIX=	v
-DISTVERSION=	0.8.3
+DISTVERSION=	0.8.4
 CATEGORIES=	security
 
 MAINTAINER=	eduardo@FreeBSD.org
@@ -24,7 +24,6 @@ USE_GITHUB=	yes
 GH_ACCOUNT=	awslabs
 USE_LDCONFIG=	yes
 
-CMAKE_ARGS+=	-DCMAKE_PREFIX_PATH=${LOCALBASE}
 CMAKE_ON=	BUILD_SHARED_LIBS
 CMAKE_OFF=	BUILD_TESTING
 
diff --git a/security/aws-c-auth/distinfo b/security/aws-c-auth/distinfo
index 72f783148c400e97b06615bb133520b451b78d98..0adeee46bfc1316fa3f7f3cc1b73bd9c3eb5414b 100644
--- a/security/aws-c-auth/distinfo
+++ b/security/aws-c-auth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1738013567
-SHA256 (awslabs-aws-c-auth-v0.8.3_GH0.tar.gz) = 369c9b21c2f54fd77d61d2a72ba79e208e24736466ab7f21a140937dc7e9c615
-SIZE (awslabs-aws-c-auth-v0.8.3_GH0.tar.gz) = 260004
+TIMESTAMP = 1738181595
+SHA256 (awslabs-aws-c-auth-v0.8.4_GH0.tar.gz) = 5a49b43aba7d2be6217b73dc40256120d31a7d0ca2c3f96d06e5154beed5de7a
+SIZE (awslabs-aws-c-auth-v0.8.4_GH0.tar.gz) = 259821
diff --git a/security/aws-c-auth/files/patch-CMakeLists.txt b/security/aws-c-auth/files/patch-CMakeLists.txt
deleted file mode 100644
index ec65dc056c877fff91c7b605d4a28cb071b11ff3..0000000000000000000000000000000000000000
--- a/security/aws-c-auth/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt.orig	2021-10-23 10:33:37 UTC
-+++ CMakeLists.txt
-@@ -111,6 +111,7 @@ target_link_libraries(${PROJECT_NAME} PUBLIC ${DEP_AWS
- aws_prepare_shared_lib_exports(${PROJECT_NAME})
- 
- install(FILES ${AWS_AUTH_ROOT_HEADERS} DESTINATION "include/aws/auth" COMPONENT Development)
-+install(FILES ${AWS_AUTH_PRIVATE_HEADERS} DESTINATION "include/aws/auth/private" COMPONENT Development)
- 
- if (BUILD_SHARED_LIBS)
-    set (TARGET_DIR "shared")
diff --git a/security/aws-c-auth/pkg-plist b/security/aws-c-auth/pkg-plist
index 581572bacbd0298d560b5cf1cbba94a0b84cebd9..f7faeb9fc9902309afc8ec0e047b48ebcc239f6e 100644
--- a/security/aws-c-auth/pkg-plist
+++ b/security/aws-c-auth/pkg-plist
@@ -2,19 +2,12 @@ include/aws/auth/auth.h
 include/aws/auth/aws_imds_client.h
 include/aws/auth/credentials.h
 include/aws/auth/exports.h
-include/aws/auth/private/aws_profile.h
-include/aws/auth/private/aws_signing.h
-include/aws/auth/private/credentials_utils.h
-include/aws/auth/private/key_derivation.h
-include/aws/auth/private/sigv4_http_request.h
-include/aws/auth/private/sso_token_providers.h
-include/aws/auth/private/sso_token_utils.h
 include/aws/auth/signable.h
 include/aws/auth/signing.h
 include/aws/auth/signing_config.h
 include/aws/auth/signing_result.h
-lib/aws-c-auth/cmake/aws-c-auth-config.cmake
-lib/aws-c-auth/cmake/shared/aws-c-auth-targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/aws-c-auth/cmake/shared/aws-c-auth-targets.cmake
+lib/cmake/aws-c-auth/aws-c-auth-config.cmake
+lib/cmake/aws-c-auth/shared/aws-c-auth-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/aws-c-auth/shared/aws-c-auth-targets.cmake
 lib/libaws-c-auth.so
 lib/libaws-c-auth.so.1.0.0