From b8001d808552361cb4700fbf1e198f5b531eafa6 Mon Sep 17 00:00:00 2001
From: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
Date: Wed, 6 Sep 2023 04:41:49 +0800
Subject: [PATCH] devel/py-archspec: Fix BUILD_DEPENDS

from pyproject.toml:
[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"

Approved by:	portmgr (blanket)
With hat:	python
Reference:	https://github.com/archspec/archspec/blob/v0.2.1/pyproject.toml#L42-L44
---
 devel/py-archspec/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/devel/py-archspec/Makefile b/devel/py-archspec/Makefile
index 8e0b6dacae6f..744318b9dc1e 100644
--- a/devel/py-archspec/Makefile
+++ b/devel/py-archspec/Makefile
@@ -13,7 +13,7 @@ LICENSE_COMB=	dual
 LICENSE_FILE_APACHE20=	${WRKSRC}/LICENSE-APACHE
 LICENSE_FILE_MIT=	${WRKSRC}/LICENSE-MIT
 
-BUILD_DEPENDS=	${PYTHON_PKGNAMEPREFIX}poetry>0:devel/py-poetry@${PY_FLAVOR}
+BUILD_DEPENDS=	${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
 
 USES=		python
 USE_PYTHON=	pep517 autoplist pytest
-- 
GitLab