diff --git a/www/py-django-auth-ldap/Makefile b/www/py-django-auth-ldap/Makefile
index e59fabcc7f19ff4b5dbdcb33422532b32207f114..3c5f63dbb8db37789305069270a42744e86abc0c 100644
--- a/www/py-django-auth-ldap/Makefile
+++ b/www/py-django-auth-ldap/Makefile
@@ -1,8 +1,7 @@
 # Created by: Alexander Kriventsov <avk@vl.ru>
 
 PORTNAME=	django-auth-ldap
-PORTVERSION=	4.0.0
-PORTREVISION=	1
+PORTVERSION=	4.1.0
 CATEGORIES=	www security python
 MASTER_SITES=	CHEESESHOP
 PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +16,7 @@ BUILD_DEPENDS=	${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_sc
 RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR} \
 		${PYTHON_PKGNAMEPREFIX}ldap>=3.1:net/py-ldap@${PY_FLAVOR}
 
-USES=		python:3.6+
+USES=		python:3.7+
 USE_PYTHON=	autoplist concurrent distutils
 
 NO_ARCH=	yes
diff --git a/www/py-django-auth-ldap/distinfo b/www/py-django-auth-ldap/distinfo
index c9ce77fde25692412026a640f1b9119d552344c2..43490a063c0e4376a3ae57d4561d20be889eeefd 100644
--- a/www/py-django-auth-ldap/distinfo
+++ b/www/py-django-auth-ldap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1641496154
-SHA256 (django-auth-ldap-4.0.0.tar.gz) = 276f79e624ce083ce13f161387f65ff1c0efe83ef8a42f2b9830d43317b15239
-SIZE (django-auth-ldap-4.0.0.tar.gz) = 52648
+TIMESTAMP = 1654945388
+SHA256 (django-auth-ldap-4.1.0.tar.gz) = 77f749d3b17807ce8eb56a9c9c8e5746ff316567f81d5ba613495d9c7495a949
+SIZE (django-auth-ldap-4.1.0.tar.gz) = 53254
diff --git a/www/py-django-auth-ldap/files/patch-docs_conf.py b/www/py-django-auth-ldap/files/patch-docs_conf.py
index 8ab329172ad80303b7d723c1920b2df572052e11..d41916245ebcda6775fcd03ff555e7ddf7d44592 100644
--- a/www/py-django-auth-ldap/files/patch-docs_conf.py
+++ b/www/py-django-auth-ldap/files/patch-docs_conf.py
@@ -2,14 +2,12 @@ Avoid the download of various intersphinx inventories during build.  Only two
 intersphinx mappings are used and the documentation can be built/used without
 them.
 
---- docs/conf.py.orig	2021-02-28 15:46:24 UTC
+--- docs/conf.py.orig	2022-06-12 10:26:47 UTC
 +++ docs/conf.py
-@@ -186,15 +186,3 @@ texinfo_documents = [
- 
- 
+@@ -188,13 +188,3 @@ texinfo_documents = [
  # -- Extension configuration -------------------------------------------------
--
--# -- Options for intersphinx extension ---------------------------------------
+ 
+ # -- Options for intersphinx extension ---------------------------------------
 -
 -intersphinx_mapping = {
 -    "python": ("https://docs.python.org/3/", None),
@@ -17,6 +15,6 @@ them.
 -        "https://docs.djangoproject.com/en/stable/",
 -        "https://docs.djangoproject.com/en/stable/_objects/",
 -    ),
--    "pythonldap": ("https://python-ldap.readthedocs.io/en/latest/", None),
--    "tox": ("https://tox.readthedocs.io/en/latest/", None),
+-    "pythonldap": ("https://www.python-ldap.org/en/latest/", None),
+-    "tox": ("https://tox.wiki/en/latest/", None),
 -}