diff --git a/net/tcpproxy/Makefile b/net/tcpproxy/Makefile
index dd2e687fdfcfb68db066b449da7bd5ca49b4a447..a79b048098315a25fa83ff617107397ad52e053a 100644
--- a/net/tcpproxy/Makefile
+++ b/net/tcpproxy/Makefile
@@ -1,5 +1,6 @@
 PORTNAME=	tcpproxy
 PORTVERSION=	1.2
+PORTREVISION=	1
 CATEGORIES=	net
 MASTER_SITES=	http://www.spreadspace.org/tcpproxy/releases/ \
 		http://alex.bmg.gv.at/programs/
@@ -24,11 +25,11 @@ USE_RC_SUBR=	tcpproxy
 WRKSRC=	${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
 
 PLIST_FILES=	bin/tcpproxy etc/tcpproxy_sample.conf \
-		man/man8/tcpproxy.8.gz
+		share/man/man8/tcpproxy.8.gz
 
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${STAGEDIR}${PREFIX}/bin
 	${INSTALL_DATA}  ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${STAGEDIR}${PREFIX}/etc/tcpproxy_sample.conf
-	${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/tcpproxy.8 ${STAGEDIR}${PREFIX}/man/man8
+	${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/tcpproxy.8 ${STAGEDIR}${PREFIX}/share/man/man8
 
 .include <bsd.port.mk>