diff --git a/MOVED b/MOVED
index 2baed981019d54a276b4852cac561fc4f5659a62..5a8c9bae5153d9bfee30e2e07f5e6cd3d15fc227 100644
--- a/MOVED
+++ b/MOVED
@@ -2933,3 +2933,4 @@ net-im/libaccounts-qt5|net-im/libaccounts-qt|2024-01-05|Renamed to support flavo
 devel/py-pygithub|devel/py-PyGithub|2024-01-06|Rename port match upstream
 devel/freebsd-gcc9||2024-01-09|No longer able to build base system, use GCC 12 or later instead
 net/downzemall|net/arrowdl|2024-01-11|Project was renamed upstream
+misc/mc-nox11|misc/mc|2023-01-15|No longer useful (misc/mc does not require Xlib at runtime)
diff --git a/misc/Makefile b/misc/Makefile
index 219cd07ac295378dae7e5f7566004d95e37d4136..7c358530f4bbc445544aa03c1a99f4df0248318d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -259,7 +259,6 @@
     SUBDIR += mate-user-guide
     SUBDIR += mbuffer
     SUBDIR += mc
-    SUBDIR += mc-nox11
     SUBDIR += mdp
     SUBDIR += meshoptimizer
     SUBDIR += metalink-checker
diff --git a/misc/mc-nox11/Makefile b/misc/mc-nox11/Makefile
deleted file mode 100644
index 6f1710a2814aabb21ad873def8ccc29e99249d99..0000000000000000000000000000000000000000
--- a/misc/mc-nox11/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-MASTERDIR=	${.CURDIR}/../mc
-OPTIONS_EXCLUDE=	X11
-
-.include "${MASTERDIR}/Makefile"
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index d7f41964a2230f66301960f432129ea8361d2c33..b6e0f887b391da79cd0858c0a0acd9c1488486c1 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -1,5 +1,6 @@
 PORTNAME=	mc
 PORTVERSION=	4.8.30
+PORTREVISION=	1
 CATEGORIES=	misc shells
 MASTER_SITES=	http://ftp.midnight-commander.org/ \
 		https://ftp.osuosl.org/pub/midnightcommander/
@@ -29,7 +30,7 @@ CONFIGURE_ENV=	ZIP=${LOCALBASE}/bin/zip UNZIP=${UNZIP_NATIVE_CMD}
 PORTDOCS=	AUTHORS FAQ HACKING MAINTAINERS NEWS README *.txt
 
 OPTIONS_DEFINE=	ASPELL DOCS EDITOR EXTATTR ICONV NLS PCRE2 SFTP SUBSHELL X11
-OPTIONS_DEFAULT=	EDITOR ICONV SFTP SLANG SUBSHELL X11
+OPTIONS_DEFAULT=	ASPELL EDITOR ICONV SFTP SLANG SUBSHELL X11
 OPTIONS_SINGLE=	SCREEN
 OPTIONS_SINGLE_SCREEN=	SLANG NCURSES
 OPTIONS_SUB=	yes
@@ -41,8 +42,9 @@ PCRE2_DESC=	Use PCRE2 as low-level search engine
 SCREEN_DESC=	Screen library
 SFTP_DESC=	Support for SFTP (via libssh)
 SUBSHELL_DESC=	Build with subshell support
+X11_DESC=	X11 events support (if available)
 
-ASPELL_LIB_DEPENDS=	libaspell.so:textproc/aspell
+ASPELL_BUILD_DEPENDS=	${LOCALBASE}/include/aspell.h:textproc/aspell
 ASPELL_CONFIGURE_ENABLE=aspell
 
 EDITOR_CONFIGURE_WITH=	internal-edit
@@ -71,11 +73,8 @@ SLANG_CONFIGURE_ON=	--with-screen=slang
 SUBSHELL_CONFIGURE_WITH=subshell
 SUBSHELL_SUB_FILES=	pkg-message
 
+X11_BUILD_DEPENDS=	${LOCALBASE}/include/X11/Xlib.h:x11/libX11
 X11_CONFIGURE_WITH=	x
-X11_USES=		xorg
-X11_USE=		xorg=x11,xext
-X11_VARS=		CONFLICTS_INSTALL=mc-nox11
-X11_VARS_OFF=		CONFLICTS_INSTALL=mc PKGNAMESUFFIX=-nox11
 
 post-patch:
 	@${REINPLACE_CMD} -e 's|clang\*)|*)|' ${WRKSRC}/configure