diff --git a/www/py-gunicorn/Makefile b/www/py-gunicorn/Makefile
index 7751b0d0a04366c992e7c38763eec8320efc5918..79f861fe05241fb28871809d49edb418cb59f64c 100644
--- a/www/py-gunicorn/Makefile
+++ b/www/py-gunicorn/Makefile
@@ -1,10 +1,10 @@
 # Created by: Kristaps Kulis <kristaps.kulis@gmail.com>
 
 PORTNAME=	gunicorn
-PORTVERSION=	19.9.0
-PORTREVISION=	1
+PORTVERSION=	20.1.0
 CATEGORIES=	www python
 PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+MASTER_SITES=	CHEESESHOP
 
 MAINTAINER=	bofh@FreeBSD.org
 COMMENT=	WSGI HTTP Server for UNIX
@@ -12,30 +12,28 @@ COMMENT=	WSGI HTTP Server for UNIX
 LICENSE=	MIT
 LICENSE_FILE=	${WRKSRC}/LICENSE
 
-TEST_DEPENDS=	${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS=	${PYTHON_PKGNAMEPREFIX}aiohttp>0:www/py-aiohttp@${PY_FLAVOR} \
+		${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES=		cpe python:3.6+
+USE_PYTHON=	autoplist concurrent distutils
+
+NO_ARCH=	yes
 
 OPTIONS_DEFINE=		PROCTITLE
 OPTIONS_DEFAULT=	PROCTITLE
 OPTIONS_GROUP=		WORKERS
-OPTIONS_GROUP_WORKERS=	EVENTLET GAIOHTTP TORNADO
+OPTIONS_GROUP_WORKERS=	EVENTLET GEVENT TORNADO
 
 EVENTLET_DESC=	Eventlet async worker
-GAIOHTTP_DESC=	gaiohttp async worker
+GEVENT_DESC=	Greenlet worker
 PROCTITLE_DESC=	Custom process titles with setproctitle(3)
 TORNADO_DESC=	Tornado async worker
 
-EVENTLET_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.7:net/py-eventlet@${PY_FLAVOR}
-GAIOHTTP_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}aiohttp>0:www/py-aiohttp@${PY_FLAVOR}
+EVENTLET_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}eventlet>=0.24.1:net/py-eventlet@${PY_FLAVOR}
+GEVENT_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}gevent>1.4.0:devel/py-gevent@${PY_FLAVOR}
 PROCTITLE_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}setproctitle>0:devel/py-setproctitle@${PY_FLAVOR}
-TORNADO_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}tornado>=2.2:www/py-tornado@${PY_FLAVOR}
-
-USES=			cpe python:3.6+
-USE_GITHUB=		yes
-USE_PYTHON=		autoplist concurrent distutils
-
-GH_ACCOUNT=	benoitc
-
-NO_ARCH=	yes
+TORNADO_RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}tornado>=0.2:www/py-tornado@${PY_FLAVOR}
 
 do-test:
 	@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/www/py-gunicorn/distinfo b/www/py-gunicorn/distinfo
index f568af0f1f381591065c6bde4f32ac8954bfa56a..609a15b77f2cc12aeb1f854016471a3c4567433e 100644
--- a/www/py-gunicorn/distinfo
+++ b/www/py-gunicorn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551828009
-SHA256 (benoitc-gunicorn-19.9.0_GH0.tar.gz) = d593aa13812eadc1f5cffe4a81ccdcbcb25528e5418af1b5138e88fd8c0c2a31
-SIZE (benoitc-gunicorn-19.9.0_GH0.tar.gz) = 401755
+TIMESTAMP = 1646846134
+SHA256 (gunicorn-20.1.0.tar.gz) = e0a968b5ba15f8a328fdfd7ab1fcb5af4470c28aaf7e55df02a99bc13138e6e8
+SIZE (gunicorn-20.1.0.tar.gz) = 370601