Commit 75b95505 authored by Rene Ladan's avatar Rene Ladan
Browse files

cleanup: Remove expired ports:

2021-10-31 devel/sdl_sge: Upstream no longer maintained
2021-12-31 net/appkonference: Outdated, depends on unsupported version of net/asterisk
2021-12-31 dns/bind911: End of life, please migrate to a newer version of BIND9
2021-12-31 net/zebra: Abandoned upstream, last release in 2005. Consider migrating to net/frr7 or net/bird2
2021-12-31 audio/osalp: Abandoned upstream, listed as beta and no new release since 2008
2021-12-31 games/stransball2: Depends on expired devel/sdl_sge
2021-12-31 devel/rubygem-ruby-sdl-ffi: Depends on expired devel/sdl_sge
2021-12-31 devel/rubygem-rubygame: Depends on expired devel/sdl_sge
2021-12-31 devel/ruby-sdl: Depends on expired devel/sdl_sge
2021-12-31 games/magicmaze: Depends on expired devel/sdl_sge
2021-12-31 games/trophy: Depends on expired devel/clanlib1
2021-12-31 devel/clanlib1: Older than expired and removed devel/clanlib
2021-12-31 www/py-django31: Upgrade to Django 3.2+. Mainstream support ended (April 6, 2021). Extended support ends December 2021. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-prometheus: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 databases/postgis24: Deprecated in favour of databases/postgis3x
2021-12-31 net-im/ekiga: Last release in 2013, not actively maintained
2021-12-31 sysutils/sample: abandoned upstream, incompatible with newer kernels
2021-12-31 www/mediawiki131: Upstream EOL
2021-12-31 www/py-dj31-django-mptt: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 net/py-flask-xml-rpc: No longer maintained upstream
2021-12-31 audio/libaacplus: Abandoned upstream, no new release since 2011
2021-12-31 security/obfsclient: https://github.com/Yawning/obfsclient/issues/37
2021-12-31 devel/eric6: Uses EOL Python 2.7 via www/py-qt5-webengine
2021-12-31 www/grafana: No longer maintained upstream, use www/grafana8
2021-12-31 www/py-dj31-django-auth-ldap: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-filter: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-drf-yasg: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-js-asset: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-timezone-field: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-tables2: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-taggit: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 graphics/librasterlite: Deprecated in favour of graphics/librasterlite2
2021-12-31 www/py-dj31-django-cacheops: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 net-mgmt/p0f2: newer version available in net-mgmt/p0f
2021-12-31 devel/libhash: Abandoned upstream
2021-12-31 www/py-dj31-django-debug-toolbar: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 www/py-dj31-django-cors-headers: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 audio/flake: Abandoned upstream, no new release since 2007
2021-12-31 audio/ifp-line: Abandoned upstream, no new release since 2005
2021-12-31 audio/libnjb: Abandoned upstream, no new release since 2011
2021-12-31 audio/lpac: Abandoned upstream in 2003
2021-12-31 multimedia/mmsclient: Abandoned upstream, Microsoft deprecated MMS in 2003
2021-12-31 www/plugger: Uses incompatible plugin interface NPAPI
2021-12-31 audio/mpiosh: Abandoned upstream, no new release since 2004
2021-12-31 audio/rplay: Abandoned upstream, no new releases since 1999
2021-12-31 audio/celt: Deprecated and considered obsolete by upstream in 2016 in favour of (lib)opus
2021-12-31 security/nacl: Unmaintained by upstream, use libsodium instead
2021-12-31 net-mgmt/unifi-poller: Now called unpoller by upstream
2021-12-31 lang/nml: Abandoned upstream, last release 2004-04-19
2021-12-31 audio/mp32ogg: Abandoned upstream and unfetchable from upstream
2021-12-31 net/libstorj: Deprecated in favour of net/storj due to v3 rearchitecture
2021-12-31 devel/yasm-devel: No need to keep the -devel version due to upstream inactivity
2021-12-31 www/py-dj31-django-redis: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 devel/py-dj31-django-rq: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
2021-12-31 graphics/libreatlas: Abandoned upstream, no new release since 2012
2021-12-31 www/py-dj31-djangorestframework: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
parent 6c401020
......@@ -16702,3 +16702,59 @@ x11-toolkits/rubygem-vte|x11-toolkits/rubygem-vte3|2021-12-21|Remove obsoleted p
sysutils/asmon||2021-12-27|Has expired: Fails to build on modern FreeBSD
java/intellij-rubymine|devel/rubymine|2021-12-31|Use better name and category
lang/python36||2021-12-31|Has expired: Upgrade to a newer Python version. 3.6 is in maintenance status and gets security fixes only. End-of-Life: 2021-12-23. See https://devguide.python.org/
devel/sdl_sge||2021-12-31|Has expired: Upstream no longer maintained
net/appkonference||2021-12-31|Has expired: Outdated, depends on unsupported version of net/asterisk
dns/bind911|dns/bind916|2021-12-31|Has expired: End of life, please migrate to a newer version of BIND9
net/zebra||2021-12-31|Has expired: Abandoned upstream, last release in 2005. Consider migrating to net/frr7 or net/bird2
audio/osalp||2021-12-31|Has expired: Abandoned upstream, listed as beta and no new release since 2008
games/stransball2||2021-12-31|Has expired: Depends on expired devel/sdl_sge
devel/rubygem-ruby-sdl-ffi||2021-12-31|Has expired: Depends on expired devel/sdl_sge
devel/rubygem-rubygame||2021-12-31|Has expired: Depends on expired devel/sdl_sge
devel/ruby-sdl||2021-12-31|Has expired: Depends on expired devel/sdl_sge
games/magicmaze||2021-12-31|Has expired: Depends on expired devel/sdl_sge
games/trophy||2021-12-31|Has expired: Depends on expired devel/clanlib1
devel/clanlib1||2021-12-31|Has expired: Older than expired and removed devel/clanlib
www/py-django31||2021-12-31|Has expired: Upgrade to Django 3.2+. Mainstream support ended (April 6, 2021). Extended support ends December 2021. See https://www.djangoproject.com/download/
www/py-dj31-django-prometheus||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
databases/postgis24||2021-12-31|Has expired: Deprecated in favour of databases/postgis3x
net-im/ekiga||2021-12-31|Has expired: Last release in 2013, not actively maintained
sysutils/sample||2021-12-31|Has expired: abandoned upstream, incompatible with newer kernels
www/mediawiki131||2021-12-31|Has expired: Upstream EOL
www/py-dj31-django-mptt||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
net/py-flask-xml-rpc||2021-12-31|Has expired: No longer maintained upstream
audio/libaacplus||2021-12-31|Has expired: Abandoned upstream, no new release since 2011
security/obfsclient||2021-12-31|Has expired: https://github.com/Yawning/obfsclient/issues/37
devel/eric6||2021-12-31|Has expired: Uses EOL Python 2.7 via www/py-qt5-webengine
www/grafana||2021-12-31|Has expired: No longer maintained upstream, use www/grafana8
www/py-dj31-django-auth-ldap||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-filter||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-drf-yasg||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-js-asset||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-timezone-field||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-tables2||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-taggit||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
graphics/librasterlite|graphics/librasterlite2|2021-12-31|Has expired: Deprecated in favour of graphics/librasterlite2
www/py-dj31-django-cacheops||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
net-mgmt/p0f2|net-mgmt/p0f|2021-12-31|Has expired: newer version available in net-mgmt/p0f
devel/libhash||2021-12-31|Has expired: Abandoned upstream
www/py-dj31-django-debug-toolbar||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
www/py-dj31-django-cors-headers||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
audio/flake||2021-12-31|Has expired: Abandoned upstream, no new release since 2007
audio/ifp-line||2021-12-31|Has expired: Abandoned upstream, no new release since 2005
audio/libnjb||2021-12-31|Has expired: Abandoned upstream, no new release since 2011
audio/lpac||2021-12-31|Has expired: Abandoned upstream in 2003
multimedia/mmsclient||2021-12-31|Has expired: Abandoned upstream, Microsoft deprecated MMS in 2003
www/plugger||2021-12-31|Has expired: Uses incompatible plugin interface NPAPI
audio/mpiosh||2021-12-31|Has expired: Abandoned upstream, no new release since 2004
audio/rplay||2021-12-31|Has expired: Abandoned upstream, no new releases since 1999
audio/celt||2021-12-31|Has expired: Deprecated and considered obsolete by upstream in 2016 in favour of (lib)opus
security/nacl|security/libsodium|2021-12-31|Has expired: Unmaintained by upstream, use libsodium instead
net-mgmt/unifi-poller||2021-12-31|Has expired: Now called unpoller by upstream
lang/nml||2021-12-31|Has expired: Abandoned upstream, last release 2004-04-19
audio/mp32ogg||2021-12-31|Has expired: Abandoned upstream and unfetchable from upstream
net/libstorj|net/storj|2021-12-31|Has expired: Deprecated in favour of net/storj due to v3 rearchitecture
devel/yasm-devel|devel/yasm|2021-12-31|Has expired: No need to keep the -devel version due to upstream inactivity
www/py-dj31-django-redis||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
devel/py-dj31-django-rq||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
graphics/libreatlas||2021-12-31|Has expired: Abandoned upstream, no new release since 2012
www/py-dj31-djangorestframework||2021-12-31|Has expired: Extended support of Django 3.1 ends December 2021, upgrade to the Django 3.2+ version of this port. See https://www.djangoproject.com/download/
......@@ -80,7 +80,6 @@
SUBDIR += cd2mp3
SUBDIR += cddb-bundle
SUBDIR += cdparanoia
SUBDIR += celt
SUBDIR += checkmate
SUBDIR += cheesecutter
SUBDIR += chordpack
......@@ -187,7 +186,6 @@
SUBDIR += flac
SUBDIR += flac123
SUBDIR += flacon
SUBDIR += flake
SUBDIR += flite
SUBDIR += fluid-soundfont
SUBDIR += fluida-lv2
......@@ -318,7 +316,6 @@
SUBDIR += id3ren
SUBDIR += id3tool
SUBDIR += id3v2
SUBDIR += ifp-line
SUBDIR += infamous-plugins-lv2
SUBDIR += inscore
SUBDIR += intersect-lv2
......@@ -353,7 +350,6 @@
SUBDIR += lenticular-lv2
SUBDIR += lewton
SUBDIR += liba52
SUBDIR += libaacplus
SUBDIR += libadplug
SUBDIR += libaiff
SUBDIR += libamrnb
......@@ -402,7 +398,6 @@
SUBDIR += libmusicbrainz5
SUBDIR += libmusicxml
SUBDIR += libmysofa
SUBDIR += libnjb
SUBDIR += libnoise
SUBDIR += libogg
SUBDIR += liboggz
......@@ -454,7 +449,6 @@
SUBDIR += logitechmediaserver-sqlplaylist
SUBDIR += logitechmediaserver-trackstat
SUBDIR += lollypop
SUBDIR += lpac
SUBDIR += lsp-plugins-lv2
SUBDIR += lua-mpd
SUBDIR += luppp
......@@ -497,7 +491,6 @@
SUBDIR += mous
SUBDIR += mp-player
SUBDIR += mp3-archive-tools
SUBDIR += mp32ogg
SUBDIR += mp3_check
SUBDIR += mp3asm
SUBDIR += mp3blaster
......@@ -525,7 +518,6 @@
SUBDIR += mpg123
SUBDIR += mpg123.el
SUBDIR += mpg321
SUBDIR += mpiosh
SUBDIR += mps
SUBDIR += mpz
SUBDIR += mumble
......@@ -564,7 +556,6 @@
SUBDIR += opusfile
SUBDIR += opustags
SUBDIR += orbit-lv2
SUBDIR += osalp
SUBDIR += osd-lyrics
SUBDIR += osdmixer
SUBDIR += oss
......@@ -704,7 +695,6 @@
SUBDIR += rnnoise
SUBDIR += rnnoise-nu
SUBDIR += rosegarden
SUBDIR += rplay
SUBDIR += rsynth
SUBDIR += rtaudio
SUBDIR += rtmidi
......
# Created by: Edward Tomasz Napierala <trasz@FreeBSD.org>
PORTNAME= celt
PORTVERSION= 0.11.3
PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://downloads.us.xiph.org/releases/celt/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= The CELT ultra-low delay audio codec
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Deprecated and considered obsolete by upstream in 2016 in favour of (lib)opus
EXPIRATION_DATE=2021-12-31
LIB_DEPENDS= libogg.so:audio/libogg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
USE_LDCONFIG= yes
USES= gmake libtool:keepla pathfix
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
SHA256 (celt-0.11.3.tar.gz) = 7e64815d4a8a009d0280ecd235ebd917da3abdcfd8f7d0812218c085f9480836
SIZE (celt-0.11.3.tar.gz) = 465020
The CELT codec is an experimental audio codec for use in low-delay
speech and audio communication. It's meant to close the gap between
Vorbis and Speex for applications where both high quality audio
and low delay are desired.
WWW: http://www.celt-codec.org/
bin/celtenc
bin/celtdec
include/celt/celt.h
include/celt/celt_types.h
include/celt/celt_header.h
lib/libcelt0.so.2.0.0
lib/libcelt0.so.2
lib/libcelt0.so
lib/libcelt0.la
lib/libcelt0.a
libdata/pkgconfig/celt.pc
# Created by: David Naylor <dbn@FreeBSD.org>
PORTNAME= flake
PORTVERSION= 0.11
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME:tl}-enc/${PORTNAME:tl}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FLAC audio encoder
LICENSE= LGPL21
DEPRECATED= Abandoned upstream, no new release since 2007
EXPIRATION_DATE=2021-12-31
CONFIGURE_ARGS+= --cc="${CC}"
HAS_CONFIGURE= yes
USES= gmake tar:bzip2
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/flake include/flake.h lib/libflake.a
.include <bsd.port.mk>
SHA256 (flake-0.11.tar.bz2) = 8dd249888005c2949cb4564f02b6badb34b2a0f408a7ec7ab01e11ceca1b7f19
SIZE (flake-0.11.tar.bz2) = 43319
The Flake encoder project was started as a way for the author to learn more
about lossless audio encoding. The author chose the FLAC format because it is
open and well-documented. Although the FLAC reference encoder is also free and
open-source, the author's goal was to implement the standard from scratch as an
independent project. Flake is licensed under the GNU LGPL.
Once Flake progressed to a usable state, the author submitted the encoder to be
included as part of FFmpeg. It was included and improved upon by other FFmpeg
developers. Since then, Ithe author has added more features to Flake and
improved the encoding speed. The author plan to add some of these features into
FFmpeg as the encoder progresses.
There are both benefits and drawbacks to using Flake as a FLAC encoder
alternative. In its current state, Flake gives, on average, slightly better
compression than the FLAC reference encoder and is about twice as fast.
However, it does not currently implement all the advanced features such as
tagging, cuesheets, 24-bit audio, embedded pictures, and ogg encapsulation.
The author hopes to add these to Flake in future releases.
WWW: http://flake-enc.sourceforge.net
# Created by: riggs
PORTNAME= ifp-line
PORTVERSION= 0.3
PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/ifp-driver/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Command line interface to iRiver music players
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Abandoned upstream, no new release since 2005
EXPIRATION_DATE=2021-12-31
USES= iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS= LIBUSB_LIBS=-lusb
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/ifp man/man1/ifp.1.gz
PORTDOCS= NEWS README TIPS nonroot.sh
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ifp ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ifp.1 ${STAGEDIR}${MANPREFIX}/man/man1
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
SHA256 (ifp-line-0.3.tar.gz) = 2d44807abbd5d2202d253b550b867dfa3776a71bf6d3f202b0f1254e66325257
SIZE (ifp-line-0.3.tar.gz) = 138272
--- configure.orig 2005-12-10 07:27:54 UTC
+++ configure
@@ -3860,281 +3860,6 @@ _ACEOF
-# Check whether --with-libusb-prefix or --without-libusb-prefix was given.
-if test "${with_libusb_prefix+set}" = set; then
- withval="$with_libusb_prefix"
- libusb_prefix="$withval"
-else
- libusb_prefix=""
-fi;
-
-# Check whether --with-libusb-exec-prefix or --without-libusb-exec-prefix was given.
-if test "${with_libusb_exec_prefix+set}" = set; then
- withval="$with_libusb_exec_prefix"
- libusb_exec_prefix="$withval"
-else
- libusb_exec_prefix=""
-fi;
-
- if test x$libusb_exec_prefix != x ; then
- libusb_config_args="$libusb_config_args --exec-prefix=$libusb_exec_prefix"
- if test x${LIBUSB_CONFIG+set} != xset ; then
- LIBUSB_CONFIG=$libusb_exec_prefix/bin/libusb-config
- fi
- fi
- if test x$libusb_prefix != x ; then
- libusb_config_args="$libusb_config_args --prefix=$libusb_prefix"
- if test x${LIBUSB_CONFIG+set} != xset ; then
- LIBUSB_CONFIG=$libusb_prefix/bin/libusb-config
- fi
- fi
-
- # Extract the first word of "libusb-config", so it can be a program name with args.
-set dummy libusb-config; ac_word=$2
-echo "$as_me:$LINENO: checking for $ac_word" >&5
-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-if test "${ac_cv_path_LIBUSB_CONFIG+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- case $LIBUSB_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_LIBUSB_CONFIG="$LIBUSB_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_LIBUSB_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-
- test -z "$ac_cv_path_LIBUSB_CONFIG" && ac_cv_path_LIBUSB_CONFIG="no"
- ;;
-esac
-fi
-LIBUSB_CONFIG=$ac_cv_path_LIBUSB_CONFIG
-
-if test -n "$LIBUSB_CONFIG"; then
- echo "$as_me:$LINENO: result: $LIBUSB_CONFIG" >&5
-echo "${ECHO_T}$LIBUSB_CONFIG" >&6
-else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
-fi
-
- min_libusb_version=0.1.7
- echo "$as_me:$LINENO: checking for libusb - version >= $min_libusb_version" >&5
-echo $ECHO_N "checking for libusb - version >= $min_libusb_version... $ECHO_C" >&6
- no_libusb=""
- if test "$LIBUSB_CONFIG" = "no" ; then
- no_libusb="yes"
- else
- LIBUSB_CFLAGS=`$LIBUSB_CONFIG $libusb_config_args --cflags`
- LIBUSB_LIBS=`$LIBUSB_CONFIG $libusb_config_args --libs`
-
- libusb_major_version=`$LIBUSB_CONFIG $libusb_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- libusb_minor_version=`$LIBUSB_CONFIG $libusb_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- libusb_micro_version=`$LIBUSB_CONFIG $libusb_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
- if test "x$enable_libusbtext" = "xyes" ; then
- ac_save_CFLAGS="$CFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $LIBUSB_CFLAGS"
- LIBS="$LIBS $LIBUSB_LIBS"
- rm -f conf.libusbtest
- if test "$cross_compiling" = yes; then
- echo $ac_n "cross compiling; assumed OK... $ac_c"
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <usb.h>
-
-char*
-my_strdup (char *str)
-{
- char *new_str;
-
- if (str)
- {
- new_str = malloc ((strlen (str) + 1) * sizeof(char));
- strcpy (new_str, str);
- }
- else
- new_str = NULL;
-
- return new_str;
-}
-
-int main ()
-{
- int major, minor, micro;
- char *tmp_version;
-
- system ("touch conf.libusbtest");
-
- /* HP/UX 9 (%@#!) writes to sscanf strings */
- tmp_version = my_strdup("$min_libusb_version");
- if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
- printf("%s, bad version string\n", "$min_libusb_version");
- exit(1);
- }
-
- if (($libusb_major_version > major) ||
- (($libusb_major_version == major) && ($libusb_minor_version > minor)) ||
- (($libusb_major_version == major) && ($libusb_minor_version == minor) &&
- ($libusb_micro_version >= micro)))
- {
- return 0;
- }
- else
- {
- printf("\n*** 'libusb-config --version' returned %d.%d, but the minimum version\n", $libusb_major_version, $libusb_minor_version);
- printf("*** of libusb required is %d.%d. If libusb-config is correct, then it is\n", major, minor);
- printf("*** best to upgrade to the required version.\n");
- printf("*** If libusb-config was wrong, set the environment variable LIBUSB_CONFIG\n");
- printf("*** to point to the correct copy of libusb-config, and remove the file\n");
- printf("*** config.cache before re-running configure\n");
- return 1;
- }
-}
-
-
-_ACEOF
-rm -f conftest$ac_exeext
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- :
-else
- echo "$as_me: program exited with status $ac_status" >&5
-echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-no_libusb=yes
-fi
-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi
- if test "x$no_libusb" = x ; then
- echo "$as_me:$LINENO: result: yes" >&5
-echo "${ECHO_T}yes" >&6
- :
- else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
- if test "$LIBUSB_CONFIG" = "no" ; then
- echo "*** The libusb-config script installed by libusb could not be found"
- echo "*** If libusb was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the LIBUSB_CONFIG environment variable to the"
- echo "*** full path to libusb-config."
- else
- if test -f conf.libusbtest ; then
- :
- else
- echo "*** Could not run libusb test program, checking why..."
- CFLAGS="$CFLAGS $LIBUSB_CFLAGS"
- LIBS="$LIBS $LIBUSB_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-#include <stdio.h>
-#include <usb.h>
-
-int
-main ()
-{
- return 0;
- ;
- return 0;
-}
-_ACEOF
-rm -f conftest.$ac_objext conftest$ac_exeext
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>conftest.er1
- ac_status=$?
- grep -v '^ *+' conftest.er1 >conftest.err
- rm -f conftest.er1
- cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
- { ac_try='test -z "$ac_c_werror_flag"
- || test ! -s conftest.err'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; } &&
- { ac_try='test -s conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- echo "*** The test program compiled, but did not run. This usually means"
- echo "*** that the run-time linker is not finding libusb or finding the wrong"
- echo "*** version of libusb. If it is not finding libusb, you'll need to set your"
- echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
- echo "*** to the installed location Also, make sure you have run ldconfig if that"
- echo "*** is required on your system"
- echo "***"
- echo "*** If you have an old version installed, it is best to remove it, although"
- echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
-else
- echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means libusb was incorrectly installed"
- echo "*** or that you have moved libusb since it was installed. In the latter case, you"
- echo "*** may want to edit the libusb-config script: $LIBUSB_CONFIG"
-fi
-rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi
- LIBUSB_CFLAGS=""
- LIBUSB_LIBS=""
- { { echo "$as_me:$LINENO: error: libusb is required." >&5
-echo "$as_me: error: libusb is required." >&2;}
- { (exit 1); exit 1; }; }
- fi
-
-
- rm -f conf.libusbtest
# Checks for header files.
ifp-line is a simple command-line tool to provide basic
functionality to manage files on iRiver music players
which are using the "manager firmware".
Using this tool, you can
o add/remove files on the player
o view information about the player, e.g. battery status
o flash your firmware using an .hex file
WWW: http://ifp-driver.sourceforge.net/
[
{ type: install
message: <<EOM
ifp directly accesses the usb/ugen devices via libusb. So
if you want to use this application as a non-root user, you
have to make sure that the corresponding device nodes
/dev/usb<somenumber> and /dev/ugen<somenumber> where
<somenumber> is dependent on your personal usb environment
are readable and writable by the user intended to use the
tool.
EOM
}
]
PORTNAME= libaacplus
PORTVERSION= 2.0.2
PORTREVISION= 9
CATEGORIES= audio
MASTER_SITES= http://tipok.org.ua/downloads/media/aacplus/libaacplus/ \
ftp://ftp.3gpp.org/Specs/archive/26_series/26.410/:site2 \
https://www.3gpp.org/ftp/Specs/archive/26_series/26.410/:site2
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${SRC26410}.zip:site2
MAINTAINER= takefu@airport.fm
COMMENT= HE-AAC+ Codec as Shared Library
LICENSE= libaacplus
LICENSE_NAME= 3GPP
LICENSE_TEXT= unclear legal status, probably need licenses from 3GPP, Via Licensing and Coding Technologies
LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
DEPRECATED= Abandoned upstream, no new release since 2011
EXPIRATION_DATE=2021-12-31
USES= autoreconf cpe pathfix pkgconfig libtool
USE_CSTD= gnu89
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
CPE_VENDOR= libaacplus_project
CONFLICTS= aacplusenc-0*
OPTIONS_DEFINE= FFTW3
OPTIONS_DEFAULT=FFTW3
FFTW3_DESC= Use FFTW3 library for performance