From 64a800d83df28391a75317302ea47f1210bb5596 Mon Sep 17 00:00:00 2001
From: Piotr Kubaj <pkubaj@FreeBSD.org>
Date: Thu, 15 Jul 2021 22:02:27 +0000
Subject: [PATCH] emulators/qemu: fix build on powerpc

Define _CALL_SYSV to fix error:
In file included from /wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/tcg.c:344:
/wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/ppc/tcg-target.inc.c:2290:3: error: "Unhandled abi"

Use gcc because clang hangs.
---
 emulators/qemu/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 17edfbdc8b39..4c341e7a33f0 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -123,7 +123,8 @@ PORTDOCS?=	docs index.html interop/.buildinfo interop/* qemu-ga-ref.html qemu-ga
 
 WITHOUT_CPU_CFLAGS=yes	#to avoid problems with register allocation
 CFLAGS:=	${CFLAGS:C/-fno-tree-vrp//}
-CFLAGS_amd64+=	-fPIC
+CFLAGS_amd64=	-fPIC
+CFLAGS_powerpc=	-D_CALL_SYSV
 CONFIGURE_ARGS?=--localstatedir=/var \
 		--extra-ldflags=-L${LOCALBASE}/lib --disable-libssh \
 		--prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
@@ -143,6 +144,7 @@ MAKE_ARGS+=	ARCH=x86_64
 
 .if ${ARCH} == "powerpc"
 MAKE_ARGS+=	ARCH=ppc
+USE_GCC=	yes
 .endif
 
 .if ${ARCH} == "powerpc64"
-- 
GitLab