diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 1397b5d62833ed09ac354051770af149cc990f58..48f0b8a231ba0aa5a2a5f5f650fd101a897b117c 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -1,8 +1,7 @@
 # Created by: Samy Al Bahra <samy@kerneled.org>
 
 PORTNAME=	libpci
-PORTVERSION=	3.7.0
-PORTREVISION=	1
+PORTVERSION=	3.8.0
 CATEGORIES=	devel
 MASTER_SITES=	KERNEL_ORG/software/utils/pciutils \
 		LOCAL/sunpoet
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index 8ff73b64ed0e5af7fb60efef24643ab52aaee0df..f18f6c0410410775a66c63b65a2599fd79134bc2 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1590926979
-SHA256 (pciutils-3.7.0.tar.xz) = 9d40b97be8b6a2cdf96aead5a61881d1f7e4e0da9544a9bac4fba1ae9dcd40eb
-SIZE (pciutils-3.7.0.tar.xz) = 371612
+TIMESTAMP = 1650970037
+SHA256 (pciutils-3.8.0.tar.xz) = 91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05
+SIZE (pciutils-3.8.0.tar.xz) = 410144
diff --git a/devel/libpci/files/patch-Makefile b/devel/libpci/files/patch-Makefile
index 11edc14d3e0748f5f73d2d61cbefe1216b9928cb..93d0e7538725e02c00cbbf46a54c31b5ffb1d382 100644
--- a/devel/libpci/files/patch-Makefile
+++ b/devel/libpci/files/patch-Makefile
@@ -1,22 +1,23 @@
---- Makefile.orig	2020-05-30 22:17:26 UTC
+--- Makefile.orig	2022-04-18 16:47:28 UTC
 +++ Makefile
 @@ -1,8 +1,8 @@
  # Makefile for The PCI Utilities
- # (c) 1998--2020 Martin Mares <mj@ucw.cz>
+ # (c) 1998--2022 Martin Mares <mj@ucw.cz>
  
 -OPT=-O2
 -CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
-+# OPT=-O2
++#OPT=-O2
 +CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
  
- VERSION=3.7.0
- DATE=2020-05-31
-@@ -32,10 +32,10 @@ HWDB=
+ VERSION=3.8.0
+ DATE=2022-04-18
+@@ -32,11 +32,11 @@ HWDB=
  ABI_VERSION=.3
  
  # Installation directories
 -PREFIX=/usr/local
-+# PREFIX=/usr/local
++#PREFIX=/usr/local
+ BINDIR=$(PREFIX)/bin
  SBINDIR=$(PREFIX)/sbin
  SHAREDIR=$(PREFIX)/share
 -IDSDIR=$(SHAREDIR)
@@ -24,12 +25,20 @@
  MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
  INCDIR=$(PREFIX)/include
  LIBDIR=$(PREFIX)/lib
-@@ -45,7 +45,7 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
+@@ -46,11 +46,11 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
  INSTALL=install
  DIRINSTALL=install -d
  STRIP=-s
+-ifdef CROSS_COMPILE
 -CC=$(CROSS_COMPILE)gcc
-+# CC=$(CROSS_COMPILE)gcc
+-else
+-CC=cc
+-endif
++#ifdef CROSS_COMPILE
++#CC=$(CROSS_COMPILE)gcc
++#else
++#CC=cc
++#endif
  AR=$(CROSS_COMPILE)ar
  RANLIB=$(CROSS_COMPILE)ranlib