From 4ee4d8d1d3e9d19b9b99d78dbee3f09ebccf2444 Mon Sep 17 00:00:00 2001
From: VVD <vvd@unislabs.com>
Date: Tue, 19 Jul 2022 07:51:39 +0200
Subject: [PATCH] games/jinput: Fix build

Fix build by removing examples from the module list.
VDD takes over maintainership.

PR:	264752
Reported by:	vvd@unislabs.com
Approved by:	voidanix@420blaze.it (maintainer, timeout > 2 weeks)
---
 games/jinput/Makefile | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/games/jinput/Makefile b/games/jinput/Makefile
index f917f2d94a45..ef74a1afd763 100644
--- a/games/jinput/Makefile
+++ b/games/jinput/Makefile
@@ -8,8 +8,6 @@ COMMENT=	Java Game Controller API
 
 LICENSE=	BSD2CLAUSE
 
-BROKEN=		does not build: .../input/example/ReadAllEvents.java:[5,28] cannot find symbol
-
 BUILD_DEPENDS=	${JAVAJARDIR}/jutils/jutils.jar:games/jutils \
 		mvn:devel/maven
 RUN_DEPENDS=	${JAVAJARDIR}/jutils/jutils.jar:games/jutils
@@ -21,14 +19,15 @@ GL_COMMIT=	bf22dd975bbba31f01895332255b63df376894e6
 
 USE_JAVA=	8+
 
-PLIST_FILES=	${JAVAJARDIR}/${PORTNAME}/${PORTNAME}.jar
 PLIST_DIRS=	${JAVAJARDIR}/${PORTNAME}
+PLIST_FILES=	${JAVAJARDIR}/${PORTNAME}/${PORTNAME}.jar
 
 MAVEN_ARGS=	-Dmaven.antrun.skip -Dmaven.javadoc.skip -Dmaven.source.skip -Dmaven.test.skip -DskipTests -DskipITs
 MAVEN_REPO=	-Dmaven.repo.local=${WRKSRC}/repository
 
 pre-build:
 	${CP} ${JAVAJARDIR}/jutils/jutils.jar ${WRKSRC}/repository/net/java/jutils/jutils/1/jutils-1.jar
+	${SED} -i -e '/example/d' ${WRKSRC}/pom.xml # example/ReadAllEvents.java:[5,28] cannot find symbol ...
 
 do-build:
 	cd ${WRKSRC}; \
-- 
GitLab