diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 5939c5a318d7e6649d213b89eeed7baa7220fc82..a0ae512351da4584a1db0eb8583b19693b3d8d3f 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -40,7 +40,7 @@ GMP_DESC=		Use GNU Multi-precision Library from Ports
 PROFILE_DESC=		Add support for performance profiling
 
 BOOT_CONFIGURE_ENV=	GHC=${LOCALBASE}/bin/ghc
-BOOT_CONFIGURE_ENV_OFF=	GHC=${BOOT_GHC}
+BOOT_CONFIGURE_ENV_OFF=	GHC=${BOOT_GHC} LLC=llc${BOOT_LLVM_VERSION} OPT=opt${BOOT_LLVM_VERSION}
 
 DOCS_BUILD_DEPENDS=	sphinx-build:textproc/py-sphinx
 DOCS_VARS=		enable_docs=YES