diff --git a/devel/Makefile b/devel/Makefile
index 918d5064766603b53de67e9e5d6259d1d3c02c4e..76657e5968a6ee31a0f28becdd9cc1f654341516 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7052,6 +7052,7 @@
     SUBDIR += rubygem-strings
     SUBDIR += rubygem-strings-ansi
     SUBDIR += rubygem-strong_migrations
+    SUBDIR += rubygem-strong_migrations61
     SUBDIR += rubygem-strptime
     SUBDIR += rubygem-strscan
     SUBDIR += rubygem-structured_warnings
diff --git a/devel/rubygem-strong_migrations61/Makefile b/devel/rubygem-strong_migrations61/Makefile
new file mode 100644
index 0000000000000000000000000000000000000000..9666d2b69743d34f42aecdc9501e09625c33b0f4
--- /dev/null
+++ b/devel/rubygem-strong_migrations61/Makefile
@@ -0,0 +1,21 @@
+PORTNAME=	strong_migrations
+PORTVERSION=	1.4.0
+CATEGORIES=	devel rubygems
+MASTER_SITES=	RG
+PKGNAMESUFFIX=	61
+
+MAINTAINER=	bofh@FreeBSD.org
+COMMENT=	Catch unsafe migrations at dev time
+WWW=		https://github.com/ankane/strong_migrations
+
+LICENSE=	MIT
+LICENSE_FILE=	${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS=	rubygem-activerecord61>=5.2:databases/rubygem-activerecord61
+
+USES=		gem
+USE_RUBY=	yes
+
+NO_ARCH=	yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-strong_migrations61/distinfo b/devel/rubygem-strong_migrations61/distinfo
new file mode 100644
index 0000000000000000000000000000000000000000..fa260219a7fc7eb8928c6bda68d3542fdc64cf6e
--- /dev/null
+++ b/devel/rubygem-strong_migrations61/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668890435
+SHA256 (rubygem/strong_migrations-1.4.0.gem) = 975bb62f80b787449795bc90e4394181ff11e47c4e313268b3df46591514b277
+SIZE (rubygem/strong_migrations-1.4.0.gem) = 27136
diff --git a/devel/rubygem-strong_migrations61/pkg-descr b/devel/rubygem-strong_migrations61/pkg-descr
new file mode 100644
index 0000000000000000000000000000000000000000..06ca9058210780b52f2ac448579713c08388a858
--- /dev/null
+++ b/devel/rubygem-strong_migrations61/pkg-descr
@@ -0,0 +1,8 @@
+This gem catches the following unsafe migrations:
+- adding a column with a non-null default value to an existing table
+- changing the type of a column
+- renaming a table
+- renaming a column
+- removing a column
+- adding an index non-concurrently (Postgres only)
+- adding a json column to an existing table (Postgres only)