diff --git a/databases/Makefile b/databases/Makefile
index d8c84dafdb60c133839d16037e3249840e9499a7..371cf14a59cb606aeff1e70b852954c708f5b919 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -914,6 +914,7 @@
     SUBDIR += rubygem-activerecord52
     SUBDIR += rubygem-activerecord60
     SUBDIR += rubygem-activerecord61
+    SUBDIR += rubygem-activerecord70
     SUBDIR += rubygem-after_commit_queue
     SUBDIR += rubygem-amalgalite
     SUBDIR += rubygem-arel
diff --git a/databases/rubygem-activerecord70/Makefile b/databases/rubygem-activerecord70/Makefile
new file mode 100644
index 0000000000000000000000000000000000000000..8b497a61077c4cdfef82f17d70417e0f65abadcf
--- /dev/null
+++ b/databases/rubygem-activerecord70/Makefile
@@ -0,0 +1,23 @@
+PORTNAME=	activerecord
+PORTVERSION=	7.0.0
+CATEGORIES=	databases rubygems
+MASTER_SITES=	RG
+PKGNAMESUFFIX=	70
+
+MAINTAINER=	sunpoet@FreeBSD.org
+COMMENT=	Object-relational mapping layer for Rails MVC Framework
+
+LICENSE=	MIT
+LICENSE_FILE=	${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS=	rubygem-activemodel70>=${PORTVERSION}:databases/rubygem-activemodel70 \
+		rubygem-activesupport70>=${PORTVERSION}:devel/rubygem-activesupport70
+
+USES=		gem
+USE_RUBY=	yes
+
+NO_ARCH=	yes
+
+PORTSCOUT=	limit:^7\.0\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord70/distinfo b/databases/rubygem-activerecord70/distinfo
new file mode 100644
index 0000000000000000000000000000000000000000..2acb03304066080cd0dafc4e85a7351172c26c0c
--- /dev/null
+++ b/databases/rubygem-activerecord70/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1641045756
+SHA256 (rubygem/activerecord-7.0.0.gem) = bda71d8c2679ec2fde2ab1b5d27e16872ca9bf60a660c57ee7e76b98a9a3850f
+SIZE (rubygem/activerecord-7.0.0.gem) = 470528
diff --git a/databases/rubygem-activerecord70/pkg-descr b/databases/rubygem-activerecord70/pkg-descr
new file mode 100644
index 0000000000000000000000000000000000000000..0688737cb23fec13eb84894e3a0a32d5450658ef
--- /dev/null
+++ b/databases/rubygem-activerecord70/pkg-descr
@@ -0,0 +1,14 @@
+Active Record connects classes to relational database tables to establish an
+almost zero-configuration persistence layer for applications. The library
+provides a base class that, when subclassed, sets up a mapping between the new
+class and an existing table in the database. In the context of an application,
+these classes are commonly referred to as models. Models can also be connected
+to other models; this is done by defining associations.
+
+Active Record relies heavily on naming in that it uses class and association
+names to establish mappings between respective database tables and foreign key
+columns. Although these mappings can be defined explicitly, it's recommended to
+follow naming conventions, especially when getting started with the library.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/main/activerecord