2. Change some names so that the interface makes sense with the Galilean group action (which is not based on the Lie basis directly)
I need a name for the core manifold data: point (but that's used for the point that the user moves), data (allright but generic), manifold point (verbose), action data, manifold state, view state, orientation (not bad, orientation = position + angle which is what it is), configuration
Actually, we can reduce the importance of the notion of a point.
A point gets meaning only when it is printed.
Currently, I store a bunch of points on a 2D surface as constrained 3D points.
So I do save points.
So I guess points are kind of important.
I could also save directly the action data for each point, but that would take more space.
So then what are the methods I need:
So then what are the methods I need:
*`action_data_to_center()` returns the center point associated with the current action data
*`action_data_to_center()` returns the center point associated with the current action data
*`action_data_to_lie_basis()` returns the lie algebra basis associated with the current action data
*`action_data_to_lie_basis()` returns the lie algebra basis associated with the current action data
*`action_data_to_tangents(lie basis)` returns the 3 tangents (or 2, since one is null) for each lie algebra. The tangents are in pebble space and belong to the tangent space of the center.
*`act_on_data(lie vector)` updates
*`act_on_data(lie vector)` updates
*`view_pebbles(array of 3D points all lying on a 2D manifold)`
*`view_pebbles(array of 3D points all lying on the pebble space which is a 2D manifold)`
*`act_on_pebbles(lie vector)`
*`act_on_pebbles(lie vector)`
*`killing(lie vector, lie vector)`
*`killing(lie vector, lie vector)`
*`lie_bracket(lie vector, lie vector)`
*`lie_bracket(lie vector, lie vector)`
...
@@ -46,6 +33,20 @@ Should I move to typescript?
...
@@ -46,6 +33,20 @@ Should I move to typescript?
I don't think the class should hold the action data.
I don't think the class should hold the action data.
Because it contains more information than just action data, it is more general.
Because it contains more information than just action data, it is more general.
Need to:
1. Identify the currently used methods
2. Change some names so that the interface makes sense with the Galilean group action (which is not based on the Lie basis directly)
I need a name for the core manifold data: point (but that's used for the point that the user moves), data (allright but generic), manifold point (verbose), action data, manifold state, view state, orientation (not bad, orientation = position + angle which is what it is), configuration
Actually, we can reduce the importance of the notion of a point.
A point gets meaning only when it is printed.
Currently, I store a bunch of points on a 2D surface as constrained 3D points.
So I do save points.
So I guess points are kind of important.
I could also save directly the action data for each point, but that would take more space.