GitLab Commit is coming up on August 3-4. Learn how to innovate together using GitLab, the DevOps platform. Register for free: gitlabcommitvirtual2021.com

Tags give the ability to mark specific points in history as being important
  • 0.2.0   After the Election #11, this is the end of the Beta Phase. You can now view posts without being logged in, although they cannot register themselves without the Admin's approval.
  • 0.1.0   Anforderungen an DemNet Version 0.1.0 Inhalt 1. Benutzeranforderungen 2. Entwickleranforderungen 3. Administrationsanforderungen 4. Erklärung zur Versionsnummer 5. Übersicht über andere Anforderungsdefinitionen und deren Versionsnummern =============== Benutzeranforderungen Für jeden Benutzer muss DemNet 0.1.0 folgende Anforderungen erfüllen. 1. Erhältlichkeit Die Benutzer müssen die Funktionalitäten der Seite im Testzeitraum von jedem mit dem Internet verbundenen PC erreichen können. 2. Sicherheit Jeder Benutzer ist der einzige, der sich unter seinem Namen einloggen kann. Er ist der einzige, der Nachrichten in seinem Namen Nachrichten schicken kann und der einzige der in seinem Namen wählen kann. Es ist nicht wichtig, wenn diese Regeln für den Administrator nicht immer technisch durchgesetzt werden können. 3. Einflussnahme Jeder Benutzer muss wählen können und die Ergebnisse der Wahl umgesetzt werden. =============== Entwickleranforderungen Für jeden Entwickler muss DemNet 0.1.0 folgende Anforderungen erfüllen. 1. Jeder muss ein Git- Repositories der gesamten Codebase einsehen können. 2. Jeder muss die Codebase mit Git Funktionen (clone, add, commit, push, pull) bearbeiten können. 3. Jeder muss seine Veränderungen zu genannten Problemen vorschlagen und in die Mainline aufgenommen werden können. =============== Administratoranforderungen Es gibt zu jeder Zeit drei Administratoren. Für jeden dieser Administratoren muss DemNet 0.1.0 folgende Anforderungen erfüllen. 1. Zugriff auf den Server von einem mit dem Internet verbundenen Gerät durch SSH. 2. Die Möglichkeit den Server zu stoppen und zu starten. 3. Das Einsetzen von Patches zu DemNet, im Falle eines Sicherheitsrisikos. Diese müssen jedoch daraufhin durch eine Wahl angenommen werden. 4. Die Möglichkeit einen der Administratoren zu sperren, mit einer 2/3 Mehrheit. =============== Versionsnummerndeklaration Dies sind die Anforderungen für die Alpha Version von DemNet. Eine Version von DemNet, die diese Anforderungen erfüllt hat die Versionsnummer 0.1.0 oder höher. =============== Übersicht über andere Anforderungsdefinitionen Die Anforderungen für die Versionen: 0.2.0 - Betaversion 0.3.0 1.0.0 - Releaseversion 2.0.0 müssen noch erstellt werden. Stand 17.03.2020 Joris Gutjahr
    Release 0.1.0