• Daniel Playle's avatar
    Restrict version of pylint · 4f168b9b
    Daniel Playle authored
    pylint >2 is not compatible with pytest_pylint in its current form. As
    such, allowing any version of pylint for testing results in a failure.
    
    This commit restricts down the allowable versions of pylint to those
    that are both compatible with pytest_pylint, and also offer the feature
    set that we require.
    
    See #427 for further
    details.
    4f168b9b
Name
Last commit
Last update
.gitlab Loading commit data...
buildstream Loading commit data...
contrib Loading commit data...
doc Loading commit data...
man Loading commit data...
tests Loading commit data...
.coveragerc Loading commit data...
.gitattributes Loading commit data...
.gitignore Loading commit data...
.gitlab-ci.yml Loading commit data...
.pylintrc Loading commit data...
BuildStream.doap Loading commit data...
COPYING Loading commit data...
HACKING.rst Loading commit data...
MAINTAINERS Loading commit data...
MANIFEST.in Loading commit data...
NEWS Loading commit data...
README.rst Loading commit data...
conftest.py Loading commit data...
setup.cfg Loading commit data...
setup.py Loading commit data...
versioneer.py Loading commit data...