Commit 4348292b authored by Tino Goratsch's avatar Tino Goratsch

- dropped the support for HHVM

- adjusted the Travis-CI configuration to reflect the recent changes regarding the supported PHP versions
parent 0499652e
......@@ -3,17 +3,13 @@ sudo: required
dist: trusty
group: edge
php:
- 5.6
- 7.0.8
- 7.1
- nightly
- hhvm
matrix:
fast_finish: true
allow_failures:
- php: nightly
- php: hhvm
addons:
code_climate:
......@@ -41,25 +37,25 @@ deploy:
skip_cleanup: true
on:
tags: true
condition: "$TRAVIS_PHP_VERSION = 7.0*"
condition: "$TRAVIS_PHP_VERSION = 7.1*"
- provider: script
script: ./build/travis/update_module_repositories.sh ${TRAVIS_TAG}
skip_cleanup: true
on:
tags: true
condition: "$TRAVIS_PHP_VERSION = 7.0*"
condition: "$TRAVIS_PHP_VERSION = 7.1*"
- provider: script
script: ./build/travis/update_version_check.sh ${TRAVIS_TAG}
skip_cleanup: true
on:
tags: true
condition: "$TRAVIS_PHP_VERSION = 7.0*"
condition: "$TRAVIS_PHP_VERSION = 7.1*"
- provider: script
script: ./build/travis/generate_api_docs.sh
skip_cleanup: true
on:
branch: master
condition: "$TRAVIS_PHP_VERSION = 7.0*"
condition: "$TRAVIS_PHP_VERSION = 7.1*"
cache:
directories:
......
......@@ -10,6 +10,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Changed
- Dropped the support for PHP 5.6. The minimum required PHP version is 7.1 now
- Dropped the support for HHVM
- Updated Symfony to version 3.3
- Updated the bundled JavaScript packages to their current versions
......
......@@ -2,7 +2,7 @@
TRAVIS_PHP_VERSION=$1
if [[ ${TRAVIS_PHP_VERSION} = 7.0* ]]
if [[ ${TRAVIS_PHP_VERSION} = 7.1* ]]
then
if [ ! -f release.zip ]
then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment