Hurray: Monocle and Circe-Optics for Scala 2.13!

Update dependencies and resurrect ReportApiTest from
Scala-2.12-only-land back to 2.12,2.13 crossbuild.

Change coverage target to Scala 2.13.

* Dependencies
** cats: 2.0.0-RC1
** circe: 0.12.0-RC1
** circe-optics: 0.12.0-RC1

https://github.com/circe/circe-optics/issues/29
https://github.com/julien-truffaut/Monocle/issues/677

Signed-off-by: 35V LG84 <35vlg84-x4e6b92@e257.fi>
3 jobs for wip/scala-2.13 in 14 minutes and 27 seconds
Status Job ID Name Coverage
  Test
passed #268934842
codecov

00:11:01

99.8%
passed #268934840
test·jdk11

00:13:30

passed #268934841
test·jdk8

00:14:27